No 5.1 sound in Vero 4k with Xonar U5

Hello,

I have just installed the new sound card, initialy Vero 4k recognice U5 without problem but only works with 2.0 configuration. I´m ussing the analogic connection with a 5.1 analogic device

If I select usb 1.0 in xonar U5, I have two options Analogic and Spdif -> no sound in all of them
If I select usb 2.0, I have three options
Analogic + 5.1 configuration -> 2.0 sound
Analogic 2.1 + 5.1 configuration -> Thunderous sound
SPdif -> No sound

I have be able to see this post.


It was solved for Spdif output but no for Analogic output.

Thanks in advance.

Hi,

to get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you with this device.

OSMC skin screenshot:

Here´s:

https://paste.osmc.tv/jucakuponu

Can you confirm which mode the U5 was switched to when you took those logs? USB1 or 2?

Can you set it to USB2, get a commandline and post here the output of:

aplay -l and
aplay -L

The output from the second command is quite long. You could use
aplay -L | grab-logs and post here the url you get.

Hi grahamh, sorry it seems that initialy I aswered you with mail instead reply in the forum.

I got the logs from USB2

I have also run aplay -l command from USB2
osmc@osmc:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: AMLM8AUDIO [AML-M8AUDIO], device 0: I2S.39 T9015-audio-hifi-0
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: AMLM8AUDIO [AML-M8AUDIO], device 1: SPDIF.40 dit-hifi-1
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: AMLM8AUDIO [AML-M8AUDIO], device 2: PCM.41 pcm2bt-pcm-2
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: U5 [ASUS XONAR U5], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: U5 [ASUS XONAR U5], device 1: USB Audio [USB Audio #1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: U5 [ASUS XONAR U5], device 2: USB Audio [USB Audio #2]
Subdevices: 1/1
Subdevice #0: subdevice #0

And aplay -L from USB2

https://paste.osmc.tv/aviluzoqep

Sorry the grab-logs is incorrect, this is the real out.
osmc@osmc:~$ aplay -L
null
Discard all samples (playback) or generate zero samples (capture)
default:CARD=AMLM8AUDIO
AML-M8AUDIO,
Default Audio Device
sysdefault:CARD=AMLM8AUDIO
AML-M8AUDIO,
Default Audio Device
hdmi:CARD=AMLM8AUDIO,DEV=0
AML-M8AUDIO,
HDMI Audio Output
dmix:CARD=AMLM8AUDIO,DEV=0
AML-M8AUDIO,
Direct sample mixing device
dmix:CARD=AMLM8AUDIO,DEV=1
AML-M8AUDIO,
Direct sample mixing device
dmix:CARD=AMLM8AUDIO,DEV=2
AML-M8AUDIO,
Direct sample mixing device
dsnoop:CARD=AMLM8AUDIO,DEV=0
AML-M8AUDIO,
Direct sample snooping device
dsnoop:CARD=AMLM8AUDIO,DEV=1
AML-M8AUDIO,
Direct sample snooping device
dsnoop:CARD=AMLM8AUDIO,DEV=2
AML-M8AUDIO,
Direct sample snooping device
hw:CARD=AMLM8AUDIO,DEV=0
AML-M8AUDIO,
Direct hardware device without any conversions
hw:CARD=AMLM8AUDIO,DEV=1
AML-M8AUDIO,
Direct hardware device without any conversions
hw:CARD=AMLM8AUDIO,DEV=2
AML-M8AUDIO,
Direct hardware device without any conversions
plughw:CARD=AMLM8AUDIO,DEV=0
AML-M8AUDIO,
Hardware device with all software conversions
plughw:CARD=AMLM8AUDIO,DEV=1
AML-M8AUDIO,
Hardware device with all software conversions
plughw:CARD=AMLM8AUDIO,DEV=2
AML-M8AUDIO,
Hardware device with all software conversions
default:CARD=U5
ASUS XONAR U5, USB Audio
Default Audio Device
sysdefault:CARD=U5
ASUS XONAR U5, USB Audio
Default Audio Device
front:CARD=U5,DEV=0
ASUS XONAR U5, USB Audio
Front speakers
surround21:CARD=U5,DEV=0
ASUS XONAR U5, USB Audio
2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=U5,DEV=0
ASUS XONAR U5, USB Audio
4.0 Surround output to Front and Rear speakers
surround41:CARD=U5,DEV=0
ASUS XONAR U5, USB Audio
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=U5,DEV=0
ASUS XONAR U5, USB Audio
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=U5,DEV=0
ASUS XONAR U5, USB Audio
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=U5,DEV=0
ASUS XONAR U5, USB Audio
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=U5,DEV=0
ASUS XONAR U5, USB Audio
IEC958 (S/PDIF) Digital Audio Output
dmix:CARD=U5,DEV=0
ASUS XONAR U5, USB Audio
Direct sample mixing device
dmix:CARD=U5,DEV=1
ASUS XONAR U5, USB Audio #1
Direct sample mixing device
dmix:CARD=U5,DEV=2
ASUS XONAR U5, USB Audio #2
Direct sample mixing device
dsnoop:CARD=U5,DEV=0
ASUS XONAR U5, USB Audio
Direct sample snooping device
dsnoop:CARD=U5,DEV=1
ASUS XONAR U5, USB Audio #1
Direct sample snooping device
dsnoop:CARD=U5,DEV=2
ASUS XONAR U5, USB Audio #2
Direct sample snooping device
hw:CARD=U5,DEV=0
ASUS XONAR U5, USB Audio
Direct hardware device without any conversions
hw:CARD=U5,DEV=1
ASUS XONAR U5, USB Audio #1
Direct hardware device without any conversions
hw:CARD=U5,DEV=2
ASUS XONAR U5, USB Audio #2
Direct hardware device without any conversions
plughw:CARD=U5,DEV=0
ASUS XONAR U5, USB Audio
Hardware device with all software conversions
plughw:CARD=U5,DEV=1
ASUS XONAR U5, USB Audio #1
Hardware device with all software conversions
plughw:CARD=U5,DEV=2
ASUS XONAR U5, USB Audio #2
Hardware device with all software conversions

Sorry , should’ve been paste-log or something.

My own USB soundcard is showing some of the same symptoms in the logs but does, in fact, work with all multi-channel layouts with an even number of channels (2.0, 4.0, 5.1, 7.1 but not 2.1 or 5.0). That’s if I pick the @ version of the device, not the Surround21 one (which, as you say, sucks).

Not sure what’s going on but I’ll try and fix mine up first. I’ve never understood why Kodi picks up that Surround21 device specifically.

@mbailen Could you let me know what happens if you type this:

speaker-test -t wav -c6 -l2 -Dsurround51:U5

You may have to sudo apt-get install alsa-utils to get speaker-test.

osmc@osmc:~$ speaker-test -t wav -c6 -l2 -Dsurround51:U5

speaker-test 1.1.3

Playback device is surround51:U5
Stream parameters are 48000Hz, S16_LE, 6 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 12 to 87381
Period size range from 6 to 43690
Using max buffer size 87380
Periods = 4
was set period_size = 21845
was set buffer_size = 87380
0 - Front Left
1 - Front Right
2 - Unknown
3 - Unknown
4 - Unknown
5 - Unknown
Time per period = 6.900254
0 - Front Left
1 - Front Right
2 - Unknown
3 - Unknown
4 - Unknown
5 - Unknown
Time per period = 8.663343

Thanks. Sorry I didn’t get a notification. I assume you got ‘Front Left’ and ‘Front Right’ from the correct speakers but nothing else heard?

Can you also post the output of
amixer -c1 contents

I´m so sorry I didn’t know how work speaker-test utility and I had swicht off my amp :sweat: the news are that despite of the command output the 6 speaker sound correctly.

This is the amixer output:

osmc@osmc:~$ amixer -c1 contents
numid=18,iface=MIXER,name=‘PCM Capture Source’
; type=ENUMERATED,access=rw------,values=1,items=2
; Item #0 ‘Unit 23’
; Item #1 ‘Unit 23’
amixer: Control hw:1 element read error: Broken pipe

numid=13,iface=MIXER,name=‘PCM Capture Switch’
; type=BOOLEAN,access=rw------,values=1
: values=on
numid=16,iface=MIXER,name=‘PCM Capture Switch’,index=1
; type=BOOLEAN,access=rw------,values=1
: values=on
numid=14,iface=MIXER,name=‘PCM Capture Volume’
; type=INTEGER,access=rw—R–,values=2,min=0,max=28,step=0
: values=16,16
| dBminmax-min=-16.00dB,max=12.00dB
numid=17,iface=MIXER,name=‘PCM Capture Volume’,index=1
; type=INTEGER,access=rw—R–,values=2,min=0,max=28,step=0
: values=16,16
| dBminmax-min=-16.00dB,max=12.00dB
numid=12,iface=MIXER,name=‘IEC958 In Playback Switch’
; type=BOOLEAN,access=rw------,values=1
: values=on
numid=15,iface=MIXER,name=‘Auto Gain Control’
; type=BOOLEAN,access=rw------,values=1
: values=on
numid=11,iface=MIXER,name=‘Input Gain Pad Control’
; type=BOOLEAN,access=rw------,values=1
: values=off
numid=5,iface=MIXER,name=‘Speaker Playback Switch’
; type=BOOLEAN,access=rw------,values=1
: values=on
numid=7,iface=MIXER,name=‘Speaker Playback Switch’,index=1
; type=BOOLEAN,access=rw------,values=1
: values=off
numid=9,iface=MIXER,name=‘Speaker Playback Switch’,index=2
; type=BOOLEAN,access=rw------,values=1
: values=on
numid=6,iface=MIXER,name=‘Speaker Playback Volume’
; type=INTEGER,access=rw—R–,values=2,min=0,max=31,step=0
: values=9,9
| dBminmax-min=-34.50dB,max=12.00dB
numid=8,iface=MIXER,name=‘Speaker Playback Volume’,index=1
; type=INTEGER,access=rw—R–,values=2,min=0,max=31,step=0
: values=23,23
| dBminmax-min=-34.50dB,max=12.00dB
numid=10,iface=MIXER,name=‘Speaker Playback Volume’,index=2
; type=INTEGER,access=rw—R–,values=6,min=0,max=55,step=0
: values=55,55,55,55,55,55
| dBminmax-min=-55.00dB,max=0.00dB
numid=1,iface=PCM,name=‘Playback Channel Map’
; type=INTEGER,access=r----R–,values=2,min=0,max=36,step=0
: values=0,0
| container
| chmap-fixed=FL,FR
| chmap-fixed=FL,FR,RL,RR
| chmap-fixed=FL,FR,FC,LFE,RL,RR

numid=4,iface=PCM,name=‘Capture Channel Map’,device=1
; type=INTEGER,access=r----R–,values=2,min=0,max=36,step=0
: values=0,0
| container
| chmap-fixed=FL,FR

numid=2,iface=PCM,name=‘Playback Channel Map’,device=1
; type=INTEGER,access=r----R–,values=2,min=0,max=36,step=0
: values=0,0
| container
| chmap-fixed=FL,FR

numid=3,iface=PCM,name=‘Playback Channel Map’,device=2
; type=INTEGER,access=r----R–,values=2,min=0,max=36,step=0
: values=0,0
| container
| chmap-fixed=FL,FR

Excellent. So you are getting all the channels with speaker-test but it’s just Kodi that’s not working.

I think I know why and I’ll see if I can fix it.

I think I may have a fix for USB audio channels. If you can test it for me it would be really good. You would just need to change the file kodi.bin, like this:

cd ~
sudo systemctl stop mediacenter
wget https://collab.osmc.tv/s/wuEc4wCKEGGS3nD/download -O kodi.bin
sudo cp /usr/lib/kodi/kodi.bin /usr/lib/kodi/kodi.bin.bak
sudo cp kodi.bin /usr/lib/kodi/
sudo systemctl start mediacenter

Can you test it with debug logging and also turn on ‘Component-specific logging’ for the audio component, play some multi-channel audio, let me know if it works and post the logs?

If anything goes wrong, you can revert with

cd ~
sudo systemctl stop mediacenter
sudo cp /usr/lib/kodi/kodi.bin.bak /usr/lib/kodi/kodi.bin
sudo systemctl start mediacenter

TIA

Thanks Grahamh but there was no luck.
Now I have two option for kodi audio ouput, Analogue and spdif. I choosed Analogue, but I only got sound from front speakers.

Logs:
https://paste.osmc.tv/tikolisaxa
aplay -l -> same output
aplay -L-> same output
speaker-test -t wav -c6 -l2 -Dsurround51:U5 -> same output

Thanks for testing. That log is very useful.

Ok, if this doesn’t fix it I will be annoyed:

cd ~
sudo systemctl stop mediacenter
wget https://collab.osmc.tv/s/c74M2W2Lucut6ZS/download -O kodi.bin
sudo cp /usr/lib/kodi/kodi.bin /usr/lib/kodi/kodi.bin.bak2
sudo cp kodi.bin /usr/lib/kodi/
sudo systemctl start mediacenter

Then is annoyed :disappointed:.
If I try to playback a 5.1 file the system hangs inmidiatly, when I activate the logs, the system was capable tu playback the file, but with 2.0 sound then I pushed “stop” and the system hungs too.

Logs:
https://paste.osmc.tv/ijakofosew

Dammit. Unfortunately the logs haven’t captured where you try to play the 5.1 file. Are you able to get logs with grab-logs -A even after the ‘hang’ or does the device freeze up completely?

The frist time it didn´t hang, the second time I play forward and then hangs.

https://paste.osmc.tv/esajucixif

Thanks.

Sorry a forgot reboot before reproduce de error may be this log is better than the previous one.

https://paste.osmc.tv/doruvedufo