No 8 channel audio on July update

I’m trying to get 8 channel DTS-HD MA working and it’s only outputting 6 channels to my receiver.

I have the audio settings all correct (number of channels 7.1 / Support 8 channel decoding is checked / pass through is turned off)

I noticed that line 1145 in the debug logs mentions the dca decoder changing it to 6 channel, why would that be?

My kodi.log

Are you sure file really is 8 channel? Not all DTS-HD MA files are.
Can you try a file from here:
and if you have the same problem then post a log and I can compare to what I see.

I’ll do that when I wake-up, but I’m sure they’re since I personally ripped them from my retail Blu-ray discs with mskemkv and made sure to add back the unselected hd audio. Plus I have watched the same files on different players and had the audio with eight channels.

Plus the media info in that log speed it as 8 channel.

@popcornmix shouldn’t “Support 8 channel DTS HD audio decoding” be disabled by default? mine was enabled and I got no audio for some files. Unchecking this fixed.

UPDATE: seems is set to false:

wondering why was enabled in my install

also this settings don’t have translations in transifex

I believe it’s enabled for Pi2 and disabled for Pi1, by default.

If you get no audio, then try testing with freely available samples (e.g. and post a debug log. I can check if I get the same behaviour.

thanks for the fast reply
will test tonight and let you know. I’m downloading some files from that url to test.
for now this is the mediainfo from the file that I got no audio with that setting enabled:

ID                                       : 2
Format                                   : DTS
Format/Info                              : Digital Theater Systems
Mode                                     : 16
Format settings, Endianness              : Big
Codec ID                                 : A_DTS
Duration                                 : 1h 23mn
Bit rate mode                            : Constant
Bit rate                                 : 1 510 Kbps
Channel(s)                               : 6 channels
Channel positions                        : Front: L C R, Side: L R, LFE
Sampling rate                            : 48.0 KHz
Bit depth                                : 24 bits
Compression mode                         : Lossy
Stream size                              : 902 MiB (10%)
Default                                  : Yes
Forced                                   : No

question: If I connect HDMI cable to a TV that only support this:

osmc@osmc:~$ tvservice -a
PCM supported: Max channels: 2, Max samplerate: 48kHz, Max samplesize 24 bits.

how this new setting is supposed to work?

If your TV does not support multi channel PCM or DTS bitstreaming then you can’t take advantage of 8 channels - they can only be mixed down to 2 channels.

These options are designed for AV receivers that can decode passthrough DTS or decoded multichannel PCM.

so shouldn’t be enable by default in rpi2, agree?
Otherwise users without receivers will complain about no sound.


What makes you think pass through is enabled by default ? Did you look in the GUI or only examine xml files ?

Pass through defaults to disabled.

yes but “Support 8 channel DTS HD audio decoding” is enabled by default.
and this setting only shows up if passth is disabled

look in the gui. played first file. no sound. opened audio settings. disabled this. audio ok again

Playing a file with what kind of audio ? Do you have omxplayer enabled or disabled ? What other audio settings have you changed from defaults ?

Only enabled both players.
See posts before this. Send mediainfo
I found out that patch because popcornmix said:

“believe it’s enabled for Pi2 and disabled for Pi1, by default.”

You shouldn’t get silence with “Support 8 channel DTS HD audio decoding” enabled though.
Even with a stereo TV, it should decode 8 channels and downmix to stereo.
If you get silence there is a bug somewhere.

Confirming that you get silence from a file I have access to (e.g. and confirming which settings are needed to get the failure (e.g. omxplayer enabled/disabled would be interesting). A debug log from after the failure would be useful.

NP. will get that soon

Here is my debug log using the 8 channel sound test file from your link. I still only get 6 channels.


Tested with:

Set Audio settings to “default”

Both players disabled. Sound OK
Both players enabled. No sound
MMAL only enabled: Sound ok
OMXPlayer only enabled: No sound

I enabled both because the default values (both disabled) cause shutters in my mkv files. OMXplayer play fine and MMAL plays with a little less shutter then both disabled.
I prefer OMXPlayer. IMO plays better. Not for technical reasons just for what I experienced.

What happens when both are enabled? Which one is the preferred one?

Full logs:

When both are enabled, you get omxplayer for most file types, unless there are unsupported features.
If software decode is required, or DVD menus, or ALSA audio or AC3 transcode, then dvdplayer will be used.

Any clue of whats going on or need deep investigation?

UPDATE: and when both are disabled?

No hardware acceleration. i.e. software decode with ffmpeg (using dvdplayer).

So IMHO @sam_nazarko can enable both by default in RPI1 and 2 as both have hardware accelaration. This would avoid “shutter” issues for normal users (those who dont tweak settings)
Or is there a reason for not enabling them by default?