No audio from single channel AAC video

I just tried play video from my new action camera.
Video is OK, but I have no audio at all. Sound format is AAC single channel (center).
Vero4K is connected directly to TV. Same video plays fine in windows based kodi box.
Could you please help resolve this?

Format : MPEG-4
Format profile : Base Media
Codec ID : isom (isom/iso2/mp41)
File size : 431 MiB
Duration : 1 min 33 s
Overall bit rate mode : Variable
Overall bit rate : 38.6 Mb/s

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : Main@L5.1
Format settings, CABAC : Yes
Format settings, RefFrames : 1 frame
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 1 min 33 s
Source duration : 1 min 33 s
Bit rate : 38.5 Mb/s
Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Frame rate : 30.000 FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.155
Stream size : 430 MiB (100%)
Source stream size : 430 MiB (100%)
Language : English
Color range : Limited
Color primaries : BT.601 PAL
Transfer characteristics : BT.601
Matrix coefficients : BT.601
mdhd_Duration : 93732

ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : 40
Duration : 1 min 33 s
Source duration : 1 min 33 s
Bit rate mode : Variable
Channel(s) : 1 channel
Channel positions : Front: C
Sampling rate : 8 000 Hz
Frame rate : 7.813 FPS (1024 SPF)
Compression mode : Lossy
Source stream size : 176 KiB (0%)
Language : English
mdhd_Duration : 93732

Debug log or a sample would help.

Does AC3 transcoding help? There are a couple of AAC issues in the last update that haven’t been resolved yet, but there’s a workaround for now: Multichannel (non-passthrough) surround sound stopped working after June update.

Alternatively, you can install the pre-June version for now.


Thanks for replying.
Unfortunately AC3 transcoding didn’t help.
I’ll try uploading a small sample later today.
Is this expected to be fixed in July update?
thank you.

No – because it sounds like you have a different problem.

Please find a small sample at the link bellow

Did you manage to reproduce the issue with this AAC audio?

Not just yet

I was patient enough to check the issue with the July update.
Unfortunately the issue remains.
Could you please help?

I’ll take a look.


Not sure if it is the same issue, but dvblogic pvr also stopped working, no audio on any of the channels… can send log if required

Probably not related – but a log would be useful


Okay: DVBLogic issue seems to be a problem specifically with DVBLogic. Hopefully fixed in next release.

Regarding audio: the file you sent me seems problematic. Did this file work before on Vero 4K (i.e. before an update)?


I didn’t have the action camera before June update, so I cannot really tell if the file was playing properly before June update. However, I can tell for sure that is plays correctly at all of my other devices – Vero4K is the only one that gives me the issue.
Trying to identify the issue, I did some conversions:
First, I converted the audio to stereo, no luck. Then I changed from AAC to mp3, AC3, and others, still no luck. After experimenting few more times, finally I resample the audio from 8 KHz to 41.1 KHz. That did the trick; Vero4K can now reproduce the audio correctly.
So, is it safe to tell that the Vero has issue with the 8 KHz audio? If yes, is it possible to have a fix with the next update?

Yes – the issue is the 8Khz.

Vero 4K can’t output audio in this format at this time. I haven’t found many files encoded this way.

I believe the workaround is to fix the frequency in Kodi settings. If you look on your other devices that work, you’ll likely see that this is being done (the audio isn’t actually being output as 8Khz)

Thanks for the swift answer, I’ll try the workaround.