No Audio on DD+ with 8 Channels on Vero4K

Dear team,

thanks for keeping up such good work with my Vero4K and its software. Recently I discovered not being able to playback some 8 Channel Dolby Digital E-AC3 encoded files. In passthrough of course.

I pasted the media info here:
https://paste.osmc.tv/erateyuwul.coffee

And my logs here:
https://paste.osmc.tv/odifiyulif

The sample file contains 3 audio streams. Both 8 channel 640kbit E-AC3 streams in the sample file play with no sound while the 6 channel 768kbit E-AC3 with Atmos on top plays fine.
I tried switching in the logs between the streams.

Until now I had no issues with any files on my Vero 4K and Denon X4400H receiver.

The MKV sample where I only extracted the audio that does not play can be found here:

Could you help me here ?

I guess this is something for my hero @Chillbo

Does this file contain only one problematic track - as it’s a music file, it’s not possible to toggle between tracks? It’s not playing here with passthrough either, but it does play when decoded to PCM.

Yes, I extracted only one of the problematic streams. It plays on a friends Nvidia Shield via passthrough with no problems. It is the second time I encounter such a track.

I could verify that all works as expected playing back this clip via MPC with passthrough enabled. As this and another clip we’ve encountered do not play via Kodi from a Windows PC with passthrough enabled either, it seems we have found a Kodi issue here. We can certainly look into it, but it might be more complicated as it’s not platform dependent - not an OSMC specific issue.

@Chillbo Oh nice, or not so nice. I guess we will have more of such tracks in future.
If you have good relations with the Kodi team would be great if you could try to solve it.
I could also help opening a case, let me know.

Oh oh I fear we could have run into this issue:

The bug is 1,5 years old. I don’t understand the comment that they don’t maintain the passthrough code anymore. That would be terrible.

Yes that’s exactly the issue. I’m looking at fixing it. I’d have thought it would be trivial for Fritsch or Anssih to sort out but maybe there’s a gotcha.

Well that would be fantastic @grahamh !
In the GitHub Thread a guy even said that he found the part where it is going wrong.
It seems Kodi always expects E-AC3 streams with AC3 streams embedded.

That’s roughly it. It’s not quite as simple as I thought it would be though :slight_smile:

Haha, so where does it leave us ? :slight_smile:

Well - we are aware that it’s an upstream issue with Kodi.

We will do our best to look at it, but there are people in Team Kodi that have more knowledge of how that code works.

I asked the Kodi guys for help as well.
@fritsch_xbmc suggested to implement ffmpeg. As they support passthrough now.

See:
https://forum.kodi.tv/showthread.php?tid=369720&pid=3111917#pid3111917

1 Like

It makes more sense long term

Would be great if you could push this topic on the Kodi Thread as well. Or do you have good contacts with the Kodi team ? I see that a suggestion has been made but I do not really know if anyone would take up that task or how it is gonna continue.

Perhaps if you posted on the bug report with Fritsch’s proposed fix it might come on someone’s radar.

Just did it. Lets keep fingers crossed. I wonder why there is not more complaining for this. It basically affects all E-AC3 tracks with more than 5.1 channels. Maybe having an Atmos home setup on DD+ is still “early adopter” :smiley:

No, I’ve got what looks like an official Dolby E-AC3 7.1 test clip that has that hybrid format. I’m no expert but suspect most Atmos is TrueHD, and I can’t think why new titles would be published with DD+ instead of TrueHD unless they had loads of language options.

For stuff that originates on some kind of streaming service (e.g. Netflix, Disney+, etc.) Atmos via DD+ is pretty much the standard option these days.