No Audio with DTS-HD-HRA Movies

The issues should now be completely resolved with the latest available update.

Sam, per our email I updated today to vero4k March 3.2. I’m still having issues with Atmos and DTS-HD MA 5.1 and 7.1 tracks. Seems better though as toggling “Stereo upmix” setting or restarting the movie is a quick way to get the audio working. So, not fixed but maybe better. No issues I’ve seen with the video as Bisonator reported.

the last 2-3 Days i got about 3 or 4 Updates. Now my Video files are playing fine again (the update before cpu was on 100% on any stream) but the DTS-HRA problem isn’t solved

I can assure this isn’t fixed yet…

Which kernel version are you on? Could you check under settings/system info or via SSH and uname -a?

3.14.29-69-osmc

There has already been made a topic about it: AVR Onkyo TX-RZ820, DTS-HD HRA/Hi Res Passthrough Issue

Ok, just checking… But it looks like the problems of the last days have been resolved for most now.

We’re very aware of this issue. Part of the problem with the last days’ updates was an approach to fix this DTS-HD HRA issue with mostly Denons, but also some other AVRs. But the fix was not working as expected.

The issue here may correlate with DSPs in the affected AVRs from Cirrus Logic that caused problems with DTS-HD HRA based DTS:X tracks when those chips were first introduced. It’s a guess so far and won’t help solve the problem really, but the affected AVRs mainly from Denon (lower-end models) and Onkyo are all using those chipsets.
We’re still trying to find a way to fix this on the Vero side, but it may be that it’s just not solvable. DTS-HD HRA is quite a rare format and therefore the problem might not have been noticed by all owners of affected AVRs. The inconsistency of it working with some players, but not all seems to fit as well. It is a HDMI timing issue. But solving it for affected AVRs may break things for others. It’s a very unfortunate issue that seems to need more time to hopefully fix it. But no guarantees that we can do it :slightly_smiling_face:

Lets hope so else I need a different device for every other movie :wink:
It is nota bigdeal for now, only got a few files, but would like to have the DTS core as a minimum.

The workaround is to let the Vero 4K decode DTS-HD audio and send it as PCM. You lose zero quality, and since HDMI is required for sending both DTS-HD and more than 6 channel PCM, there is no way somebody can stream DTS-HD to their AVR and not be able to send the decoded PCM.

1 Like

I want chime in that I also have problem of no audio sometimes. I have to stop and start the video a coupple of times and randomly it just works.

DTS-HRA and Dolby True-HD almost always fails first try and it feels like most pure 5.1 works always.

I have tried Fixed, Optimized and Best and cant see one being better then the other really.
If it works it gives me Atmos and if it doesnt work its no sound. I can either change the audio track back and forth sometimes or stop the video and start again, it seems like its the initializing fase that fails?

I also got the sound only(mostly?) in the surrounds once but this was on an old tv-series so I cannot vote for the rip but I remember reading something about this together with problems with 7.1 so this is why im commenting on it.

I have a Yamaha 3060.

Thanks for the report. Yes that’s where the bug-hunting effort is pointed at as we speak.

If you have GUI sounds turned on, then hdmi gets reset to stereo to produce the clicks etc. Then I think you have the best chance of a passthrough stream behaving properly.

I have GUI sounds turned on.

I really hope we find a solution, Atmos is the main reason I got the box. I do have to say however that its no turning back to software client/server after using this, its a whole new world, but still…sound is extremely important to me.

Im running 5.1.4 btw.

Version of what? Do you mean speaker layout?

Yes speaker layout. I have put 7.1 in kodi and it used to work perfectly.

The first thing I did when getting the Vero was to try the Atmos demos and all I did was changing to 7.1 - checking that passthru is enabled and that all formats are ticked. And everything worked.

I dont know what changed, but I havent touched the audio-settings until it started to not work.

When did you get it, and did you immediatly update it? Please upload logs using MyOSMC.

I got it a coupple of weeks ago before the many updates that happened a while ago. So it is many updates later now, and I never really tested the Atmos demos again until now when the HRA disnt work I tried the demos again and sure enough they are also problematic.

I know this is all a little fuzzy and it could very well have been the same all the way since it does work sometimes and sometimes not and there are very few Atmos files around so…

But sure I can provide logs tonight.

Hi

Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

This was a magical testing. I have no idea how you guys figured this out, and offcourse its a little too early too see if everything will work, but just testing Atmos, DTS:X, DTS-HD-MA and HRA i got a lock 5 out of 5 for all those.

But thats not all - its also superfast, the reciever lights up “Atmos” even before the picture comes on!!

Looking really good just after some initial testing. Great job!

3 Likes

When i am home again (friday) i will test it and give feedback. Thanks for all the hard work.

Do a test with the problematic DTS-HD-HRA movies like Fast and Furious 6 + 7 but without luck - my Denon Receiver shows “Stereo” and no audio - i must change the Kodi audio setting from “best match” to “Fixed” to have sound in DTS-HD-HRA movies as bevore the update!