No Audio with DTS-HD-HRA Movies

Did you test those discs with a Blu-ray player and your 2400H before? Did it work from that source (not using the Vero to play DTS-HD HRA)?


Just wanted to check if there was any update to this as I am unable to play DTS-HD HRA files either? I am using a Denon AVR-X2400H receiver. I downgraded the firmware and only the DTS core would play. I upgraded firmware to the latest version and I get no sound now. I have tested some files I have that use DTS-HD HRA on a i3 HTPC with PowerDVD 17 and they play fine to my Denon.

There is no progress just yet unfortunately

I just tested some movies, and DTS-HR (High Res) streams fine to my Sony AVR. The AVR recognizes it correctly.

But, if the movie has multiple audio streams and you switch between them, DTS-HR takes by far the longest time to find an in-stream sync point so that audio is heard. I don’t think this is a bug in any way with the Vero or OSMC, but rather an issue with the format. I can replicate this when playing back the same movie with my NeoTV.

Before the 3-D audio systems (Atmos, etc.), DTS-HR was the last new format, and because it is not used much on BluRay, there are likely more bugs with the decoders.

My Atmos and DTS-HD tracks are not reliably playing - related to this thread? Or do I have a HW or SW problem?

The Atmos and DTS-HD MA tracks are now working sporadically, about 1 out of 10 times, or not at all. Until recently all of these tracks worked perfectly. Sometimes I can get the track to play by toggling the vero4k “Stereo upmix” audio setting.

My configuration:
Vero 4k
Marantz SR7009 AVR

Things I’ve changed that may have resulted in this breakage:

  • Updated the Marantz SR7009 firmware to 6005-3165-6011-07
  • Updated vero4k to 2018.03-1

Is this failure mode related to this thread?
Is this a known issue related to the Marantz firmware? If so, can I downgrade the firmware?
Or is this more likely a HW failure? Short of buying another vero4k I don’t know how to test this.

After checking cables and all settings on my AVR and vero4k, I’m not sure what else to do. I can’t make sense out of something that works some of the time.

Any advice?

1 Like

I’m having the same issue that Clockkent has described. I’ve searched other threads and although there’s a lot of discussion about HD audio formats and the Vero 4k etc, I’ve not managed to find any suggestions that fix it for me as yet. Clockkent’s description is the closest to what I’m experiencing that I can find, so chiming in here.

Before the 2018.03 update, I was able to play Atmos and DTS-HD MA tracks consistently, without problems. However, now it appears to be touch and go as to whether I will get any sound from those video files.

Another thing I’ve noticed is that I can sometimes work around it…

If I start playback and get no sound, then skip forward 5 mins into the file so kodi marks the file as ‘in progress’. Then if I ‘resume’ playback from that point of the video file, skip back to the start of the file and let it play, it is more likely to then produce the audio. (Still some cases where it doesn’t produce sound at all even using this workaround.)

Only started happening recently.

When this happens and I bring up the OSD for the amp to see what it’s receiving it seems to not be able to identify an audio track. Whereas, when I do get sound for these files it will correctly display Atmos / DTS-HD MA.

And if I disable Atmos/DTS-HD passthrough in kodi, I do get PCM audio.

I’ve got a Denon AVR-X2200W, which did have a firmware update a while ago, but I can’t remember exactly when. It’s currently on firmware: 4200-2411-4032, DTS version:

And my Vero 4k is up to date as of an update it got today: 2018.03-2

Same here unfortunately!

1 Like

Have you tried updating again via My OSMC?

It could take an hour for this update to reach your mirror.

Try updating it now again, the audio stuff has been reverted so Atmos etc plays like it used to now

Thanks Martorias

I’ve updated and got video problems now, same as another user, more details here: 2018.03-2 update has broken my passthrough sound - #31 by ac16161

Yeah I saw that :frowning: im still on the -67 in which most stuff seems to work

1 Like

The issues should now be completely resolved with the latest available update.

Sam, per our email I updated today to vero4k March 3.2. I’m still having issues with Atmos and DTS-HD MA 5.1 and 7.1 tracks. Seems better though as toggling “Stereo upmix” setting or restarting the movie is a quick way to get the audio working. So, not fixed but maybe better. No issues I’ve seen with the video as Bisonator reported.

the last 2-3 Days i got about 3 or 4 Updates. Now my Video files are playing fine again (the update before cpu was on 100% on any stream) but the DTS-HRA problem isn’t solved

I can assure this isn’t fixed yet…

Which kernel version are you on? Could you check under settings/system info or via SSH and uname -a?


There has already been made a topic about it: AVR Onkyo TX-RZ820, DTS-HD HRA/Hi Res Passthrough Issue

Ok, just checking… But it looks like the problems of the last days have been resolved for most now.

We’re very aware of this issue. Part of the problem with the last days’ updates was an approach to fix this DTS-HD HRA issue with mostly Denons, but also some other AVRs. But the fix was not working as expected.

The issue here may correlate with DSPs in the affected AVRs from Cirrus Logic that caused problems with DTS-HD HRA based DTS:X tracks when those chips were first introduced. It’s a guess so far and won’t help solve the problem really, but the affected AVRs mainly from Denon (lower-end models) and Onkyo are all using those chipsets.
We’re still trying to find a way to fix this on the Vero side, but it may be that it’s just not solvable. DTS-HD HRA is quite a rare format and therefore the problem might not have been noticed by all owners of affected AVRs. The inconsistency of it working with some players, but not all seems to fit as well. It is a HDMI timing issue. But solving it for affected AVRs may break things for others. It’s a very unfortunate issue that seems to need more time to hopefully fix it. But no guarantees that we can do it :slightly_smiling_face:

Lets hope so else I need a different device for every other movie :wink:
It is nota bigdeal for now, only got a few files, but would like to have the DTS core as a minimum.

The workaround is to let the Vero 4K decode DTS-HD audio and send it as PCM. You lose zero quality, and since HDMI is required for sending both DTS-HD and more than 6 channel PCM, there is no way somebody can stream DTS-HD to their AVR and not be able to send the decoded PCM.

1 Like