No Audio with DTS-HD-HRA Movies

I want chime in that I also have problem of no audio sometimes. I have to stop and start the video a coupple of times and randomly it just works.

DTS-HRA and Dolby True-HD almost always fails first try and it feels like most pure 5.1 works always.

I have tried Fixed, Optimized and Best and cant see one being better then the other really.
If it works it gives me Atmos and if it doesnt work its no sound. I can either change the audio track back and forth sometimes or stop the video and start again, it seems like its the initializing fase that fails?

I also got the sound only(mostly?) in the surrounds once but this was on an old tv-series so I cannot vote for the rip but I remember reading something about this together with problems with 7.1 so this is why im commenting on it.

I have a Yamaha 3060.

Thanks for the report. Yes that’s where the bug-hunting effort is pointed at as we speak.

If you have GUI sounds turned on, then hdmi gets reset to stereo to produce the clicks etc. Then I think you have the best chance of a passthrough stream behaving properly.

I have GUI sounds turned on.

I really hope we find a solution, Atmos is the main reason I got the box. I do have to say however that its no turning back to software client/server after using this, its a whole new world, but still…sound is extremely important to me.

Im running 5.1.4 btw.

Version of what? Do you mean speaker layout?

Yes speaker layout. I have put 7.1 in kodi and it used to work perfectly.

The first thing I did when getting the Vero was to try the Atmos demos and all I did was changing to 7.1 - checking that passthru is enabled and that all formats are ticked. And everything worked.

I dont know what changed, but I havent touched the audio-settings until it started to not work.

When did you get it, and did you immediatly update it? Please upload logs using MyOSMC.

I got it a coupple of weeks ago before the many updates that happened a while ago. So it is many updates later now, and I never really tested the Atmos demos again until now when the HRA disnt work I tried the demos again and sure enough they are also problematic.

I know this is all a little fuzzy and it could very well have been the same all the way since it does work sometimes and sometimes not and there are very few Atmos files around so…

But sure I can provide logs tonight.


Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

This was a magical testing. I have no idea how you guys figured this out, and offcourse its a little too early too see if everything will work, but just testing Atmos, DTS:X, DTS-HD-MA and HRA i got a lock 5 out of 5 for all those.

But thats not all - its also superfast, the reciever lights up “Atmos” even before the picture comes on!!

Looking really good just after some initial testing. Great job!


When i am home again (friday) i will test it and give feedback. Thanks for all the hard work.

Do a test with the problematic DTS-HD-HRA movies like Fast and Furious 6 + 7 but without luck - my Denon Receiver shows “Stereo” and no audio - i must change the Kodi audio setting from “best match” to “Fixed” to have sound in DTS-HD-HRA movies as bevore the update!

There are some Blu-Rays that have playlists for the main movie where the first item in the playlist is something like the studio logo, or a rating card, or a copyright warning card, etc., and then the movie is the second item.

The problem is that some of them are technically out-of-spec because the tracks on the first item in the playlist don’t match up to the ones on the second item in the playlist (different audio formats, or even a different number of tracks). I don’t know if the movies you mention are that way, but if you are only having problems with a couple from the same studio, I’d blame the movie, not the Vero or your receiver.

I have untouched mkv and the movies i mean are only two with HRA Audio i have tested! All of them with HRA have the same issue after update so i think the offered solution (the update) doesn´t work for me!

It is obvious also from your feedback that passthrough itself seems to work as expected again, but the latest build doesn’t solve the HRA issue. Please also see this for some explanation: AVR Onkyo TX-RZ820, DTS-HD HRA/Hi Res Passthrough Issue - #72 by Chillbo

So, we’re still trying our best to see whether we can find a solution to this problem and we’ll keep you posted. :+1:t2:

Yes, i know this - the source of the problem is the last firmware update for my Marantz Receiver and not the vero. But when the vero-team find a solution for this i´m very happy! :slight_smile:

We’ll see, if something can be done… It may take time though and we can’t promise anything. Let’s just hope :wink:

1 Like

Unrelated to OSMC, an update to my Sony BluRay player caused it to stop sending any format beyond basic DTS and AC3 to my Sony AVR.

If one company can’t keep this kind of thing working with their own hardware, imagine how hard it is when you don’t control some of the hardware. I know the OSMC team will work hard at this, but there may not be a solution that works for every case.


I have a Pioneer VSX-921K Receiver and have Problems with DTS-HD (normal and MA, 5.1 and 7.1) and Dolby True HD. --> No Sound. So the problem isn’t only present on Onkyo and Denon AVR’s…

My Receiver is capable to decode that formats.

I’ve got a Raspberry Pi 2 with Libreelec and same Settings within Kodi. No problems at all on this platform. The DTSHD and Dolby TrueHD content is playing fine. Why is this a problem with the Vero? It’s a hardware thing between Vero and the AVR i guess?!

Is there any chance of a fix in the very near future?
Got my Vero today and that sound problem is a real problem for my use cases.

Raspberry Pi cannot bitstream DTS HD or Dolby TrueHD.

Simply disable these formats under passthrough to pass the core through, as is done on Pi, in the interim.


The Problem is not solved for me after following the steps. :frowning: