No files appeares in added shared folders

Hi guys,
I’ve searched almost whole Internet and I can’t find the answer.

I’m trying to add to OSMC files shared on my computer (Win10).
I can easily add shared directories from my computer but then I have no files on a list (but I’m pretty sure I’ve got some files in this folders). It’s not the issue like this: Files not showing on SMB share, only folders . I am aware that I have to firstly add directory and then I will be able to see files. Believe me, I’m adding it and there are still no files on the list.

I’ve created a new local user on my win10 and i shared folders with the full access for this user and for everyone. I checked if this files are available for other users on my PC and everything looks ok. So the problem is only on OSMC side but I don’t know where.

I would appreciate some help.

First make sure that the contained files have permissions for Everyone and make sure you are logging in to the shares with a valid user “Everyone” is only users that are known to the Windows PC Right click the shared folder>properties>security>advanced> Replace child object permissions…

Then go to Control Panel\All Control Panel Items\Network and Sharing Center\Advanced sharing settings Under All Networks turn file sharing connections down to 40/56 bit encryption, if that doesn’t work then try turning off password protected sharing.

Thanks for answer Diligaf!
I have a little trouble with understanding your first paragraph because of no punctuation, but still:

  • Shared folder has all permissions for Everyone and for osmc user (local user i’ve created for osmc connection)
  • I’ve enabled inheritance in Security tab
  • I’ve turned conections to 40/56 as you had written
  • I’ve turned off password protected sharing (still OSMC needs password to some account when I’m trying to add shared folder)

Still no files on OSMC list after adding folder :sweat: