No Hdmi ARC on AV receiver when V4K is hooked

Hello,

I’m starting a new thread to not interfere with others.
If you feel concerned, don’t hesitate to share your experience.

My current setup is Vero 4K > Onkyo RZ710 > LG EF9500 (oled tv)
(latest firmware for everything)

I got in touch with Onkyo earlier this week because i hadn’t noticed that i had lost Hdmi arc function after installing the Vero 4K (i only need this when i m watching DVB TV, or internal tv apps like Netflix, youtube, Amazon Prime video etc…).

That’s clearly annoying since i bugged onkyo about the problem until i noticed that as soon as i unplugged the V4K from its hdmi cable, sound instantly switched back on.

Since i prefer that HDR Banding issue gets firstly and fastly sorted, i prefered waiting before talking about it but another user seems to report the same problem.

First things first, i have 6 or 7 hdmi sources hooked up to my AV receiver, and the Vero 4K is the only responsible for that problem (i skip you the story where i say that i resetted totally the AV, had to recalibrate speakers, resetted tv settings, unplugged everything etc…).
I didn’t find any menu on OSMC to disable Hdmi CEC functions (i don’t need the V4K to turn on or off my hdmi chain, really). In my opinion, that would be the most convenient and fastest solution, if anyone knows about that.

I even noticed that keeping only hdmi between V4K and the AV isn’t sufficient. With power supply unplugged from the outlet, the problem exists (!), i really had to pull the hdmi cable to notice it was the V4K.

Anyway, thank you to Osmc team to bring support to this 4K Hdr Hevc kodi hardware, it’s high time we get the ultimate 4K player, once the bugs will be sorted out.

Settings -> System -> Input -> Peripherals -> CEC Adapter

1 Like

Nice, i would have never looked in “input” settings. I ll try this option, but i don’t think it’s enough since the problem exists without power supply.

So I just replugged my V4K and the problem was gone today weirdly (it was unplugged totally since at least tuesday).

For now, i can’t reproduce it, i ll add a message when (if) it comes back.

Thank you for the heads up fzinken, i disabled everything to not waste time.

Hi,

Indeed. That’s why I would ask: do you get the problem when the device is actually on?
This was another reason that we introduced the Standby mode recently.

Sam

Don’t take this the wrong way MRK, but I’m glad someone else is having this problem! :wink:

My setup is:

I’ve got LG B7 <–(arc)—> Marantz Nr1607 <-------Vero 4K

…and I have exactly the same issue as you. I had a short chat about it on this thread:

My case is the same weirdness as yours - sometimes I’ll be watching something on the Vero, switch off for the night. Wake up next day and the kids switch the TV on for Netflix and ARC won’t work. I’ve tried a bunch of stuff and it’s definitely the Vero, and the fix is to pull the HDMI cable out and ARC reestablishes itself. Powering the Vero off does work sometimes, although there tends to be a 5-6 second delay while the AVR sorts itself out.

My CEC adapter is off, and always has been (I use a Harmony for all the device controlling), so I don’t think this is the cause of it.

For me, it’s very intermittent and hard to reproduce. After the suggestion on the thread above, I switched the HDMI cable out for an Amazon basics one and I haven’t had the problem since (I was using a freebie cable that Peter Tyson sent with the AVR, although it did look like a nice one). It’s only been a month since I did that though and sometimes I don’t encounter the problem for weeks at a time so it might not be the answer. I do wonder if it’s a shielding issue.

I’m having quite the same problem watching Amazon or Netflix on my LG by using ARC to return the audio to the amp.

Vero 4K (CEC-adapter disabled) --> Yamaha RX-A870 --> LG OLED B7

When I’am starting up all devices at the same time I have no problems with ARC. But for example I power off the TV and amp (Vero not touched, so idle), wait for some time, power on TV and amp again, ARC is completely gone. Solution: Pull out the HDMI-cable from the Vero and ARC is working again.
So I’m not sure, but maybe the Vero is doing something strange while going to idle?

Hi Sam,

i’m sorry for the delay. I came back from work this evening and tried to turn on my tv :

No sound, problem is back.
The device was on (it turns on when my AV turns itself on).

I tried :
-rebooting V4K > no effect.
-Manually switching on “tv source” >no effect
-unplugging psu from V4K > sound came back instantly on AV before stopping and coming out from TV speakers only without my intervention (by checking sound settings from TV, it had set as internal speakers and forcing to ARC results in no sound still).

Before unplugging hdmi cable from V4K which is currently disconnected from power supply, i can do some more tests today and tomorrow if needed.

Else, sound is perfectly working from V4K and other hdmi sources are too from AV.

Note that i don’t have anything else plugged on my tv besides AV receiver.

There maybe something related to suspend or idling time like maerty said.

Hi,

Have you tried connections as follows:

Onkyo RZ710 >> ARC Hdmi port
Vero 4k >> Next free hdmi port on the LG EF9500

My Setup is as follows with by soundbar:

Soundbar >> Hdmi 1 (ARC)
Vero4k >> HDMI 2
PC (NVIDIA HDMI) >> Hdmi 3
Bluray player >> Soundbar (Only because I’ve run out of HDMI ports on my telly)

ARC is working as it should for all devices. My understanding is the preference for setting this up so the audio return channel works (Arc) is to connect input devices to the TV first and only use hdmi on AVs when no further TV HDMIs are available. The return channel, will direct audio where is should be.

Thanks Tom.

I bought the V4K in order to get 7.1 and Atmos from my 4K media.
On TV’s hdmi, since it’s not e-arc (new gen ARC), i ll only get “simple 5.1 sound”, which i m not interested in.
All devices outputing DTS-HD or more sound quality get through my AV first.

Hi,

Have you tried a different HDMI cable?

Thanks Tom.

yes.

Just posting here as in three months of using the Vero, just had my second ARC lock-up event. First time was a while back, after a full power down, the Panasonic TV could not establish an ARC connection with my Marantz AVR. After much random fiddling, it eventually came back. Last night I installed the latest OSMC test release, and when I went to use the system today, the TV remote volume and ARC were both broken. On this occasion it took less fiddling to get it back, and all now seems to be ok. But it does seem that the Vero has an issue with occasionally breaking ARC on some receivers.

It may not be relevant, but I get no ARC if the TV is switched on (or woken up) when the AVR is already on. The fix is to turn off the AVR and turn it on again. Is this a bug or just me not understanding CEC and stuff?

That’s never been an issue for me. My Panny TV and Marantz AVR have been playing nicely together for five years. Very rarely, the TV will lose the AVR as its speaker output but the fix is to go to the Viera Link menu in the TV and restart the AVR speaker output. What has been very disconcerting about the two incidents since I bought the Vero is that the restart in the Viera Lnk menu on the TV does not work, as if the AVR is locked out. The first time was quite stressful as no matter what I tried, I cold not recover the ARC. Eventually by some fluke it came back. Today, I simply removed the Vero entirely, including its HDMI lead, powered off the TV and the Viera Link started working again. All seems fine now, if it remains an infrequent problem I can live with it, not otherwise.

Hi,

same Problem here.
My Setup LG B7 >> Denon AVR X3500h >> Vero 4K

As soon as Vero is hooked up via HDMI, no more ARC is working form all internal TV Apps like Netflix, Amazon, DAZN, Youtube…
When i unplugg the HDMI Cable from the vero (or the denon receiver) sound from all internal apps is back.

Any solutions?

br

With most TV’s (at least the ones i’ve played with) Your audio settings are fixed regardless of input. LG is a bit more flexible (frustrating?) as what it uses for one input is not necessarily the same as another. The first thing to check is that your TV settings when it stops working is actually set on ARC.

hi darwin,

thx 4 the information. i will make a video to see what happens, Sound output on LG doesnt change. when sound is gone from the internal apps its on HDMI Out (ARC), which it was before. this only happended when i first setup the tv. so HDMI 1-4 ist set to ARC and internal was on TV Speaker, when i changed it the setting is saved.

i guess im still not the only one with this problem?

br
michael

Nope cLoudMV, no fix so far. Only workaround is to unplug HDMI when V4K is not in use.

Since we are a few to have this problem with various hardware, I’m guessing for something defective on our units.

You could try setting Settings>System>Input>Peripherals>CEC Adapter>Physical address>1 on the Vero.

Also make sure the AVR is plugged into hdmi 2 on your TV.

There is no doubt that there is a real problem with ARC. In my case the ARC lock-up (Marantz AVR, Panasonic TV) has only ever happened a couple of times, clearly others are affected by this much more. First time it happened I was pulling my hair out trying to fix it. But to be clear, this is a real thing.