No HDR on Samsung KS7090

Hello,

i just got my new vero4k and sold my Nvidia Shield because HDR was not working on the shield.

Samsung KS 7090 Firmware 1208 - Capable of 10 bit HDR Rec. 2020
Denon x1200 capable of hdr.

I tried both connecting the Vero4k directly to the televison and activated UHD at the right port.
And tried to connect the vero4k at my receiver Denon x1200w.
But no change at all the Display does not change into HDR mode and the brightness level went down as soon as i play a HDR file on my Vero4k colours are not HDR like…

If i play the Samsung Winderland demo.ts on my inbuilt TV player it works flawlessly the televison change the Display mode and the brightness went up and the colour are more intensive just as HDR should be.

Testfile Samsung wonderland Demo.ts
Dowload Samsung Wonderland 4k HDR demo

The logfile:
Logfile of my vero4k

I can see you tried to play a number of clips, but didn’t have debug logging consistently on.

Have you enabled Adjust Refresh Rate?
Have you tried Vero 4K directly connected to the TV?

At the moment the log was made the Vero was connected directly to the TV.
Adjust refresh Rate is on

Here is a new logfile i just made it playing the Samsung File New logfile
Should i leave the file played for a specific time?

Hi,

What have you got this set to? its under settings, player.

Thanks Tom.

Adjust display refresh rate is set to always

Hi,

Apologies just re-read your post and can see you had already advised refresh was on, and I can now also see it in the logs now.

Mediainfo may help?

Thanks Tom.

here ist the mediainfo:

Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Frame rate : 23.976 (24000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 10 bits
Writing library : ATEME Titan File 3.7.3 (4.7.3.1002)
Color range : Limited
Color primaries : BT.2020
Transfer characteristics : PQ
Matrix coefficients : BT.2020 non-constant
Complete mediainfo
Mediainfo Samsung Wonderland

Hi,

Apologies for the late reply, something doesn’t look right here:

Display resolution ADJUST : 1920x1080 @ 60.00

If I’m reading the logs right for both these the adjust frame is playing these files at 1080p @ 60 fps, where as the mediainfo advises both of these are 4k and 23 fps.

Could you please provide the output of the following, when connected to the tv and then denon:

cat /sys/class/amhdmitx/amhdmitx0/disp_cap

Thanks Tom.

So at first this is the output directly connected to the TV

480p60hz
576p50hz
720p60hz
1080i60hz
1080p60hz
720p50hz
1080i50hz
1080p30hz
1080p50hz
1080p25hz
1080p24hz
2160p30hz
2160p25hz
2160p24hz
smpte24hz
smpte25hz
smpte30hz
smpte50hz
smpte60hz
smpte50hz420
smpte60hz420
2160p50hz
2160p60hz
2160p50hz420
2160p60hz420

and this connected to the Denon

480p60hz
576p50hz
720p60hz
1080i60hz
1080p60hz
720p50hz
1080i50hz
1080p30hz
1080p50hz
1080p25hz
1080p24hz
2160p30hz
2160p25hz
2160p24hz
smpte24hz
smpte25hz
smpte30hz
smpte50hz
smpte60hz
smpte50hz420
smpte60hz420
2160p50hz
2160p60hz
2160p50hz420
2160p60hz420

Hi,

Ok looks like both are advertising the resolutions correctly, strange that when these files are played its not switching correctly.

If you check under settings, system, display, resolutions: What resolutions does kodi report as available?

Thanks Tom.

these are displayed
1920x1080p
1280x720p
1920x1080p
1920x1080i
3840x2160p
4096x2160p

Hi,

Sorry I’m at a bit of a loss now, short of trying a different HDMI cable.

@sam_nazarko any thoughts?

Thanks Tom.

Used 4 diffrent cable including the cable which comes with the vero4k no change at all

As @Tom_Doyle notes, it seems that your video is being played back as 1080p.
We’d need to see a complete Kodi debug log. Currently, it’s not possible to deduce what the problem is from your current logs.

If you tell me how i do that im gonna mage such a logfile for you

See Log file/Advanced - Official Kodi Wiki

I sometimes see a 4k video will not adjust to 4k and will play at 1080p on my Samsung KS9000. This is usually if the Vero has been on for days / weeks without a reboot. After a reboot it always switches to 4K properly. Have you tried a reboot? I’m sure you have but if not…

In your case, that will happen if you turn your Vero 4K on before the TV as well.
Run:

cat /sys/class/amhdmitx/amhdmitx0/disp_cap > ~/.kodi/userdata/disp_cap

And then on the next OSMC update, you won’t ever get this problem again.

Good to know, thanks Sam.

I leave the Vero ‘always on’, but it’s plugged into a receiver not the TV so it’s possible the receiver is on before the TV, so same scenario you explain.

This and enabling HPD Lock (under Display in the next update) should resolve this entirely for you. Give me a shout if it doesn’t.