No Internet (eth0 or WiFi)

Hi all,

Firstly, i know there are a number of topics around internet connection issues, and I’ve trawled through many of them in vain. So I’m hoping that someone can help me, as non of the other posts have helped resolve my issue thus far.

I have a 200Mbps fibre connection and I have 2 Vero 4k devices (one in my lounge and one in the master bedroom). One is connected via WiFi and the other via Ethernet cable. Both are running the November 2019 release. Neither devices are able to connect to the internet. they both say that they are connected to the network and are able to display content from my content server (which is in my office), but neither of them are able to update (OSMC or library) as they cannot connect to the internet. All other devices on my network are able to connect regardless of connection mode (wifi / ethernet).

What I’ve tried so far:

  1. Changed from wifi to ethernet (both devices)
  2. Changed from DHCP to static IP and back.
  3. Checked the /etc/resolv.conf file (entry looks correct, pointing to my router -
  4. Reset the .kodi file (ssh, stop media center, mv .kodi file, start media center).
  5. Complete re-install of OSMC on the Vero. I downloaded the Nov 2019 version.

Is there a known issue with this version? all other devices (mobile, desktops, tablets, TVs) are all able to connect to the internet (some are running on DHCP and others have a static IP). And if not, what else can I try to resolve this issue?

Thank in advance for any assistance.

Since you can SSH in, try a few things:


That will give an idea of if it’s a DNS problem or not.

I haven’t tried a traceroute. but i did try a ping.

i am able to ping my router
when trying to ping the request simply times out.
i did this vis SSH (Putty) from my laptop. at the same time my laptop was also connected to then same wifi SSID and was able to ping without any issue

If you can’t ping, then you have a network problem. Something in your router is blocking the Vero. Check your firewall rules.

What does the output of



what is output of:
ip addr
ip ro

I’ll have a look when i get home.
does the Vero use any special protocols or ports that the default firewall on my router might be blocking?


results for ifconfig

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 4096
inet netmask
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 0 (Local Loopback)
RX packets 15588 bytes 1368920 (1.3 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 15588 bytes 1368920 (1.3 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC> mtu 1500
inet netmask broadcast
ether 6c:21:a2:78:c4:2c txqueuelen 1000 (Ethernet)
RX packets 1284644 bytes 262363418 (250.2 MiB)
RX errors 0 dropped 3461 overruns 0 frame 0
TX packets 1557705 bytes 1180687208 (1.0 GiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

results for ip addr

: lo: <LOOPBACK,UP,LOWER_UP> mtu 4096 qdisc noqueue state UNKNOWN group default
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,DYNAMIC> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
link/ether 90:0e:b3:01:c7:49 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,DYNAMIC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether 6c:21:a2:78:c4:2c brd ff:ff:ff:ff:ff:ff
inet brd scope global wlan0
valid_lft forever preferred_lft forever

results for ip ro

default via dev wlan0 dev wlan0 proto kernel scope link src dev wlan0 scope link

Looks right.
So ping works but ping
How about traceroute

results from traceroute

traceroute to (, 30 hops max, 38 byte packets
 1  gateway (  0.865 ms  0.786 ms  0.687 ms
 2  *  *  *
 3  *  *  *
 4  *  *  *
 30 *  *  *

so it looks like the router is blocking traffic. but i don’t understand. because every other device on my network has no issue. like i said in my original post, i have smart TVs, laptops, servers, AV receivers and mobile devices all connected via ethernet and wifi. so i’m lost.

Me too. What router do you have?
Do you have different firewall rules for IP segments?

its a Zyxel VMG3625-T20A

i’ve tried turning the firewall on the router off, no change.

Well maybe just for testing temporary switch of one of the device that are working (and assign that IP to the Vero for testing).

I’ll give it a shot. i did try changing the Vero to DHCP but i’ll try a different static IP

I tried on a completely different IP address. also no difference.

My last resort is to try restoring an older version of OSMC like like october 2019 and see if that works… not sure though

Could my switch be causing an issue. i replaced my 10/100MB swtches with 2 tp-link gigabit switches

I wonder about the gateway address … what is in your network? Is the right gateway to use? is my router address.

nothing is on

and my router is configured to lease out addresses from -

subnet is

all other devices connected to the router are all able to connect to the internet

The switch shouldn’t affect the WiFi connection, though it might be worth excluding it from the wired test.

It’s unlikely to be an error on both of your OSMC devices. A quick test is try to reboot the router and see if there is any QoS enabled.