No sound on ATV

I have been having problems with not having sound at all on my apple tv with osmc has anyone else had this problem and do they know of any fix. I have osmc installed on the hdd and I’m running the newest version. i have tried

amixer set Master 100% unmute > /dev/null 2>&1
and that didn’t fix it and i have the setting set to hdmi. I’m not sure what else to do.

It will depend on the files you are trying to play.
Are you trying to bitstream or play PCM?

Sam

I just stream stuff with addons. I don’t have sound when moving through the menu or playing videos. This has happened several time the only way i have been able to fix it is wipe everything and do a clean install but after some time i lose sound again.

Hi there,

Unfortunately we’ve had to remove your thread from public viewing because it mentions a pirate addon, repository or website. We cannot provide any support for piracy.

To get a better idea of our piracy policy, please see this link here https://discourse.osmc.tv/faq#piracy You are welcome to edit your post and request for it to be re-listed at anytime.

Thank you for your understanding

Sorry about my mistake. I have edited my post and took out the info about the unsupported repo.

I am replying to this one as it is closest to the issue I am having and I found a solution for it. The audio on my atv1 running osmc stopped working. I have 6 of these running in the same office and users just play videos for our patients. The one device lost audio and I tried everything I could find with no success. My solution was to copy the gui settings config file .kodi/userdata/guisettings.xml from a working unit and the sound came back. I could tell right away as scrolling through menus started making sounds again. If you don’t have a second unit, do a backup of this file when it is working in case it happens in the future. Hope this helps someone.