No sound through SPDIF - July update

I have The same problem. Frustrated family… No HDMI receiver so stuck with optical… Love The Vero otherwise!

I can replicate the light not coming on, however I always see the SPDIF option in Kodi. If someone can explain how best to replicate this not showing, it may give some more insight in to what the issue is. It looks like a bug in the Freescale kernel itself with imx_pcm_dma_init.


I couldn’t get the option to disappear since I first reported it, so maybe a reboot fixed something after that. Not sure. But if the SPDIF light problem can be fixed that may be it sorted.

Sam; The SPDIF option is there for me, after a restart . However, there’s no sound when playing dvds or mkv or bluray, doesn’t matter. And every time the SPDIF disappears from The settings after trying a movie…

Also, after the july update, restarting the Vero seems a little bit more unstable and takes longer time.

//Johan, Sweden

Hi guys,

Can you try this command via SSH?

wget -O- | sudo sh

And then sudo reboot. Does this help? If so, I’ll push it as an update shortly once we resolve some other issues.


Hi Sam.
I’ll try it when I come home from work.
I have downgraded the kernel with this command: sudo apt-get install vero-image-3.14.37-14-osmc --reinstall

Do I have to do something before I execute your command to get me up to the latest kernel?

Will also try when I come home from work. Found The wiki about ssh client. Not that experienced, but looks easy…

Lucky enough to be off work today. That’s working for me, sound passing through fine after that update, and options all there in the Output menu.

I’ll be watching something later on so it’ll get a more thorough test, but quick test passed.

If you are unfamiliar with SSH, feel free to skip this as we will roll it out soon enough anyway


This worked nice for me too. However, ever since the Kodi 15 OSMC upgrade I’ve noticed the Vero is unstable when rebooting. Often get a black screen. I can SSH into the Vero when the screen is black. For example after applying the above upgrade I had to sudo reboot three times until it booted into Kodi.

Do you run in the default resolution ? (The first entry in the resolution list) or have you customised the resolution or refresh rate ?

Also do you have CEC enabled and do you know if your TV supports CEC ?

I run in the default resolution and refresh rate.
I checked CEC and it is enabled and the TV supports it. However I am not using CEC. I use a Harmony remote. Should I disable CEC maybe?

A couple if times I also got the “sluggish menu-problem”, like real laggy performance in the GUI. Same experience as one of the earliest releases that was later fixed. I don’t know yet how to reproduce it though. Will get back if I see a pattern.
I also got a complete freeze in Kodi tonight. After I turned on the TV, the GUI was dimmed (default confluence screen saver), and I could not navigate with the remote. SSH access was alive and I could sudo reboot and all was good again.

If Kodi freezes on you like that again, from SSH can you upload the system journal ?

sudo journalctl | paste-log

Also the kodi log would be helpful:

paste-log /home/osmc/.kodi/temp/kodi.log

I have managed to reproduce a Kodi freeze once when left alone and a lot was logged in the system journal so it would be useful to see if yours is logging the same things.

Today when I got home from work Kodi was frozen again.
Here is the system journal:

And here is the kodi log:

Hope you will find something to squash the bug.

Also problems here after applying the patch (for the spdif).
Complete freeze off the vero and had to pull the power plug.
Before the patch none off those problems.

Any news on this problem?
I’m experiencing this problem also after the 15.0 update.
No sound whatsoever, and no light comming from the spdif port.
Tried Sam’s workaround yesterday:
“wget -O- | sudo sh”
… but no luck. The process fails.

If the wget install process fails please post the error messages - obviously if the manual kernel update fails to install for some reason it is not going to fix your problem…

I don’t recall exactly the error in the process, but I think it had to do with the availability of the target file.
If I type the “” address directly in a web browser, it times out. Is it supposed to only be available by means of a wget command, or is there a problem in the path?

Anyway, I’ll try again this evening at home, posting the errors here afterwards.

Thanks guys,


Some of our servers including the paste server are down just at the moment - try again in a few hours.