No SPDIF sound and squeezed video after September update

Hi, there is no sound after update and also I’ve noticed video looks squeezed in height almost twice

Check your output resolution in Settings->System->Video Output, make sure it is set at a sensible resolution such as 1920x1080p or 1280x720p depending on what your screen can handle. Most likely it is running in some oddball resolution that the monitor might report as its default mode.

I checked all of them, the interface looks just fine, however when I’m playing any video, the image of video squeezed

So what refresh rate and resolution is it set to ?

Can you take a photo of the squashed picture ?

1280x800 @ 59.00Hz

59Hz will not work properly and it’s very unlikely your screen is 1280x800.

Change it to 1280x720 at 60Hz and it will be fine.

My projector NEC NP510W native resolution is 1280x800 @ 75Hz non-interlace WXGA. I’ve checked all different combination of resolutions and refresh rates with no luck.

I do some research and it looks like it has something to do with deinterlacing.

Field extension deinterlacing

Half-sizing
Half-sizing displays each interlaced field on its own, resulting in a video with half the vertical resolution of the original, unscaled.

Also it’s still no sound, here is my sudo journalctl | paste-log
http://paste.osmc.io/zokazehaca

Could you please advise if there is any option to downgrade the system?

grab-logs -a would likely be more useful…

DBMandrake, I’ve found how to fix it, but i have to make it for every video i would to see, so while playing i go to video settings - pixel ration put to 0.50 instead of 1

osmc@osmc:~$ grab-logs -a
Logs successfully uploaded.
Logs available at http://paste.osmc.io/nehabuyoko

Sorry that should be grab-logs -A (capital A) for all logs, small a is only the apt logs which are not helpful for this issue.

So are you saying the video is definitely still squashed if you manually select 1280x720 at 60Hz ? If so I’m surprised that nobody else would have reported a problem like this yet.

1 Like

Hi

This may help you, but without logs it’s hard to say:

As for the sound, I’m not sure of the cause of that yet.

Would you be interested in trying a test build?

Sam

osmc@osmc:~$ grab-logs -A
sh: 1: /proc/cmdline: Permission denied
Logs successfully uploaded.
Logs available at http://paste.osmc.io/teqaviseki

I did, same issue

Yes, I would definitely try it

Sam, what options do I have ?

Hi

I am planning to release OSMC October update over the weekend. This will have some fixes for sound and more exotic video resolutions, so it should resolve your issue.

Sam

Sam, I’ve just updated to October release, spdif sound and video image issues weren’t fixed.

Sam, my Vero is not usable already for 2 weeks. Everytime I start the new video I have to go to video settings - and set pixel ration to 0.50 instead of 1. But still no sound at all. How can i downgrade the system so I can use it until you guys fix the issues ?

Hi

Thanks for getting back to me so quickly,

In this case, the issue that we resolved did not affect you. Can you please enable debugging and run grab-logs -A again so I can take a further look.

Can you please also:

  • Add mxc_hdmi.ignore_edid=1 to /boot/uEnv.txt. You can put the SD card
    in your computer and add this to the end of the file (all on the same
    line).
  • If this still doesn’t work:

Remove the change in /boot/uEnv.txt and enable HDMI tracing:

touch /home/osmc/enable-hdmi-trace

Then after the issue occurs, upload:

/var/log/hdmi-trace.old.log
/var/log/hdmi-trace.log

Also upload your EDID with:

printf "$(echo \0$(find /sys -name edid -exec cat {} +|sed 's/\0x/\\x/g') | sed 's/\ //g' | sed 's/\0//' )" |tr -d ' ' | paste-log

And that should give me enough to find out what’s going on with video. Re. audio: I am not sure what the issue is here yet, but logs should help

We keep an archive of images at osmc.tv/download if you wish to downgrade to an older version temporarily.

Sam

here are the logs
http://paste.osmc.io/erovenugob

That’s funky:

ValidateSAR: Screen SAR: 0.677 (from detailed: yes, 1637x2418)

In the September update, we added support for more non-native resolutions. Kodi is picking up this resolution from detailed modes for SAR calculation which is why things look odd.

Can you also try the other steps above? Your EDID will let me see what resolutions your projector is advertising to OSMC

Sam