No Wifi connection since May update

Hi all,

I just got the May update and unfortunately since then my Wifi refuses to connect. Neither automatically, nor manually.
LAN still works fine.

Here’s what I did to reproduce the problem:

  • enabled debug logging
  • 21:11 (local time) reboot
  • Wait until 21:14 - nothing happening, home router shows vero as disconnected. I am already connected via LAN though, so maybe it’s just not automatically trying to connect wifi
  • Go to MyOSMC network settings → wireless. Adapter is enabled, “Status: No wireless connection”. My Wifi network is shown in the list on the right
  • 21:15 disabled wireless adapter → “Status: Disabled”
  • 21:17 re-enable wireless adapter → “Status: No wireless connection”
  • 21:18 manually select wifi network from the list and try to connect → asking for password (note, this time it asked instantly, when I rehearsed this before it took up to 2 minutes to even ask - not to mention that of course the password should be saved already)
  • NOTE: At this point (before entering the PW) my home router shows the Vero as connected and having its usual IP
  • 21:21 Provide password → “Configuring…”
  • 21:23 Pop up message “Connect to Wifi failed” → “Status: No wireless connection”
  • 21:26 upload logs →

Any ideas what the problem might be?

[Edit] It’s a Vero 4k+ from 2018

[Edit2] Another report here OSMC's May update is here - OSMC - #6 by shebdabe at least it’s not just me

1 Like

I just figured out a temporary solution. My Wi-Fi was encrypted with WPA3 with fallback to WPA2. Switching it to just WPA2 let me reconnect my Vero 4k to my Wi-Fi.

Not the solution I want for the future, but at least it works for now.

Worked for me too. Good find, thanks!

Same issue. Same fix. Disabled WPA2+WPA3.

Have a couple of ideas,

If anyone is willing I can produce a couple of test builds that may allow you to run WPA2 + WPA3 again. Can only test here on a Unifi AC Lite.


Sure, I’d be happy to try

Me too

I have some ideas on how to approach this, but want to collect some more details first so I can take this upstream to ConnMan developers if needed.

If anyone with affected can run an Ethernet cable temporarily and upload some logs this would be useful.



Sure. What logs do you need specifically / what do you want me to do? When I created the logs above I was already connected via ethernet in parallel.

Indeed you did – apologies, will check it shortly and advise.

Thanks for the log


I too am having this issue and I too have just recently uploaded my logs.

Have you provided the URL that you were given when you uploaded the logs?

Hi, I got the same problem. I just updated half an hour ago and now wifi is not working anymore.

Actually I think my problem is different. I’m using WPA2 but after the update I can’t connect to any network at all. And there are some random error or the Vero is not responding if I gtry to connect.

Users only seem to be affected if they have WPA3 enabled on their router. If you don’t, then I suspect it’s a different issue, but without logs it’s hard to say.

I know Sam, but at the moment it is hard to replicate it because sometimes it just won’t connect without giving me an error.

Is there a way to just go back to the previous version and wait for another update in the future?
In the next days I have not much time and I just want to use the Vero for now.
Thanks in advance

Yes - you can reinstall the previous version from the Download page.

Ah ok, Is it one of the .gz files?
Will this delete all of my skins, addons and Kodi settings?
And can I install it via USB? I have no other way to connect to the Vero due to the issue.
Thanks in advance

You can install via USB. You’ll need to take a backup via My OSMC if you want to keep your data.

I am not sure which package is responsible for these messages. Presumably wpasupplicant changed but I am still investigating. With the version after the may update ( 2:2.9.0-21 ) I get these kernel messages

[May12 10:20] wl_run_escan: LEGACY_SCAN sync ID: 4, bssidx: 0
[ +7.999612] wl_run_escan: LEGACY_SCAN sync ID: 5, bssidx: 0
[ +7.001116] wl_run_escan: LEGACY_SCAN sync ID: 6, bssidx: 0
[ +7.929328] wl_run_escan: LEGACY_SCAN sync ID: 7, bssidx: 0
[ +7.070219] wl_run_escan: LEGACY_SCAN sync ID: 8, bssidx: 0
[ +3.783748] Connecting with dc:39:6f:54:11:xx ssid “WiFite”, len (6) channel=36

[ +0.005251] dhd_dbg_start_pkt_monitor, 1724
[ +0.080572] wl_iw_event: Link UP with dc:39:6f:54:11:xx
[ +0.000072] wl_bss_connect_done succeeded with dc:39:6f:54:11:xx
[ +0.028109] CFG80211-ERROR) wl_cfg80211_add_key : WLC_SET_KEY error (-8)
[ +0.000250] CFG80211-ERROR) wl_cfg80211_disconnect : Reason 1
[ +0.000014] dhd_dbg_stop_pkt_monitor, 1963
[ +0.000939] wl_iw_event: Link Down with dc:39:6f:54:11:xx, reason=2
[ +0.000082] CFG80211-ERROR) wl_is_linkdown : Link down Reason : WLC_E_LINK
[ +0.000022] link down if wlan0 may call cfg80211_disconnected. event : 16, reason=2 from dc:39:6f:54:11:xx
[ +0.000005] dhd_dbg_stop_pkt_monitor, 1963
[ +0.066262] CFG80211-ERROR) wl_cfg80211_del_key : WLC_SET_KEY error (-8)
[ +0.000445] CFG80211-ERROR) wl_cfg80211_del_key : WLC_SET_KEY error (-8)
[ +0.001984] CFG80211-ERROR) wl_cfg80211_del_key : WLC_SET_KEY error (-8)
[ +0.000430] CFG80211-ERROR) wl_cfg80211_del_key : WLC_SET_KEY error (-8)

I tried installing a newer version via the bullseye backports ( 2:2.10-8~bpo11+2 ), but that version also fails with the same error.

Can you upload a full log please?

What is your WiFi setup like? Do you have WPA3 enabled?