No wired connection on Vero 4k

Since a week or so I see that I do not have a wired connection anymore. Wireless works fine but is not fast enough to play 4K. What I checked:

  • Moved the network cable to another port on the switch
  • Removed the network cable from the Vero and attached it to my laptop. Everything works fine.

So I know the cable, switch and network access works, however it does not work. Yesterday I bought a new (longer) network cable and it worked for a few hours. Today I get the same message ( No Wired Connection). Also when manually trying to update I get an error message about the update that could not be installed followed by no updates are availabke. My current software version is 2019.07-1

Anyone have a clue how to fix this or is it a hardware malfunction?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

All done. https://paste.osmc.tv/zilecihete

Was the wired network connected and enabled when you grabbed that log?

A couple of thoughts: Have you tried rebooting your router? Have you added any new devices to your home network? It could be a duplicate IP address. Dup IPs can cause all kinds of strange problems. Try removing all un-necessary devices from your network and see if that helps.

If none of that helps, try posting logs again with the wired network connected/enabled. (Or at least boot with it enabled, and if the problem happens switch to WiFi and post logs without rebooting)

The wired network was connected and enabled during time of the log.

I did all that. I had assigned an ip based on macaddress from the router (Netgear Orbi) for months and even removed that but no change. I enabled wifi only after the wired connection stopped working.

In the log I see:
Aug 20 17:16:08 osmc-Nigel connmand[397]: iptables support missing error 2 (No such file or directory)
Aug 20 17:16:08 osmc-Nigel connmand[397]: Failed to flush table ‘mangle’: Invalid argument

Maybe that is the error, but this is new territory for me.

I have no idea how to do a factory reset otherwise I will try that and if that fails then I’m afraid the device is faulty

Those ‘errors’ are normal.

In the log that you posted it appears that WiFi was active when you rebooted.

Nothing else in the logs really jumps out at me. Maybe @sam_nazarko will see something that I’m missing.

So when you say you moved it to a different port on the switch are you referring to another port on a Orbi extender or do you have additional switches in use?

1 Like

I was about to ask the same question. @arno.klaassen, can you try with the Vero connected directly to the Orbi?

Hi,

The Ethernet PHY looks OK from your logs.

Some suggestions:

  • Do you see a light on the switch when the cable is connected?
  • Can you run ‘sudo connmanctl enable ethernet’

Sam

No the light stays off when connected to the switch.

The command states “Error ethernet: Already enabled”

When I plug in a laptop to the same cable the network is available and the light on the switch is on

I meant a different port on the swicth, so I ruled out that the swicth is not working or the network cable is broken. Another device on the cable works fine just not the Vero anymore.

It worked since I got the Vero (about 6 months)

Also connected straight to the Orbi but no difference.

Is there a way to reset the Vero to factory defaults?

https://osmc.tv/wiki/vero-4k/reinstalling-osmc/

1 Like

I have the same/very similar issue.
My wired connection have stopped working on my Vero 4k+.
It reports,“Status: No wired connection” even though I have a working connection (tested with laptop)
Not sure when it stooped but it has been at least a couple of months but I haven had time to troubleshoot until now. Have updated router sw (pfSense 2.4.4) today without any improvement.

Log: https://paste.osmc.tv/ezigaleqix

1 Like

I already thought that some people should have the same issues. Later today will try to install an older version to see if that helps

Teste with all version and no change whatsoever. Seems the network chip is broken.

Your log is completely empty, so it’s impossible to tell.

If you start a support request we can get this swapped over.

Sorry about that. I will cerate a new log and upload on monday. Yesterday I also installed the latest and then last months releases using a sdcard without solwing the issue. When i pluged in an externa USB network dongel i worked fine.
So I also suspect a hw/firmware problem.

What cable are you using? Have you tried another cable?