None of the subtitle add ons can download subtitles

Hello everyone,

We are experiencing severe issues with subtitle download after the May Update (the one on June 5th) on Pi 3 & 2. When the video starts playing, we are trying to download subtitles from various providers (e.g. opensubtitles WITH username/password, Subscene etc) to no avail… The subtitle search never begins for any subtitle provider and the filename is never displayed on the screen, indicating that the search has started. Even if Kodi is turned off and then back on and other videos are selected, the behavior is the same: no subtitles can be searched (and then downloaded).

OSMC debug logs -> http://paste.osmc.io/raw/bupalejala

Any ideas?

Hi,

Are these logs for the pi2 or 3. If its the pi3, you appear to under-clocking it:

arm_freq=900
sdram_freq=450

Also have you checked the subtitle plugins, are updated to the latest version?

Thanks Tom.

It doesn’t look like the subtitles service is actually trying to download them. I’d suggest that you contact the subtitles addon developer for help.

Hello to all,

The issue appears with all subtitle plugins. I am using very commonly used subtitle services, such as open subtitles & subscene. They were all at the latest versiins but I have also re-updated them from the kodi repo to the (same as previously) respective latest versions.

The logs posted @ pastebin are from Pi 2.

I also re-updated the skin, to no effect.

Subtitle download functionality still unavailable.

Hi,

Have you tried un-installing and reinstalling the affected addons?

Thanks Tom.

Hello Tom,

Yes, I have done that as well… that’s why I’m completely baffled…

… as an addition, the kodi units MAY start recognizing the filename and start retrieving subtitles through the addons AFTER they have been power cycled some times, with no additional software installed or parameters changed. Furthermore, it cannot be determinded if 2,3 or 5 power cycles will do the job… sometimes I reset 5 times to no avail, others if I power cycle twice the subtitles start working…

???

Hi,

Equally baffled here, and the logs unfortunately don’t show a lot either.

There could be a config issue, it may be worth starting with a fresh kodi configuration:

sudo systemctl mediacenter stop
sudo mv .kodi kodi.back
sudo systemctl mediacenter start

Add sources, then install a subtitle plugin and see if the issue persists. If it still persists revert the above changes, if not, add your settings and addons back in one by one; untill you find which one is causing the confict.

Thanks Tom.

I thought that it might be a skin error… I’ll try your suggestion with the OSMC-provided skin and not the one that I prefer (Rapier) in order to keep my baseline as close as possible to the distro…

I’ll report back any findings!

I reinstalled OSMC but as of 24hrs ago I cannot install any addon or update kodi. I noticed that download.osmc.tv is not responsive.

Is there an issue with osmc repo?

No connectivity issues from southeast USA here. http://download.osmc.tv responds as expected.

You have a network problem.

Hi Sam,

The browser connects to the site… we receive Error 500, thus I don’t believe it is a network access issue.

Please see attached image… I got the screen shot from IE 11, the same occurs with Chrome and Firefox and on other PCs. I also tried the same website (as well as paste.osmc.io) from my mobile using a 4G connection (not using the metro Ethernet connection of the local network) with the same results.

It might just be a temporary network glitch. See if you get the same problem accessing apt.osmc.tv in a browser.

Some users of Virgin Media in the UK had/have such problems for reasons that are still unclear. Are you with Virgin?

Same with that… therefore, apt.osmc.tv, download.osmc.tv, paste.osmc.io are not accessible from any browser (fixed connection or mobile), they produce Error 500.

No, I am not accessing the internet from the UK but from Greece. Furthermore, the fixed-connection ISP is different from the mobile one (Vodafone).

Is there any geoprocessing involved for clients visiting those sites that may generate this error (just sayin’…)?

This has started occurring about 3-4 days now and all three websites are still inaccessible. The main website, www.osmc.tv, and the forum are running properly with no issues. Furthermore, the paste-logs command from the SSH command-line works properly even though access to paste.osmc.io is not feasible through the browser.

Just to be clear, is there proxy or VPN being used? If so, you need to remove it and see if the issue persists.

The paste-log command now uses https, as does the main osmc.tv site (including discourse.osmc.tv).

Along with now using https, the paste-log command uses a new URL, paste.osmc.tv, which is in line with the main site. Right now, it can be accessed either as http://paste.osmc.tv or https://paste.osmv.tv . Whether by accident or design, the http address does not redirect to https, which gives us a chance to see how each performs on your network.

Most likely, http://paste.osmc.tv will give a 500 error and https://paste.osmc.tv will work. If so, it would generally suggest that you’re being affected by some kind of (transparent) caching proxy, since https traffic can’t be cached. However, the fact that your fixed-line ISP and mobile operator are both exhibiting this same behaviour is puzzling (though I’m guessing that you only checked the Vodafone link after you started to have trouble with the fixed-line ISP, so it might have been that way with Vodafone for a while).

Depending on what you find, we can take it from there.

@dillthedog no proxy or VPN is used, jist direct connections to the internet.

I can confirm that https://paste.osmc.tv/ works from both the landline and the Vodafone LTE connection.

However, MyOSMC cannot update either of the 3 OSMC Pi2/3 I own (it ends with “Error installing, please report this on the osmc forum”) after checking the internet and enumerates the updates). I even flashed one of them with a new OSMC installation and it cannot even connect to the kodi.tv repo to download addons(same behavior with MyOSMC). I don’t believe that the installations have an issue as they were operational 3-4 days ago.
I checked http://apt.osmc.tv and I get an error 500. I then checked https://apt.osmc.tv and I get an invalid SSL certificate for that host. I suspect that this might be the source of both issues, as the OSMC installations cannot connect to the repo (I might be mistaken however).

Btw, how can I re-install the kodi.tv repo from zip file? I cannot seem to find the correct zip file in order to perform the associated procedure within Kodi.

OSMC updates use the unencrypted URL http://apt.osmc.tv and AFAIK there is no https version.

So, as expected, https is getting through and http traffic is giving the 500 error. Please run the following commands, so we can try to get an idea of what’s happening:

traceroute -n paste.osmc.tv
wget --server-response -O /dev/null https://paste.osmc.tv
wget --server-response -O /dev/null http://paste.osmc.tv

For this last test, you’ll need to install httping, so I’m hoping that the Debian repo isn’t also blocked.

httping -s -S -r -l -g https://paste.osmc.tv -c 5
httping -Z -s -S -r -g http://paste.osmc.tv -c 5

Please remember to format the results using the </> edit button.

I don’t know if there is a zip file for the kodi.tv add-on repo.

Hello,

Did all those and here are the results: http://paste.osmc.tv/raw/jerixeqale

The https on apt.osmc.tv does go through BUT it provides an erroneous cert, thus an exclusion should be made otherwise the session will not continue. On the other hand, the repo-used http://apt.osmc.tv gives error 500. The latter I believe is the source of not being able to update the various Kodis…

Just retried http://apt.osmc.tv . It now redirects to Index of /osmc/osmc/apt and it does not give Error 500.

Furthermore, MyOSMC works and the Install from repository as well.