Noob help with connecting to NAS

I’ve just received delivery of my unit but am having trouble browsing my NAS. It supports uPnP, SMB and NFS.

I’ve tried searching help and found an article that tells me how to connect but it’s just not working.

Device is connected to network.

Gone to “Add videos”
tried adding manually using:
nfs:/nas/multimedia
nfs:/nas
Error: couldn’t retrieve directory information
(NAS is the network name, Multimedia is the share)

Tried:
Browse
NFS
It sees the IP address of my NAS but when I click on it nothing happens

Also tried browsing by IP address but again “couldn’t retrieve directory information”

Tried SMB and setting max to SMB1

Just cannot connect to my NAS at all.

Any help greatly appreciated

Which one?

This one: Configuring fstab based NFS share mounts is explaining nfs mounts, try that one.

Try File sharing with a NAS, media server, windows share or other device

Thanks for the reply. This was the article I was using. It says:

To add a network share pick Music (say) then Files then Add music and enter the network location as follows or click left to browse to the location.

If using NFS, nfs://SERVER/path.
For SMB, smb://user:password@SERVER/sharename/folder

And this is the bit that doesn’t work.

The one thought that’s going through my mind is logon details. Would I expect to be prompted to enter them when connecting or do they have to be pre-configured somehow?

Thanks for the reply. I was using this - which seems pretty straightforward but doesn’t work as explained.

The article you refer to seems very involved. Am I just being overly optimistic to have an expectation that it should pretty much work out of the box on the basis there is nothing non-standard about my network?

You normally will be prompted for them but sometimes there are issues with that, but if in doubt check .kodi/userdata/passwords.xml

Personally I would go with the autofs approach, that will give you peace of mind in the long run.

What make of NAS? I found with Synology that I had to tweak advanced options on the NAS to get nfs to work with the Vero, this was not necessary with an LE Pi.

Maybe you could share those advanced options with the forum.

See step 1

1 Like

Depending on the nas type, you may not have the path correct.

Can you ssh into the Vero and enter:
showmount -e (your NAS IP address here)

If you can’t ssh to the Vero, can you run the command from another device (no idea if Windows has this command)?

In my case it returns /export/Music so that is the path to use in your nfs://

“Can you ssh into the Vero”

you need to treat me like an idiot - this is all new to me :slight_smile:

With a lot of googling I have downloaded Putty and connected to the Vero with the correct username and password.

However when I enter the showmount command I get:
"unknown command “showmount”

This helped a little.

On a share on the NAS I can go into NFS properties and turn it on. Now, for the first time, I can see that share - but I still cannot connect to it and I simply don’t get why.

I:
Add Videos
Browse
NFS

It then sees the IP address of my NAS

I click on it and can then see two “shares” (which I enabled with NFS)

However when I highlight one of them and click on OK, nothing happens. It just sits there and does nothing.

Hi,

I believe showmount is included by default, are you running the latest version of osmc? If so try installing showmount, it part of the nfs-common package. Please issue:

sudo apt-get install nfs-common

Please provide logs for this:

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Thanks Tom.

Have you configured your NFS rule for the shares? Here’s one of mine. This works for me as my “guest” account has access to the video share. But to start with you could select the option “Map all users to admin” and see if that works.