[not solveable] Could not set up tvheadend MSI VOX USB2.0 TV BOX

Hi, new to osmc, I’m trying to make TV run.

[EDIT: I gave up. It seems not to be possible to make that device work. Rather keep away from it - or give me a hint. :wink:


First, I tried to install a VDR following: these instructions. But there was a compiling error, so I switched over to TVheadend.

First it successfully installed, but my MSI Vox USB adapter did not appear in the web interface. So I removed tvheadend, and tried to reinstall it - but that permanently fails - displaying a message “please report this error to the forum”. So I’m doing now.

Here are the logs:

Thanks a lot in advance,

According to your logs your Tv-Adapter is not recognized correct, you should create a file em2820.conf with the following content:
options em2820 card=5
save the file and move it to /etc/modprobe.d/
another thing is you must have the firmware file/s for your card in /lib/firmware.
Try to reinstall tvheadend with the following commands:
sudo apt-get purge armv7-tvheadend-app-osmc
sudo apt-get update
sudo apt-get install armv7-tvheadend-app-osmc

Thanks for the quick reply. Reinstalled tvheadend as advised. The DVB adapter seems not to register at startup, it seems to do after unplugging and reinserting.

But it still does not show up in the web interface under ip:9981

Here are the new logs:

Thank you so much!


Did you follow this?

Ufff - right, sorry. I didn’t pay attention for the firmware section.
But - how do I obtain the appropriate firmware? - Links I can find are something like 5 years old, likely not to be the best choice… )-:


So did you follow the first part of @franky384 suggestion?

Well how old is the device? I doubt it is newer than that, or?

Yes, I created a em2820.conf.
I bought the USB adapter last week. It came in the original package - but I’ve not idea, how old it really is.

In the respective folder with the right option? Did you rebooted? Because seems not successful

Nov 29 07:23:19 osmc-westendien kernel: em2820 #0: found i2c device @ 0xc0 on bus 0 [tuner (analog)]
Nov 29 07:23:19 osmc-westendien kernel: em2820 #0: found i2c device @ 0xc2 on bus 0 [tuner (analog)]
Nov 29 07:23:19 osmc-westendien kernel: em2820 #0: Your board has no unique USB ID and thus need a hint to be detected.
Nov 29 07:23:19 osmc-westendien kernel: em2820 #0: You may try to use card=<n> insmod option to workaround that.
Nov 29 07:23:19 osmc-westendien kernel: em2820 #0: Please send an email with this log to:
Nov 29 07:23:19 osmc-westendien kernel: em2820 #0:         V4L Mailing List <linux-media@vger.kernel.org>
Nov 29 07:23:19 osmc-westendien kernel: em2820 #0: Board eeprom hash is 0x00000000
Nov 29 07:23:19 osmc-westendien kernel: em2820 #0: Board i2c devicelist hash is 0xde3500c3
Nov 29 07:23:19 osmc-westendien kernel: em2820 #0: Here is a list of valid choices for the card=<n> insmod option:
Nov 29 07:23:19 osmc-westendien kernel: em2820 #0:     card=0 -> Unknown EM2800 video grabber
Nov 29 07:23:19 osmc-westendien kernel: em2820 #0:     card=1 -> Unknown EM2750/28xx video grabber
Nov 29 07:23:19 osmc-westendien kernel: em2820 #0:     card=2 -> Terratec Cinergy 250 USB
Nov 29 07:23:19 osmc-westendien kernel: em2820 #0:     card=3 -> Pinnacle PCTV USB 2
Nov 29 07:23:19 osmc-westendien kernel: em2820 #0:     card=4 -> Hauppauge WinTV USB 2
Nov 29 07:23:19 osmc-westendien kernel: em2820 #0:     card=5 -> MSI VOX USB 2.0

Maybe I created the em2820.conf in the wrong way? - Group and ownership was root before. I both to osmc - but still I cannot find the card in ip:9981.

ls -l /etc/modprobe.d/em2820.conf
-rw-r–r-- 1 osmc osmc 22 Nov 29 05:51 /etc/modprobe.d/em2820.conf

Recent logs are here:

Thank you very much for your patience!

owner/group should be root.
please post the output of:
dmesg | grep dvb
to see if your Stick is correctly recognized.
lsusb should give you an ID of your stick. Search google with this ID to find the correct firmware.
or look here for more hints: em28xx › Archiv › Wiki › ubuntuusers.de
or try
sudo apt-get install firmware-linux-nonfree


osmc@osmc-westendien:~$ lsusb
Bus 001 Device 008: ID 413c:2011 Dell Computer Corp. Multimedia Pro Keyboard
Bus 001 Device 007: ID 413c:1005 Dell Computer Corp. Multimedia Pro Keyboard Hub
Bus 001 Device 009: ID eb1a:2820 eMPIA Technology, Inc.
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^- guess, this is the candidate
Bus 001 Device 006: ID 214b:7000
Bus 001 Device 005: ID 14cd:6116 Super Top M6116 SATA Bridge
Bus 001 Device 004: ID 067b:3507 Prolific Technology, Inc. PL3507 ATAPI6 Bridge
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

osmc@osmc-westendien:~$ lsmod
Module Size Used by
em28xx_v4l 35404 0
videobuf2_vmalloc 6150 1 em28xx_v4l
videobuf2_memops 2009 1 videobuf2_vmalloc
videobuf2_v4l2 31124 1 em28xx_v4l
videobuf2_core 30026 2 em28xx_v4l,videobuf2_v4l2
em28xx 80422 1 em28xx_v4l
tveeprom 14115 1 em28xx
v4l2_common 6578 3 em28xx_v4l,em28xx,videobuf2_v4l2
videodev 210827 5 em28xx_v4l,em28xx,v4l2_common,videobuf2_core,videobuf2_v4l2
media 18006 1 videodev
bnep 12310 2
hci_uart 22713 1
btbcm 8478 1 hci_uart
bluetooth 425568 22 bnep,btbcm,hci_uart
8021q 22147 0
garp 7622 1 8021q
stp 2430 1 garp
llc 6031 2 stp,garp
evdev 13192 2
joydev 9585 0
sg 23925 0
uas 16127 0
brcmfmac 234779 0
brcmutil 9348 1 brcmfmac
cfg80211 565548 1 brcmfmac
rfkill 22502 4 cfg80211,bluetooth
snd_bcm2835 24938 0
snd_pcm 115812 1 snd_bcm2835
snd_timer 26094 1 snd_pcm
snd 78512 3 snd_bcm2835,snd_timer,snd_pcm
bcm2835_gpiomem 4026 0
bcm2835_wdt 4081 0
bcm2835_thermal 2541 0
uio_pdrv_genirq 3885 0
uio 10428 1 uio_pdrv_genirq
fuse 108681 1
ipv6 448018 42

dmesg | grep dvb - does not give any answer.

This old article says that “eb1a:2820” has generic support.

but only if you install the nonfree linux firmware.
what’s the output of
dmesg | grep em28xx
sudo dmesg | grep em28xx

sudo dmesg | grep em28xx
[ 2035.117319] em28xx: New device @ 480 Mbps (eb1a:2820, interface 0, class 0)
[ 2035.117335] em28xx: Video interface 0 found: bulk isoc
[ 2035.117572] em28xx: chip ID is em2820
[ 2035.385839] usbcore: registered new interface driver em28xx
[ 2036.198421] em28xx: Registered (Em28xx v4l2 Extension) extension

You can try to install all firmware from here:

Thank you. But again, I seem to be too stupid. I cannot find any em2 file in that zip. Or what elso should I look for?

Simply copy all the files in the firmware directory to your /lib/firmware. It seems that some em28xx devices need the xc… , some need the it9135 firmware to work. The additional files don’t cause any harm. If you try another TV-Stick you have the needed firmware in place. This is only to test if it helps in any way.
dmesg | grep dvb must give some output, otherwise your stick is not recognized and i have no more ideas to test.
ps: have you tried to install the nonfree firmware:
sudo apt-get install firmware-linux-nonfree

All, or at least most of the OpenELEC/dvb-firmware files already were in my firmware directory.

Here I found that dmesg - this man has got a MSI VOS TV as as well:

em28xx-video.c: requesting em2880-dvb!
em28xx #0: V4L2 VBI device registered as /dev/vbi0
em28xx #0: V4L2 device registered as /dev/video0
em2880-dvb.c: DVB Init
Loading base firmware: xc3028_8MHz_init0.i2c.fw
Loading default dtv settings: xc3028_DTV8_2633.i2c.fw
xc3028-tuner.c: sending extra call for DVB-T

When looking for it, there seem to be plenty of xc3028 on my rasbpi:

find /lib/firmware/ -name xc3028

But another problem more and more comes to my mind:
Whenever I boot the rasbpi, no em28xx related messages occur in dmesg. I always unplug and replug the stick, then the messages come. Can the firmware only be loaded at boot time?
I consider, whether this is a power problem. But the dvb stick is at a powered hub, so should not cause problems.

I tried to remove my USB hard disk and power the DVB stick directly by the rasbpi. It seems not to work any better:


When trying to install firmware-linux-nonfree, I get these messages:

sudo apt-get install firmware-linux-nonfree
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen… Fertig
Vorgeschlagene Pakete:
Die folgenden NEUEN Pakete werden installiert:
0 aktualisiert, 1 neu installiert, 0 zu entfernen und 2 nicht aktualisiert.
Es müssen noch 0 B von 1.386 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 5.128 kB Plattenplatz zusätzlich benutzt.
(Lese Datenbank … 38189 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von …/firmware-linux-nonfree_0.43_all.deb …
Entpacken von firmware-linux-nonfree (0.43) …
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/firmware-linux-nonfree_0.43_all.deb (–unpack):
Versuch, »/lib/firmware/v4l-cx25840.fw« zu überschreiben, welches auch in Paket dvb-firmware-osmc 1.0.1 ist
dpkg-deb: Fehler: Unterprozess einfügen wurde durch Signal (Datenübergabe unterbrochen (broken pipe)) getötet
Fehler traten auf beim Bearbeiten von:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Removing /lib/firmware/v4l-cx25840.fw does not help.

Still a little out ouf clou…

Sorry, now i’m out of any ideas.

Well seems you got one of the most messy devices out there. To at least trying to get any close I think it is important that we figure out which exact device you have as it seems that you need to configure card and tuner option in the respective files. Maybe post some pictures of the product label.
Also one more question, what TV Signal (DVB-T, DVB-C, DVB-S) are you trying to record once this is working?

This (https://de.msi.com/product/multimedia/support/VOX_USB2.0_TV_BOX.html#down-driver&Win 2000) is the device. Bought it for 3€ incl. postage, but didn’t know that it is so old. And I learned that you rather use older devices than brand new ones with linux. Maybe was not a good idea in this case…

I’m going for DVB-C.

Thank you for your patience - greatly appreciated!