Ocasional sound loss


I have a RPi2 with OSMC, working flawless until February 3 and 4th update came along. I am now having sudden loss of audio, and the only fix is by rebooting it. Can you see anything wrong?

Here are the logs.


Is the pi connected directly to a tv or aer you using an A/V receiver?

Does this happen with all media or just 1 file?

I have been experiencing the same problem beginning with the same update. In my case the audio is connected directly to the TV through HDMI. This happens periodically and seems to always be triggered as playback initiates. Seeing as how very few people are experiencing the same problem, I took a look at my unique settings that would effect a file as it initiates and can only guess that it might have something to do with “Adjust Display Refresh Rate” being set to “On start / stop” or perhaps “Sync Playback to Display” being turned on. The latter might be a default setting though, in which case is an unlikely culprit.

It takes so long to reproduce the problem that I have not turned on debug logging to find out more, but considering that it happens at least once a day, I will try to capture it in a log sometime in this coming week.

A question for utubas, if you’re still around… What type of TV do you have? Mine happens to be an older Sanyo. Also, if you are not using an A/V receiver like CaNsa asked, are you using HDMI for the audio? It would seem unlikely that you’d be using the audio jack, but I thought I’d ask.


I agree with you, it also happens when a movie starts. And yes, I also have enabled matched framerartes… I have a LG TV connected to an amp, but the sound comes from the Pi through HDMI.

I see that this topic is marked as solved, but disabling either of those two video settings to alleviate the problem really only ignores the still outstanding audio issue. When I get some time throughout the coming week, I’ll attempt to record the cause of the audio failure to a log and start a new thread on the issue. I may be able to force it by repeatedly starting and stopping playback of a file.

I’m sorry. It is not solved, must have been a mistake. Already found another topic with the same problem:

Hope you guys can fix it.