October Update and now have lost access to network shares

Completed October update but now have lost access to network shares on Windows 10, I can access my Nas drive on the same network.

I have tried using the naming protocol and also the ip address neither solve the problem.

Using naming protocol I get invalid argument error and then couldn’t connect to network server.
Using ip address I get path not found or invalid.

Log File uploaded url:https://paste.osmc.tv/iziriluyip

All was working until the update.

Thanks for any help.

Do you have user/password configure on Win10 for accessing the share?
Check this thread

Yes I have username and password configured.

Ok, you could try to enable debug logging with enable component specific logging for SMBlibrary and then upload logs again so that we might see what the problem is.
Alternative I always can only recommend to move away from Kodi internal mounts to Kernel based mounts (fstab or autofs) as they always will be more reliable.

Did you do a Windows update recently?
If so, you might want to check your Windows network shared settings.
I’ve noticed that after a Windows 10 update these settings went back to default.

Nothing has changed with Windows as far as updates only the October update applied to the Vero.

I could not see specific log listed SMBlibrary so selected all logs.


Those logs are not debug enabled (see below) and also the option of enabled component specific logging you should find after reading that.

Actually before you might also want to try to set Min/Max SMBprotocol to 3 in Settings - Services - SMB Client

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • enable component-specific logging for all components

  • enable event logging and notification event logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshots:

Thanks I have selected Verbose logging for the SMB library, rebooted twice.
Tried to connect to Network Shares, one with ip address and one with the name as I previously had configured.
Went to MyOMSC and uploded the log

Nothing there :thinking:

Sorry tried again.


Looks like you haven’t tried this suggestion

Also I saw in the log you tried the source with the name did you also try the one with IP?

I have done both of the suggestions and still cannot access the shares.

Please upload logs with that options changed and trying your IP based source

If all not working I would suggest to switch to autofs, but first let us see that last logs.

I set up acompletely new share. Using an ip address


Well this is the same error message as @Rengoor got so I wonder why his solution isn’t working for you.
SPNEGO login failed: The attempted logon is invalid. This is either due to a bad username or authentication information.

BTW, I didn’t saw any request attempt using an IP address.

I did try toconnect using an ip address and the user name and password of my pc has not changed, I have a Dune Prime 3.0 in another room which accesses the shares without any problem. Would you advise me going back to the previous build and trying from there, it did work on that before I updated.

Well that is a solution alternative is to move to kernel based mounts (aufofs).
Also You still hadn’t set Minprotocol to 3 in your last try.

i set Min SMB v1 and Max to SMB V3 was that incorrect, also how do I change to kernel based mounts (aufofs) as I have not seen that in the menus. We are having a severe thunderstorm at the moment so I am working between lightning events if my replies take some time.

For testing I would put both Min and Max to V3 as otherwise Win10 may make problems.

Kernel Based Mounts are not within Kodi (the GUI) but would be a folder based approach.