Old version of MediaInfo / libmediainfo pkg on debian stretch [Solved]

OSMC on Debian stretch only seems to allow installation of libmediainfo v. 0.7.19. This version is ~3 years old and doesn’t allow parsing of media files > 2GB. This is causing me not to be able to parse a majority of my tv series using pymedusa (Issues · pymedusa/Medusa · GitHub) and I was hoping others have found a workaround in the meantime?

Similar issue to this post from Dec '18: Mediainfo

I re-installed a fresh copy of OSMC a couple days ago and that’s when I started seeing this issue. Possibly installing an older version of OSMC or the mediainfo package could also fix my issue?

Yes, Debian has a very old release of mediainfo, but you can still use it.

  1. since mediainfoonly needs to read the header information of the file data, copy the first 4 Mbytes of the media file to a new file:
    dd if="<media file>" of=purgeme.bin bs=1024 count=4096
  2. upload the decoded media information using
    mediainfo purgeme.bin|paste-log

It will be fixed when we move to Debian Buster – and we will have an online (web based version) of MediaInfo soon.

Sam

Just install the newest version on your pc and inspect the files there. Installing mediainfo on to the vero and inspecting the files directly on it is very tedious in my opinion and offers no benefit over doing it on a pc

The media info site has arm packages for raspbian that work on pi3, might also work on vero?
https://mediaarea.net/en/MediaInfo/Download/Raspbian

1 Like

Yes – it should work.

Thanks y’all, building the version from mediaarea repo seems to have solved the issue. Thanks for the help.