On screen display removal?

@skelad01:

  1. you need an ssh client like PuTTY on your Windows system you can find here Download PuTTY: latest release (0.74)

  2. you need to know the IP address of your OSMC device, look at the graphical user interface of your OSMC device under Settings->System Info->Network

  3. Open an ssh connection with PuTTY to your OSMC device, user: osmc, password: osmc

  4. make a backup of the file to change by invoking the command (this is a continuous line)
    sudo cp /usr/share/kodi/addons/skin.osmc/16x9/DialogSeekBar.xml /usr/share/kodi/addons/skin.osmc/16x9/DialogSeekBar.xml.old

  5. start an editor to change the file (all in one line): sudo nano /usr/share/kodi/addons/skin.osmc/16x9/DialogSeekBar.xml

  6. go to the first line from top which starts: <visible>[VideoPlayer.IsFullscreen | ...

  7. in this line remove the string “Player.DisplayAfterSeek | Player.Paused |
    (so the last sign to delete is the pipe symbol ‘|’ )

  8. verify that this line now starts with
    <visible>[VideoPlayer.IsFullscreen | Window.IsVisible(visualisation)] + [Player.Seeking | Player.Forwarding | ...

  9. save the file by keystrokes ctrl and O (not zero) the same time, confirm the file name by return

  10. end the nano editor by ctrl and x the same time

  11. restart the OSMC device by command sudo shutdown -r now

You’re done!

1 Like

The only downside for this is that when the OSMC skin is updated; the changes
will be overwritten.

I setup a poll for this, see Poll, OSMC Skin, Automatic OSD/Seekbar Hiding While Videoplay + Paused.

Great idea :slight_smile:

I am a bit late -__-, but I have just seen it now that a new setting was successfully added to the OSMC skin.

I have just tested it on my Vero 4K, but this setting has different values stretching from 5 s to always.

Wouldn’t it be a good idea to add the “0 s” value ?

I would find that really helpful :slight_smile:

1 Like

Yep, agreed

I didn’t notice this back then, sry. You’d like an option to never show any OSD when pausing? That sounds quite unintuitive… There should always be a GUI reaction when a user issues a command. If adding 0 seconds, there would be none by the GUI. Not sure this is a good idea.

1 Like

I’m sure that the user always notice a command reaction. He can see if the player runs/paused.
It’s possible to configure or opt out: GUI reactions for video/audio player commands?

How is having to wait five seconds for the OSD to clear such a burden? I think Chillbo is correct as allowing this setting to go any lower would likely cause confusion to a lot of people.

1 Like

How is my wanting a specific UI a problem? I don’t want to wait, why is that an issue?

It’s only an issue when it requires a significant amount of dev hours to develop and code in a toggle and give it the option of being mapped to a remote key press for the benefit of <5 users. This doesn’t even address any impact it could have for other users.

The issue is that humans do human things. There are many people who would select 0 seconds not realizing what they were setting and then wonder why they had an inconsistent experience or complain that their skin was broken. The intent of the skinner is for that OSD to be there when you push pause. This has become very common behavior of players of all types.

If anyone wanted to modify the skin on their own install they are free to do so and that is normally the route that people take when they want to venture outside of what a skin developer is willing to do. I’m sure if you search around the Kodi forum you will find quite a few people who posted tweaks they made to someone else’s skin.

1 Like

The other thing is, I figured this out ages ago using the tools people linked me to here. So im surprised this is even still being discussed.

1 Like

After some consideration, I’ve added this to the skin… The existing OSD setting to adjust on-time of the OSD between always and a minimum of 5 seconds has now been expanded to a disabled option which will prevent the OSD from showing up when pressing pause. When pressing resume it’ll shortly show up (for about 2.5 seconds) though as it does when skipping, jumping to chapters or FFing/RWing.

If you want to test this, feel free to follow these instructions:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see, if it works as expected.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.