Oracle Java 8


I have found that filebot is very slow on my Vero 4k so I decided to install Oracle Java 8 instead of openJDK.
I followed instructions and installed it from PPA through oracle-java8-installer.
All went fine with no errors, but now when I type Java -version, I get:

bash: /usr/bin/java: No such file or directory

I tired to set the alternatives, but couldn’t help…

Any advice would be appreciated. It is very frustrating.

You can try the following:

Go to and download the apropriate Java SDK.

Take note of the Version no. which you’ll need later. In this example it is 8u131 Copy it somewhere to your Veros home folder (using Samba, FTP, it doesn’t matter). In the following I assume you placed it under ~/sources/jdk

Run this from the command line:

cd ~/sources/jdk
tar -zxf jdk-8u131-linux-arm32-vfp-hflt.tar.gz
mkdir /opt/jre

We are only interested in the runtime environment JRE, so we’re only installing this and dump the rest. Note that the directory contains the version no. You have to adjust this with the one you wrote down.

mv ~/sources/jdk/jdk1.8.0_131/jre /opt
sudo update-alternatives --install /usr/bin/java java /opt/jre/bin/java 100
rm -R --interactive=never ~/sources/jdk


java -version

Should output

Java™ SE Runtime Environment (build 1.8.0_-)
Java HotSpot™ Client VM (build 25.131-b11, mixed mode)

All that assumes you previosly removed open JDK or installed it with a lower priority.

Hi thank you for the guidance!

Actually I’ve tried before this unsuccessfully, but I used 64bit oracle java package, as the system is 64bit:

uname -a
Linux osmaztk 3.14.29-17-osmc #1 SMP Sat Apr 29 19:09:19 UTC 2017 aarch64 GNU/Linux

I tried with the 32bit and now I’ve got a result…
Seems strange. I wonder why is this.

The kernel is 64-bit
The userland is ARMv7. So use the 32-bit packages

I would be interested to know if performance improves with Oracle Java vs the OpenJDK.


Hi Sam, yes, the performance improves dramatically. Filebot is useless with OpenJDK on Vero 4k.
I would describe it with another analogy: the gaming performance of proprietary vs open drivers of videocard on Linux.