Osmc 17.1 pi config not working (berryboot osmc image)

Hi! I just set up a raspberry pi 3 with osmc 17.1 and i cannot open up the pi config. Is there a bug or something? with 17 krypton it was working fine and i could set up my hifiberry and licences.

There have been no reports. If there is an issue then we need to see logs.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

http://paste.osmc.io/exitimuzuc

Overclock settings do not open up too.

Did you try to run updates yet? If manual update fails in MyOSMC update module, do you have SSH access? If yes, run sudo apt-get update && sudo apt-get dist-upgrade && reboot and then test all functions again.

No such file or directory: '/boot/config.txt'
Well, that’s your problem. Now the question is, why can’t the config file be found?

Linux osmc 4.4.32v7-aufs #1 SMP Fri Nov 18 23:17:35 CET 2016 armv7l GNU/Linux

I’ve never shipped this kernel and it’s not supported in OSMC.
You should already have aufs in OSMC’s stock kernel.

Where did you get this from?

The user’s made a lot of changes to their system, I’m surprised it boots! In the latest versions of OSMC, unless fstab’s / is uncommented, they’ll get a RO rootfs unless using our kernel.

elevator=deadline quiet bootmenutimeout=10 datadev=mmcblk0p2

Also looks like your cmdline.txt is not appropriate either.

Please confirm that the issue exists in a fresh install from osmc.tv/download. It’s rather frustrating when we get half the story and hear ‘not working’ when you’ve made a boatload of changes and somehow considered it unnecessary to mention this fact.

1 Like

We can’t even see what changes you made, because you’ve either deleted the history or someone/something else has:

Apr 22 22:56:17 osmc mediacenter[304]: grep: /var/log/apt/term.log: No such file or directory
Apr 22 22:56:17 osmc mediacenter[304]: grep: /var/log/apt/history.log: No such file or directory

I will close this thread in two days unless this can be replicated on the latest version of OSMC from our website or NOOBS.

It appears /etc/fstab is deleted, so /boot isn’t being mounted. Ergo failure of the modules. I think overclock and settings refusing to load when the file isn’t accessible is appropriate behaviour.

Ah, another case of someone pissing on their system and complaining to us that it’s wet.

Further investigation suggests he’s using BerryBoot.

This isn’t supported, at least at this time, and will cause big problems with OSMC.
Either use NOOBS or install from osmc.tv/download.

I would like to apologize as I couldnt imagine that berryboot images would be so altered that would cause such issues.I used to have just OSMC installed and it was running just fine before. Also berryboot image of 17 was fine. I have tried NOOBS but there was no possibility to add retropie and that was the reason i turned to berryboot. I am really sorry for the trouble. I ll propably use NOOBS without retropie.

1 Like

Why not use OSMC without Noobs and install retroosmc?

Thanks! I ll give it a try.

No problem – I couldn’t work out how your system was so broken at first and thought there was something you weren’t telling us re changes.

Thank you for your interest and sorry for the trouble. Osmc is the most complete option for me so i ll keep my system stable with NOOBS for multiple boot of osmc + rasbian.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.