OSMC 19 and Lightberry

New here,

I have had my raspi 3 for many years running OSMC and lightberry and its been great! but last year I updated my OS to matix and was unaware that it uses python3 and rendered my ambilight (lightberry) setup useless. I uninstalled OSMC 19 and tried to go back to Leia but the OS was unavailable for OSMC. I went to liberec.

Now, a year later, my SD card took a crap so I had to start fresh and I decided to go back to OSMC because I love the skin and easier to read. Some forums I read say that hyperian is working on Matrix but I have not been able to get anything to work.

I made a copy of my initial OSMC/lightberrry (leia) setup but I think it’s on my old computer i no longer have and even if i know where it was, im not sure if i made a copy right lol as i said still new to all this type of stuff

anyway, I SSH a github hyperian config program and PI said it took but nothing works. I installed a hyperian controller from (GitHub - hyperion-project/hyperion.control: Kodi Addon to control Hyperion.) and i have a python module program now but still light action.

Am I missing something? do i need to go back to liberlec with Leia ect? Im still a noob-ish so be easy. I looked into hyperbian but not sure it’ll work with OSMC and i honestly dont know what LED’s i have since i bought them over 6 years ago


PS: I did do research on github, here, raspi sites, hyperian-project and general google search. nothing clearly answers my question or problem that i read.


You can grab any version of OSMC from 2016 at Index of /osmc/osmc/download/installers/diskimages. We also keep the most recent versions at Download - OSMC. You can definitely go back to Leia.

Hyperion doesn’t work with the Raspberry Pi’s new video stack anymore. See Raspberry Pi 4 with Libreelec v19 / Kodi Matrix, no grabber is working · Issue #983 · hyperion-project/hyperion.ng · GitHub and Pi 4 Kodi 19 hyperion with internal grabber.


Well thanks for that info!

But a total noob question…how to install the osmc from the link you provided? i found the disk image i want and downloaded it…is that right?

Download it, then use the tool from Download - OSMC and choose Local Image. Point to the image and image your installation media accordingly following the on-screen instructions.

thanks! i got it to work. took some trial and error with hyperion erros but it all works now! The link you provided for older OSMC was a great help