OSMC 2018.03-1 drops support for EDIMAX AC600

Since upgrade to OSMC 2018.03-1 the EDIMAX AC600 does not work anymore.

So the log is there: log

Looks like VID/PID is idVendor=7392, idProduct=a812

Does echo 7392 a812 > /sys/bus/usb/drivers/rtl8812au/new_id

help?

There is no folder rtl8812au

First run sudo modprobe 8812au

osmc@osmc:/sys/bus/usb/drivers$ sudo modprobe 8812au
modprobe: FATAL: Module 8812au not found in directory /lib/modules/4.14.26-1-osmc

That’s odd.

osmc@osmc-pi3:~$ sudo modprobe 8812au
osmc@osmc-pi3:~$ ls -l /sys/bus/usb/drivers/
total 0
drwxr-xr-x 2 root root 0 Mar 14 18:42 brcmfmac
drwxr-xr-x 2 root root 0 Nov  3  2016 hub
drwxr-xr-x 2 root root 0 Nov  3  2016 lan78xx
drwxr-xr-x 2 root root 0 Mar 14 19:04 rtl8812au
drwxr-xr-x 2 root root 0 Nov  3  2016 smsc95xx
drwxr-xr-x 2 root root 0 Nov  3  2016 usb
drwxr-xr-x 2 root root 0 Nov  3  2016 usbfs
drwxr-xr-x 2 root root 0 Nov  3  2016 usbhid
drwxr-xr-x 2 root root 0 Nov  3  2016 usb-storage
drwxr-xr-x 2 root root 0 Nov  3  2016 usbtouchscreen

Can you run

find /lib/modules -name 8812au.ko

I’m still on kernel 4.14.15-5, BTW.

osmc@osmc:~$ find /lib/modules -name 8812au.ko
/lib/modules/4.14.15-5-osmc/kernel/drivers/net/wireless/8812au.ko

I just found the same. It’s missing from the latest build. I’ve informed Sam.

Thanks

I have the same problem.

Jipp I’m not alone I think semi happy

I should be able to look in to this tomorrow

Hi Sam,

Tired of the problems with these adapter saturado i bought one from you but i don’t have received yet, meantime the upgrade crashed all.

Do you have any workaround???

Thanks

Thanks

Another one here! OSMC Log Uploader

Same here… Tried to compile the driver myself, but then the kernel headers were missing. After installing these I got other error messages and gave up after some tinkering, since a solution might come soon here :slight_smile: . For now I reactivated the onboard 2.4 Ghz.

Use the internal Wifi as @sjoerdju do I do the same there

Hi

As promised yesterday, I’ve looked in to the problem today.

Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

The official OSMC adapter is officially supported by OSMC. You shouldn’t have any problems with this in the latest update. If you are experiencing an issue with this adapter please start another post.

Sam

Great thnx! Doesn’t seem to work yet:

Do you want to continue? [Y/n] y
Get:1 http://ftp.fau.de/osmc/osmc/apt stretch-devel/main armhf rbp-bootloader-osmc armhf 2.8.0-1 [1806 kB]
Get:2 http://ftp.fau.de/osmc/osmc/apt stretch-devel/main armhf rbp-userland-osmc armhf 2.9.0-1 [1196 kB]
Fetched 3002 kB in 5s (589 kB/s)
(Reading database … 69774 files and directories currently installed.)
Preparing to unpack …/rbp-bootloader-osmc_2.8.0-1_armhf.deb …
Unpacking rbp-bootloader-osmc (2.8.0-1) over (2.7.0-1) …
Preparing to unpack …/rbp-userland-osmc_2.9.0-1_armhf.deb …
Unpacking rbp-userland-osmc (2.9.0-1) over (2.7.0-1) …
Setting up rbp-bootloader-osmc (2.8.0-1) …
Setting up rbp-userland-osmc (2.9.0-1) …

etc… (no errors)

osmc@osmc:~$ sudo modprobe 8812au
modprobe: FATAL: Module 8812au not found in directory /lib/modules/4.14.26-1-osmc

osmc@osmc:~$ find /lib/modules -name 8812au.ko
/lib/modules/4.14.15-5-osmc/kernel/drivers/net/wireless/8812au.ko

So still only the old kernel module