OSMC Alpha 4 is here!

Originally published at: https://osmc.tv/2015/02/osmc-alpha-4-is-here/
Hi, It’s been another week and we’ve been working hard. Here’s what’s changed: Bug fixes Fix an issue preventing installation to USB devices Fix an issue preventing installation to NFS shares Fix a variety of issues that can occur when upgrading the kernel Fix black screen when installing some updates Fix calibration for video in…


quick update from first tests

  • boot is smooth and fast… populate fail is gone…
  • wireless connection doesnt work out of box (worked with alpha 3)

i have Zyxel NWD2205 WLAN dongle (rtl8192cu)… dmesg shows rtl8192cu chip is found and doesnt show any errors but i see the light on the dongle is always ON (if i remove the dongle raspberry is frozen)

Also when going to My OSMC settings… network settings are empty no text only boxes are visible… this is also the same with overclock menu… no text only empty boxes.

continuing testing…

Quick and easy install

During first boot there was a error message populate something Didn’t have time to write it down. Disappeared and installation performed fine. Wireless working perfectly. Using a old Patriot USB Wireless. PBO Wirelss Link

Noticed the same with My OSMC networks settings, just empty boxes.Alpha 4 seems to be working fine. Good stuff.

This isn’t a big deal. It shows up because we don’t have, nor need, Device Tree support enabled in the installer kernel.

Investigating no text showing in My OSMC

Thanks Sam. One minor skin issue that I note carried over from Alpha 3 is the text on screen at System Info->Hardware is scrunched up at the bottom and cropped.

With regards to My OSMC Network settings.

I’ll bring this to the skin designer’s attention

While talking to skin designer… Top level menu uses one font and when going down with arrow, menu scrolls up.
When I go to Settings menu, it uses different font and instead of scrolling, it open another submenu (More…)
Not very consistent.

Other than that, installation went smoothly (sd card + wifi), video calibration now works.
One glitch I encountered - Iinstalled a video addon, later removed it and installed other. When I am on the main menu and Video is selected, I see the old one on the screen and new is missing. Reboot solves it.

Is update menu supposed to work already or is it too soon yet ?

I think, but I’m sure Kevin can weigh in, that we’ve only used a different font on other windows as a temporary stop-gap to fix the text overlap issues on most windows. We’re still undecided on the final font size and font face, so we don’t want to put too much time in making things look perfect until we’re committed to the design behind it.

The update menu should be working already. It seems the addon is broken. I will ping @Karnage about this.


got my wireless working (reinstall and dmesg shows first time auth msgs which go now thru)… but i see this 3 times in dmesg log (rtl8192c_common:rtl92c_fill_h2c_cmd(): return H2C cmd because of Fw download fail!!!)

also i confirm video calib is now ok… menus are a lot smoother.

I kept seeing this on alpha 3 too:

FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.

I reckon it can happen without proper reboot/shutdown but this is visible from the very first boot and boots after that ?

Should the weather addons work with this alpha 4? seems addon activation doesnt do anything…

maybe its early alpha thing but in osmc skin settings remove osmc logo + horizontal options have no visible impact

Hey there,
just updated to Alpha 4. Great work Sam and team, it’s really a great user experience so far.
I’m using a RPi B (non-plus) with a HifiBerry DAC. I got it working on Alpha 3 by adding the modules neccessary on raspbmc, but not on Alpha 4. Since adding the modules I’m also not able to use the “My OSMC” tool anymore (“Script error”). Should I provide log files or is this a known issue that’s gonna be addressed somewhen later?
Thanks a lot!

EDIT: my fault! HifiBerry works perfectly when activated via settings-app and without touching any modules :smile:

Hi Bryan,

Missing text in the Network Settings and Pi Overlclock settings seems to be a bug in the OSMC Skin - if you switch to another skin like Confluence you will be able to see both the Pi Overclock settings and Network settings.

We should be able to push a fix for this through the built in update system.

Keep in mind that the Network settings are not functional at the moment - they are still just a visual placeholder while the design is being worked out. The only way to configure your network settings at the moment is while running the installer.

maybe its related… i added one video addon (youtube)… launched it a couple of times and tried a lot other menu items… now i cant get either the addon or ‘get more’ working from the horizontal icon list… for example pressing ‘get more’ gives this:

12:37:03 T:3024015360 NOTICE: DVDPlayer: Opening: addons://more/audio
12:37:03 T:3024015360 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
12:37:03 T:2869142560 NOTICE: Thread DVDPlayer start, auto delete: false
12:37:03 T:2869142560 NOTICE: Creating InputStream
12:37:03 T:2869142560 WARNING: CreateLoader - unsupported protocol(addons) in addons://more/audio
12:37:03 T:2869142560 ERROR: CDVDPlayer::OpenInputStream - error opening [addons://more/audio]
12:37:03 T:2869142560 NOTICE: CDVDPlayer::OnExit()
12:37:03 T:3024015360 ERROR: PlayMedia could not play media: addons://more/audio
12:37:03 T:3024015360 NOTICE: CDVDPlayer::CloseFile()
12:37:03 T:3024015360 NOTICE: DVDPlayer: waiting for threads to exit
12:37:03 T:3024015360 NOTICE: DVDPlayer: finished waiting
12:37:03 T:3024015360 NOTICE: CDVDPlayer::CloseFile()
12:37:03 T:3024015360 NOTICE: DVDPlayer: waiting for threads to exit
12:37:03 T:3024015360 NOTICE: DVDPlayer: finished waiting

if i click straight from the main menu list videos i can get to video add-ons and ‘get more’

also for missing text in my OSMC:

missing text in overclock menu gives:

ERROR: Keymapping error: no such action ‘-’ defined

missing text in network conf:

ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<–
Error Type: <type ‘exceptions.NameError’>
Error Contents: global name ‘connected’ is not defined
Traceback (most recent call last):
File “/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/networking_gui.py”, line 166, in onAction
File “/usr/share/kodi/addons/script.module.osmcsetting.networking/resources/lib/networking_gui.py”, line 251, in populate_wifi_panel
icon_image = self.get_wifi_icon(connected, info[‘encryption’], (int(st) / 25 ) + 1)
NameError: global name ‘connected’ is not defined
–>End of Python script error report<–

Thanks for the reply. I was fortunate that the settings I entered in the installer worked fine for my Wifi adapter. Looking good.

Thanks Sam!
Is it possibile to update via apt from alpha 3?

Alas no. apt upgrades are a little broken in A3


Just installed alpha 4 and all looking good so far except I still cannot browse my external hard drive connected to my pi from my window’s pc

We have not enabled or shipped a Samba server just yet.


Tried some testfiles from http://jell.yfish.us/ with Alpha 4 on my old B, it plays Jellyfish-80-Mbps High@L5.0, min bitrate: 75 Mbps, average bitrate: 80 Mbps, max bitrate: 87 Mbps absolutly stutterfree.

1 Like


Fresh install Alpha 4 (on SD) on Raspberry 1 B ( not B+ )

Raspberry pi Overclock Settings is Black (see picture )

-No Status during Update library ?

  • Skins is not translate in FRENCH, how can i help ?


Hi Sam!

Tried Alpha 4 on my Raspberry Pi 2 today and so far OSMC seems very stable! Good work!

I’ve encountered one small problem: OSMC won’t mount my exFAT drive. If I try to mount it manually (as it shows up at /dev/sdc) I get the following error:

unknown filesystem type 'exfat'

Any idea how to solve this?