OSMC Alpha 4 is here!


Hi Sam,

I’ve found using the new skin with my keyboard trackpad the menus move around uncontrollable fast and unable to get it to select an option due to it moving around that fast.


First time trying osmc. I had a working RaspBMC install prior to todays update. I thought I would try osmc.
The install goes fine. However, It doesn’t see my Wireless USB stick which works fine in RaspBMC. http://edupwireless.com/product-1-2-6-wireless-11n-usb-adapter-en/137263
Not sure what I am doing wrong.
I will have to try hooking up to wired LAN to ssh into it and see if there are any errors.


@sam_nazarko: My newly Raspberry Pi 2 and loaded with Alpha 4 seems not to work with CEC. I experienced similar behavour with my RPi-B. I have tried 2 different HDMI cables to no avail.

I have enabled debug logging of CEC, but not sure how to retrieve the log. Maybe you can guide me how to do that?

For the rest, it’s working flawlessly. It was already snappy on the B, but now it’s even better to use.


Can anyone else confirm having issues with CEC? Our Wiki (https://osmc.TV/help/wiki) should have some info on uploading logs



If CEC problem it’s problem with the tv remote, i have too, i open a post here: Alpha 4 First Impression


This is my log: http://paste.osmc.io/kicidasena


No problems with CEC till now


I can confirm: no issues with CEC (using a Samsung Smart TV).


CEC is working fine here with 2 different setups and TV´s.
Most common issue (I would actually say 9/10 times we get a report) is that the communication between the two fails after an update or new install.
Always reset everything and try again: Unplug (power) your TV and Pi for a couple of minutes and let them reset properly, then boot up your TV before booting Pi.
Make sure CEC is enabled (on some TV´s you need to choose the device) and try again.

YATSE remote + OSMC Alpha 4 - Cannot add host to Yatse

Is there a way to manually configure (by connmanctl) the wireless connection?

I found how to manually connect to wifi doing this in terminal (maybe it helps someone else):
$ connmanctl
connmanctl> agent on
connmanctl> scan wireless
connmanctl> services
connmanctl> connect wifi_somethingsomething_managed_psk
(then the agent ask for passphrase)
connmanctl> quit


you can install the module manually via cmd-line
do sudo apt-get update followed by sudo apt-get install exfat-fuse


This will be fixed in the next release:


Hi Sam

Did have a problem with CEC and a Panasonic TV in alpha 3. Haven’t tried alpha 4 yet but will report back when I get a chance


I have a panasonic tv and i have tried what miappa suggest and know work! Thanks! I have a suggestion for the graphics interface, in the home on the left menu i have choose only four element, movies, tv shows, settings, power, in this order. When i go down with the arrow until the power menu the other option go up and disappear, i think that would be clearer if the menu doesn’t scroll up with a few element.

Last thing, in raspbmc when i power off the raspbmc power off automatically also the tv, how can achieve this feature also in OSMC?



Edit: deleted, my mistake answering to the last question.


Thank you! :slight_smile:


Sam, can you add “hdmi_force_hotplug” to the GUI instead of going to editor and type it?


is it possible to update alpha4 to possible alpha5 (apt-get update or osmc settings) or I need to reinstall it again?
I’m waiting this feature so I can retire my raspbmc sdcard.


I see this on my system as well. I cannot run video addon as a shortcut, I get messages like zxz above. When I go through menu, I can start addons.


the idea is that the update will work. Then again: Alpha Baby! :smile: