OSMC Alpha 4 Raspberry Pi 2 WLAN not working

I configured the OSMC with static IP and WLAN and use a wlan stick which works perfectly in raspbian (RT5370 chip). All modules are loaded and ifconfig shows wlan0, but without IP. I copied /etc/network/interfaces and /etc/wpa_supplicant/wpa_supplicant.conf from raspbian into OSMC, but seems not to help.
I assume that OSMC configures the wlan in a different way.

ps ax shows: /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant

This looks completely different than in raspbian.

One idea I have is the keyphrase for my ssid, it contains spaces! In the preseed.cfg file I see something like :

d-i network/wlan_key string my key phrase with spaces

This could lead in my opinion to a key “my”, because rest is ignored. If this could be, how to fix it? Putting my keypharse in quotes? Which quotes?
BTW, if I plug in ethernet cable, I will get connection via DCHP. During the test with wlan I did not connect ethernet cable, since I know this will cause problems


Please use the search function, there are several threads for this issue.

Thanks for the hint, I searched before a lot and found something like spaces in ssid. Is it also solved for space in passphrase? Should I try to install manually with /sbin/preseed like often suggested? I’m glad for every advice.

Justr take a look at this:
The guide from DBMandrake helped me connecting with my Wlan

1 Like

Thx a lot, renegade, that thread solved my problem! WiFi is up and working! :smile: