OSMC August update + WiFi 5Ghz issue

I have recently updated my Vero 4k+ to the August 21 update using apt-get commands. It all went well but after update I can’t see my 5G WiFi network. I then downgrded (using the installer and bootable flash drive) to last years update and the network is visible. I have since tried updating using the GUI but everytime on the August update my Vero 4k+ can’t scan for 5G networks.

I attach a log file if anyone could point me to a solution to this please, I would be grateful. Cheers.


Assuming your Wifi uses a channel above 100?

Thank you for your reply :slight_smile:

I will try and reduce the channel (it’s currently set at 100) to see if I can scan the network.

This issue definitely seems to be related to an error in setting the timezone during initial setup. I select London as my current timezone (I live in the UK) and yet the time and date are incorrectly set up (as you can see from the log which was taken yesterday). It seems to be stuck on 8 Aug for some reason.

Without an Internet connection the date/time can not be updated

Ah makes perfect sense! Thank you, I tried using the solutions in the other thread (sudo iw reg set GB and/or setting via crda) but to no avail.

I will use the workaround to changing my router channel lower than 100 until we have a solution to this. Many thanks for your help!