OSMC automaticall turns on my amplifier

Default install of the latest version of OSMC on a Raspberry Pi 2 automatically turns on my amplifier when I boot it up, and I don’t want this to happen. The Pi 2 is connected to the TV via HDMI, and the TV is connected to the amp via HDMI. It didn’t do this when I was running the alpha release (just upgraded tonight).

Maybe this thread helps, otherwise I think there was another thread with a similar topic

I’ll give it a shot. I’m struggling to find the location of these config files though.

config.txt is on /boot. But you can also set certain parts of that via “MyOSMC”

Figured it out. Went to Settings>System>Peripherals>CEC and disabled “switch to this device on power on” option, or something along those lines.

1 Like

Forgot to ask you to check that

Well shoot. Problem still there. Whenever I switch the source from TV to the Pi, the receiver comes on.

Are you using CEC for the remote? If not just disable it completely

I would but I’m using the TV remote

Than I suggest reading thru the other CEC/Amplifier Threads maybe somewhere is a solution

I tried what the other thread talks about having fixed the issue, but it didn’t work for me
Adding hdmi_force_hotplug setting in the config.txt did not solve anything.
I have a Samsung Smart TV, and here’s how everything has been connected all this time.
Pi connected to the TV, which is connected to the amp via the ARC HDMI plug
Not sure if this makes a difference, but when the amp powers up, it does so in MUTE mode.

I believe this is a bug and is addressed in the OSMC November update. This will be available very shortly (within an hour or so). It would be great if you could report back.


Unfortunately, the problem persists. When I boot up the Pi, everything is fine. But if I switch the source on the TV TO the Pi, it powers on the amplifier, in MUTE mode.

Hi fishbone,

did you find a solution?
I have the same problem, I tried to change CEC settings but it doesn’t work.
I think it occurred after and upgrade of OSMC.

No, the issue is still there :frowning:

I’m having the same problem. It started to happen when I change my TV (new Samsung with Tizen system). I didn’t had this problem with my old Sony.
Could it be caused by the Tizen? :smirk:

I have the same issue since switching to osmc from a really old raspbian/kodi install. It’s really annoying as my TV is too old to support audio return channel over HDMI :frowning:
The problem should have been addressed in the latest libcec as per AVR power on when changing TV input source · Issue #241 · Pulse-Eight/libcec · GitHub

Is there an easy way to get this package into osmc?

Looks like these settings are part of libCEC 4.0.0. Unfortunately, the upcoming Kodi Krypton is not compatible with this version, so it will be some time before these changes are received downstream.

Ok, I`ve created a patch against the osmc libcec build which adds in the code from libcec 4.0.0 around config.bAutoWakeAVR which makes waking up any avrs an option.
(Though I cannot work out how to change the option, the default of “dont do it”, works for me :))

Builds and works fine on my RPI3 and I can now plug my HT back in :smiley:

I’ll accept a backport of this for Jarvis if you PR it.