OSMC broken after TV being off

@sam_nazarko any news? I assume the website is back up?

The August update is scheduled for Sunday and hopefully will address this issue.

Todays update did not change anything.

Got logs like this:

  1. enabled debugging
  2. shut down TV
  3. TV resumes signal automatically
  4. signal broken (same way as before, 720p, distorted…)
  5. restarted Vero
  6. uploaded logs: http://paste.osmc.io/emahasilip

Likewise, the most recent update has done nothing to fix this on my setup.

I have checked your log for a potential GPU stall, which can sometimes occur, but it does not appear in your log.

I will have a think and work out what information we need from you to progress.

Sam

This didn’t fix the problem for me either

@sam_nazarko any news on this? Most recent update still hasn’t addressed this issue.

New update.
New logs: http://paste.osmc.io/tiqavimuni
Same problem. :tired_face:

Hi

It seems that some users have a couple of different issues in this thread. If you have been experiencing recent freezing since the August update, then we are hopefully on the right track: [resolved] Kodi GUI freezing after TV/AVR source change or while using (July Update) - #19 by sam_nazarko.

My advice would be to wait a short amount of time for this fix to get released and see if it also fixes your issue

Sam

Yes, there has been some freezings. I’ll wait for the update and report back if it helps.

btw @sam_nazarko, gz on graduation!

I don’t have the freezing. So what am I supposed to do?

Hi

On the latest build we have added an option to obtain more debugging information. Currently, the dmesg and Kodi.log’s are insufficient.

Please run the following command via SSH:

touch /home/osmc/enable-hdmi-trace && sudo systemctl restart mediacenter

When you experience an issue, run this command:

paste-log /var/log/hdmi-trace.log and upload the outputted URL.

Please ensure you are completely up to date first via My OSMC -> Updater

Thanks!

Sam

Here you go Sam:
http://paste.osmc.io/nisotefede

You can see 17 edid mode line items. Whenever it changes from 1080p to 720p that is me turning the TV off. When it changes from 720p to 1080p that is me playing a film in 1080p to force the Vero back to that resolution. There are two 720p resolution changes. The first is the TV being switched off and on again. The second is the processor being switched off and it’s passthrough activating. Both actions cause the display to switch to 720p

Do you mean that when you power on the Vero it is in 720p? If so, how are you getting to 1080p, just by playing a video? Do you have an AVR between the device and the TV?

My guess is you do, and when you power the TV back on there is a delay between the AVR realising the TV is ready and passing the TV’s EDID instead of a generic AVR one to the Vero.

Sam

Had a look and might have a quick and dirty fix for this. We will work on this after the GPU stall and SD issue are confirmed as (hopefully) fixed.

I notice that you are losing the double buffer (initially you have 1920x2160), but this goes down to (1280x720 when it should be 1280x1440), which will give you issues with Kodi as well.

Sam

If the TV is on when Vero powers up then I have no issues. It stays in 1080p. If I turn off the TV then it causes problems. As the Vero is always on this causes me problems whenever I need to use the Vero.

Yes, to get back to 1080p I either reboot Vero or I play a file that is in the relevant resolution. This can be a bit hit and miss as the display is all garbled so I generally leave Vero on the movies section with a movie lined up ready to play. Not a great workaround and definitely not wife friendly.

Yes I have an AV processor between the Vero and the TV. However, this works fine on Raspbmc.

I think the others on this thread also have a processor between their Vero and TVs.

I’ll await your fix.

EXACT same story here.
except my workaround is to go into settings, go to display settings and choose any other resolution. then, when Vero brings up the ‘new’ resolution and asks if i want to keep it, i hit ‘no’ and Vero jumps back to 1080p properly. i’ve memorized the keypresses to do this so i can do it without seeing anything on my screen. of course - a huge pain in the ass and definitely not wife friendly…

Hi

Another approach would be to configure your resolution in /boot/uEnv.txt (it is set to 1080p by default) and add the following to the end of it:

mxc_hdmi.ignore_edid=1

This should force your desired resolution and prevent any unwanted changes to 720p. This will require the latest kernel which can be obtained via My OSMC -> Updater -> Manual Controls -> Scan for updates now

Sam

Hi Sam, will this only force the resolution for the UI not the content that will be playing? i.e. that will still switch depending on the source.

It should force the UI to always boot in the resolution set in uEnv.txt regardless of what modes are detected from the AV receiver, but “adjust display refresh rate to match video” should still work.

BTW adjust display refresh rate to match video will never change the resolution, only the refresh rate, and typically only if you are in 1080 as most TV’s don’t support 24fps in anything but 1080.