OSMC broken after TV being off

Hi Sam, will this only force the resolution for the UI not the content that will be playing? i.e. that will still switch depending on the source.

It should force the UI to always boot in the resolution set in uEnv.txt regardless of what modes are detected from the AV receiver, but “adjust display refresh rate to match video” should still work.

BTW adjust display refresh rate to match video will never change the resolution, only the refresh rate, and typically only if you are in 1080 as most TV’s don’t support 24fps in anything but 1080.

Thanks for the heads up. All this time I’ve been reading that setting incorrectly.

I’ll try the uEnv.txt change and let you know.

Ok, I just made the change to the uEnv.txt file and can confirm that my issue is now fixed. Appreciate all the help with this. Very pleased that this has finally been addressed. I can now enjoy my Vero as I originally intended.

Thanks/

sorry for the noob question, but how do i edit the file?
i’ve gotten as far as ssh and can see the file in the directory, but what do i use to edit it?
thanks

to be clear - i’ve opened and appended the uEnv.txt file with pico. the problem is that when i go to exit saving the changes, it gives me an error: Permission denied. is there something i need to do first to allow me to write to this file?

Prefix the command with sudo. Eg:

sudo nano /boot/uEnv.txt

Thanks DBMandrake.
The uEnv.txt edit fix seems to resolve the problem for me too.

I changed that for v16. As we have a lot users with hdmi 1.4b hardware that can do 3840x2160@30hz. Now consider their pimary use case is LiveTV 1080i50 which is best watched on 50hz. As their GPU cannot output 50 hz at 2160p, they run their kodi in normal 1920x1080 (as our GUI scaler sucks, this is a sane approach anyways).

Now when they watch a 4k movie with 24 or 30 hz - we will automatically switch the resolution to their 3840x2160 resolution.

I think the vero does not offer 4k resolutions that won’t be a use case - but it could happen if user runs at 720p but has a 1080p capable TV and is watching 1080p content.

But that will first happen with v16.

Hi @fritsch_xbmc

Thanks for letting us know about this. We will keep an eye out for that change.

Sam

Hi Sam, to troubleshot this I enabled hdmi trace. I didn’t disable this. Should I?

I’ve got freezing on playback and one of the two CPUs is maxing out at 100% when the freeze occurs. The cpu then calms down and the video speeds up until the sound and picture get back in sync.

I’m trying to determine the cause but want to turn off all the logging I turned on when troubleshooting this issue to see if that changes anything.

If not I will raise a new thread with the relevant logs.

To disable hdmi trace, just delete the enable-hdmi-trace file in your home directory you previously created then reboot:

rm enable-hdmi-trace
reboot

Depending on what the device is doing, hdmi-trace will generate a lot of log output and may slow the system down a bit.

Thanks. Have done that and will monitor. The file was 0kb though so not sure if this will help.

The enable-hdmi-trace file is just used as a ‘flag’ to trigger the debug mode - it doesn’t have any contents, hence it is 0kb.

The actual log files created are at /var/log/hdmi.log and /var/log/hdmi.log.1 - you’ll probably find those files are quite big and can be deleted now.

The original problem (distorted signal) is fixed and it is awsum!
But I still have the problem that if the amp has been off, and then I turn it and tv on, it takes really long time (almost 10minutes) for the signal to show up.
And it does not seem to happen, when the amp has been on for a while, even in some other signal source.
The same thing happend with raspberryPi and Raspmc, but maybe it didn’t take as long for the signal show up, just couple of minutes.

Here is the hdmi-trace: http://paste.osmc.io/iseyimikuw Should I upload some other logs also? Even start a new thread?
I got impatient because this time it took over 10minutes and the signal didn’t come up. So I restarted Vero. I guess here are only logs after the restart…

I think I’m going to continue in this thread still, because the topic still applies.

Now I have it so that when TV has been off for a while and I turn it back on, Vero/OSMC dies.
I notices it so that I first SSHd in and put the “tail -f /var/log/hdmi.log” running and when I turned TV and amp on, SSH died.
Here is the end of the log that I managed to get from Putty backlog: http://paste.osmc.io/bafufibugu.md

If I restart Vero while TV and amp are already on I can SSH in again. And then after maybe 10minutes I get the signal in TV.
Here are the logs after that:
HDMI Trace: http://paste.osmc.io/puyihifaqu
All logs from the UI: http://paste.osmc.io/roxuxunemo

Let me know, If I should generate some logs differently.

I wonder if the freezing is related to my issue:

When I turn the TV on, it turns on the Amp, and then the Vero freezes.

Are you running the October update?

Sam

I updates 2 days ago, so I guess it is the newest. In the logs that I provided it says: 4.1.7-2-osmc

No progress with this?