OSMC displays boxes with no text on Apple TV 1st Gen

After two failed attempts with USBs which were too small, I finally got OSMC all the way to ‘QUIT’ and a successful installation on a USB stick.

Replaced aTV wifi card with a Broadcomm.

However, when I power up aTV with USB in I can see the amber light flashing and the USB being accessed by its blue light flashing but nothing appears for 20+ minutes. When it does all I get is a display with various boxes none of which have discernible text in.

I have the right OS state in it and adjusted the HDMI as suggested. aTV is connected to Pioneer HD TVs via an Onkyo A/V receiver. Is that relevant or what is my issue?

Help please.

Can you test by plugging directly into the TV and avoiding the Onkyo?

If I can find a long enough cable, maybe. But I would then lose 5.1 sound etc?

Take a photo of the screen. We don’t know what you mean by boxes

Reseat the CrystalHD card and try removing it. It could be damaged or not installed correctly

Here’s the screen before I try re-seating the card

Well it uploaded but isn’t here?!

Not sure. Artifacts can also mean early signs of GPU failure.

Was the hardware working before?

Yes the aTV was working before I installed the new Broadcomm and I checked again after I fitted it (and before I inserted the OSMC USB) that it was still ok.

I’m simply suggesting a test sir…

I understood that but was mulling ‘aloud’ how if that then worked and was the only way it would, how I’d get round the subsequent complexities. Also wondering if A/V receivers in general are problematic.

All advice welcome.

It could simply focus us on the issue so that we then know where to direct efforts. Not in general, though there have been some issues with onkyo. Typically with CEC function though IIRC.

One step at a time :slight_smile:

I will connect a direct aTV - TV HDMI cable and re-seat the Broadcomm tomorrow morning. Before this I will remove the USB stick and check if the aTV is still functioning.

Results thus far:

1/ Checked again after 8 hours, still the same blank ‘boxes.’

2/ Powered aTV off, removed USB OSMC stick, powered on and aTV works fine with content on its had drive as before. Does this prove Broadcomm is functioning or could it be pushing out 720p and not using it?

2/ Powered off aTV, connected aTV direct by HDMI cable to another HDMI input on TV (avoiding route through Onkyo), re-inserted USB OSMC stick and over the next few minutes Tux appeared and OSMC loaded. Went through set up steps and it seems to be ok.

So now have to understand how it all works as there seems to be no content.

Also have to see whether, now installed, it can work through Onkyo or I’ll have to work out how to route video direct, through a messy, visible additional HDMI cable (others are buried in out of sight sheathing) and audio separately through Onkyo.

Thank you so much for advice thus far.

Update: Could not get audio to function despite setting audio in system to ‘HDA Intel, ALC889A Digital S/PDIF’ as I was using an optical cable. So I reset to ‘HDA Intel, HDMI’, reconnected via the HDMI cable to route through the Onkyo and Hey Presto sound and vision.

Trouble is it is slow and re-boots frequently. Going to order a faster USB to see if that helps.

I’ve read elsewhere here that I’ve come to the party late and that you may give up on aTV 1st Gen? Should I press on and use the bits I’ve bought or is there a better, more reliable solution with longevity?

Well you have a 12 year old device, so it has had it’s fair share of longevity.
I think if you look for longevity and support by OSMC suggest to look at the upcoming VeroX

Can’t cope with this throwaway society :wink: Still running my G3. My 2009 iMac now boasts 4TB Fusion drive. Anyway there’s no fun in buying a unit.

So I’ll compromise: I’ll press on (I can’t send the Broadcom back nor the oredered fast USB) and if Sam guides me as to what feedback will make him keep him connected I’ll try and help provide some.

Also what about a aTV 4th Gen side load as a further thought? Is a seeder’s Developer account good enough to resolve the weekly certificate issue?

BTW just so I understand, is VeroX a Vero2 evolution to be?

It’s not possible unfortunately. It’s very locked down. Apple TV 1st generation is an Intel device, so a bit more hackable. OSMC is a full OS so we can’t run it as an App under the 4th generation device.

Yes. We expect to have a new OSMC flagship out soon. It will be supported for at least 5 years, so no need to replace it in a hurry.

Without an AppleTV patch for Frontrow (OS X), the CrystalHD card is unused in AppleTV OS.

Good. So seems like reseat worked?

Try a faster stick or a hard disk installation if you want to commit to OSMC on the device.