OSMC DVB-T2 and Raspberry pi

Hi everyone,

I recently purchased the OSMC DVB-T2 TV dongle from the store, and I’ve got to say I’m very impressed. Never having used TVheadend before, it was an easy and painless setup and I’m now enjoying all the benefits! Thank you osmc for designing and selling a compatible and easy to use dongle (without driver problems etc!).

Saying that, I am having trouble finding any HD channels, they just don’t show up at all? I had a google and people are saying about all different types of frequencies etc, but I’m not 100% sure what that’s all about. Any ideas/advice would be appreciated.



I noticed on my DVB-T2 tvheadend the HD channels didnt have the HD in the channel name but played back in HD fine. So playback all the channels to check.

1 Like

If your HD channels are on a separate transmitter (mux) make sure it shows up in the Muxes tab. You may have to manually add it. Every country is different, though.

I’ve had a look at the channels and they are not HD (BBC one for example) :-(.

How would I know if the HD channels are on a different transmitter? I’m in the UK btw.

My TVH muxes looks like this:

You should have at least 6 muxes. If you google for UK digital TV you should be able to see what’s availble near you.

Try All UK digital TV transmitters | free and easy

Check the adapters.
You should use 2nd adapter (the Panasonic) for DVB-T2 or DVB-C.

Thanks for the advice guys, I got the HD channels showing okay (I re-scanned using the uk:Sheffield options) but then there was no channel name on a lot of the channels.

I restarted and then this happened,


It lost the connection to the DVB-T2 dongle, it did this before and I had to restore an old backup for OSMC that I had. Any advice on making it see the USB adaptor again, the DVB-T2 dongle plugs straight into the pi, but it won’t recognise it anymore.


Post a debug log and check OSMC is up to date.
If you are on a version < October it will not work properly.

OSMC is up to date, i just double checked, lol

Here is the log file, https://paste.osmc.tv/muzegiwize

1 Like

Kernel shows the adapter is being initialised successfully and loaded.
Doesn’t show a firmware load attempt though.

Check -ls -l /lib/firmware/dvb-demod-mn88473-01.fw
Try a cold boot, i.e. power off Pi for a couple of minutes.


I tired the cold boot, but unfortunately it does the same, it pops up with a little warning saying
“Tvheadend HTSP Client
Server does not respond properly”

I tried the command you gave me but couldn’t work it out, it said that -ls (or Check) command couldn’t be found. I tried using

cat /lib/firmware/dvb-demod-mn88473-01.fw

but it only gave me what looked like garbage, same with

nano /lib/firmware/dvb-demod-mn88473-01.fw

but different garbage, lol.

Am I miss-running the command?

Ops. Sam mispelled the command.

Should be ls -l /lib/firmware/dvb-demod-mn88473-01.fw without the initial -

oh yes! haha, I should have worked that one out!

Anyway, when running that command it gives me the following

-rw-rw-r-- 1 root root 2271 Oct 9 18:02 /lib/firmware/dvb-demod-mn88473-01.fw

Does that help any?

That’s a different issue.
How invested are you in your TVH setup currently?

If you’re able, I’d recommend:

sudo systemctl stop tvheadend
rm -rf /home/osmc/.hts
sudo apt-get remove --purge armv7-tvheadend-app-osmc
sudo apt-get install armv7-tvheadend-app-osmc

This will remove everything. And then following the on screen instructions when you log in to the web interface.



1 Like

That’s fixed it, thank you Sam! Amazing support as ever! :smiley:

It’s working now with the HD channels, however TVH is displaying the wrong programme info for some of the channels, especially the HD ones, so I’ll need to have a play around with the settings I think.

I appreciate this is more of a TVH thing, but any advice would be welcome… :slight_smile:

Wait a bit for EPG to sync.
There’s also the possibility of web based EPGs, but I think Radio Times et al have become subscription only over the years.


I’ve waiting for it to sync, tried to manually sync it etc. but it’s still not showing correctly. It seems to be showing some programs, but not others, for example BBC ONE HD now mainly only shows Flog It apparently!!

How do I use a web based EPG, I’ve googled it, but it all seems to relate to an older version of TVH that actually had tick-able boxes! Mine doesn’t have any of those!

Thank you! I couldn’t find that screen for ages, I didn’t realise I had to turn on the entire User Interface Level to Expert.

It seems to be populating now, so I’ll leave it a while and see how it goes!

Thanks guys :smiley:

HD channels working with EPG info now, so all good!

Thanks everyone