OSMC DVB-T2 dongle reports itself as DVB-T

Just installed my new Dongle to my Vero 4k.
After the usual initial struggles I now have it working with the HTSP PVR Client and can access Tvheadend 4.2.2. from a web browser to configure it.

However it shows as a DVB-T and not a T2 device and cannot resolve the HD Channels from my local transmitter.
Could you confirm that the supplied dongle is as advertised - “Watch free to air DVB-T2 channels” and advise how to convince the Vero 4K box that it is a DVB-T2 device.

Any observation appreciated.

Yes — it’s a DVB-T2 device.

Make sure you are on the latest version of OSMC.

May also be useful to know what transmitter you are tuning in to

Thanks for your very prompt response.

OSMC/Kodi 17.5 compiled Oct 29 2017 , current update I think.

HTSP PVR Client and Tvheadend 4.2.2

The transmitter is UK-Midhurst, which carries its HD Channels on PSB3/770Mhz
There is a good signal and reception on the TV when using the same aerial.

Perhaps I missed something in the setup with TVheadend, there didn’t seem to be a specific setting for DVB-T2 only DVB-T and that’s what it reporting.

Uninstall everything ad reinstall perhaps! :face_with_raised_eyebrow:

Let me double check. The reason I say that is because there was an enablement patch for the DVB-T2 part of the adapter (which should show up as a second adapter); but it may not be in release yet (if I remember there were some issues).

Can you post logs via My OSMC -> Logs?

I’ve been testing a development version as have a couple of others; so release might need updating.



Thanks for that Sam,
Certainly looks as if the DVB-T2 part is not being enabled.
I’ll see if I can get the log file.

Log file should be here https://paste.ubuntu.com/25945398/
Thanks for support

Could you please post full logs, using the MyOSMC app, or grab-logs -A from the commandline after turning on debug logging in Kodi. Edit: I see you have turned on debug already


Should be here now
See https://paste.osmc.tv/ovaqekapuz


I have the OSMC adaptor and when using TVHeadend it reports it as a DVB-T device not a DVB-T2 device. My TV adaptors bit looks like this…


So I’m using the ‘Panasonic MN88473 DVB-T #1’.

Even though it says that its a DVB-T, mine can pick up the HD channels, so I’m guessing its a TVHeadend reporting thing(?).

To pick up the HD channels I had to re-scanned mine using the “uk:Sheffield” options and that’s when it picked them up, they weren’t showing before (I’m in Sheffield obviously, so pick the nearest one to you).

(I am running OSMC on a pi though, so things may be different…)

Thanks, as you can see mine is slightly different.


I’ve tried the advice that you were given but without success.

Forcing a scan on the HD Mux just returns ‘Fail’

As you say this seems to be a TvHeadend issue rather than a OSMC one.
It just isn’t seeing the DVB T2 part of the Dongle.

I hoping OSMC have a solution!


I think maybe only @sam_nazarko has the answers.


Sorry for missing this and thanks to @fzinken for reminding me.
I’m working on the solution for this. I want to have this resolved in the next update



Thanks Sam,
I briefly installed TVHeadend on my Mint18.3 laptop and enabled the dongle.
It did display itself as DVB-T/DVB-T2/DVB-C so as you say the issue was not with the dongle. :blush:

I await your updates.

Many thanks for your support,


I have the same issue on my DVB-T2 TV dongle so I do not see DVBT-T2 option and T2 channels. I can only see DVB channels so i’m looking forward to get an update to fix this :slight_smile:

Gunnar Atli


I was about to write down my experiences after I got the Vero 4K together with the USB-Adaptor last week and did quite a bit of testing during the weekend.

Overall I’m really happy with the Vero itself. It works fast and seamless even when using the shipped remote for navigating through the menus when connected to a monitor instead of TV.

BUT said to say that the USB-dongle is definitely not compatible to DVB-T2.

Simply put the used SDR-chip RTL2832 does not support all transmission modes that might be used in DVB-T2, but only the subset known from DVB-T. Comparing the relevant parameters in wikipedia the differences become quite obvious. In Germany for example DVB-T2 broadcast commonly uses LDPC+BCH for FEC, one of the “19/…” guard intervals and a 16k DFT size. In contrast, according to the specs the chip already lacks support for the used DFT size (only 2K and 8K).

To my knowledge the only or at least most known chips for DVB-T2 reception come from Silicon Labs, for instance the Si2157 tuner together with the Si2168 demodulator. These chips are used in various products, for instance the VG0022A from Logilink, CINERGY TC 2 from Terratec or PCTV 292e from Hauppauge.

I will give it a trial to get the Logilink stick working during the weekend for German DVB-T2 according to this post referring to a patch description. Assuming I get this working it would be interesting to know whether these stick(s) will be continuously supported in the future? A brief look into /lib/firmware and kernel drivers suggests that this shouldn’t be a big issue at least.


That’s not actually correct.

The DVB dongle supports DVB-T2. I am watching DVB-T2 on it as we speak. The DVB-T2 signals are handled by a Panasonic demodulator, not the Realtek part.

After the next update, you should be able to select the Panasonic demodulator in TVHeadend.


Sorry for my misleading statement! Indeed the MN88473 supports all demodulation features required for DVB-T2, while I was not aware of it replacing the RTL2832.

Thus it would be great to see it working with the OSMC stick to return the Logilink stick I just bought without even giving it a trial. When can I expect the update? From what I remember the Vero at the moment still uses the October release.

2017.10-1 is the latest version.
There will be a new version soon. We usually do a monthly update, but Debian Stretch has pushed things back a bit.


Thanks a lot! :grinning::grinning::grinning:

Can confirm now the stick to be working with German DVB-T2. I plugged it into my Ubuntu 17.10 PC, added “dvb-demod-mn88473-01.fw” to /lib/firmware and afterwards “w_scan -ft -c DE” found a bunch of T2-muxes. For the two most important local channels it even worked indoor with a tiny passive antenna :+1:

The only small challenge after all are the obviously outdated channel lists in tvheadend, i.e. parameters are referring to the old DVB-T2, which has been (mostly) switched off already.

Hi @AndreasK

Thanks for confirming that the stick is suitable for the German market. I’m sure this will reassure some others.

It will shortly be fully functional on Vero 4K as well.

Thank you for your patience



Any updates on when the OSMC DVB-T2 dongle will work on the Vero4k?

I can just see the DVB-T adapter after upgrading to the December '17 update