OSMC Initial Release for ATV1, Installation Help Thread

Mixmax, thank you so much for thinking to do this.

I have just done the install, I did not use the USB at all, I just grabbed the image from the same download page for the OSMC installer.

I have a Windows machine, unzipped the IMG file, used a program called Win32DiskImager, but am sure any image file burner can work. I put the ATV hard disk on an external drive enclosure and sent the image to the drive. BOOM! Plugged the drive back into the ATV and it booted right up after some screens. Then proceeded to hit the manual update and all went thru smoothly.

Am running some more movie tests on this but currently have the “Beast TV” build installed on it and it is sweet!

ATV + OSMC(Sam & developers) + the “Beast TV” = Non-Stop Grinning!

Huge thanks Sam and all involved…

Ah. Makes sense. Any suggestions on brands?
Also, after it got stuck, I had to go into disk management and delete one of the volumes and reformat as exfat. The HP USB formatter didn’t even see it at first.
Now I have 246MB Unallocated that I can’t do anything with. (This is on both the Sandisks and the PNY.)

I´m glad to help, It’s nice to be able to provide a working alternative.

Urgh. Well I tried again today with a Kingston DataTraveler G3, 16GB, 2.0 which previously held a USB install of CB2 that I used whenever I needed component output. Same issue - hangs at the end of Installing Files. I left it alone for over an hour. I think I will just give up and stick to CB2 for now.

Hi guys,
My 2 cents to this conversation.
I had OSMC running on USB and after a month I got message that it can’t update OSMC.
After a few restarts I got the frown face.
I decided to reinstall and I couldn’t get it to install again running the OSMC installer. (stuck on “Installing files”)
I went back to Win32image and the installation went just fine. (USB version)
I will try to install the HD version with Win32image later today.

Thank you for bringing back to life my Apple TV.


Don’t bother. As has been stated, the HDD install is broken and you usually end up with a read only partition.
Rest assured it’s being worked on.

Thanks for the heads up ! :smiley:

We’d love to get some netcat output from those that run into the system stalling at the end of “installing files”
The cause can be a bunch of things and without netcat there’s no way to see the actual logs since ssh isn’t running at that point.
To use netcat, you need to able to edit the boot configuration on the ext4 partition, have the ATV1 on a wired network connection, and netcat available on another computer

I just wanted to express my thanks to Sam for his super awesome work in offering all ATV1 users a chance to continue to enjoy their aging hardware. I am amazed at how well OSMC is working on the ATV1.
I have a question regarding MPEG2 decoding as I use my ATV1 to view live TV and recordings from my MythTV PVR. I noticed that the ATV1 is dropping many frames on 1080i material, not so much on 720p, and it appears to be using the ff-mpeg2 decoder rather than chd. I toggled deinterlacing on/off which made little to no difference in performance on 1080i material. Also, I noticed that the CPU0 is at a constant 100% on both 720P and 1080i, which could be indicative of the processing required for the software decode of the MPEG2 stream? I am hoping you can comment when you have the time.
I’m happy to use the ATV1 as a streaming device and the PVR functionality is simply an added bonus!


The CHD card only decodes H264 in OSMC.

Spinner, thank you for the prompt reply, I had figured the lack of MPEG2 decoding was due to it being removed from KODI. I know there are many threads online regarding MPEG2 decoding on different platforms on KODI. I believe KODI reverted to software acceleration due to specific problems with DVD viewing. It’s very hard to complain about the ATV1, considering that it is almost 9 years old! :open_mouth:
Perhaps I need to consider spending some money on newer hardware that offers superior MPEG2 decoding and deinterlacing support, as my Nexus player performs poorly in this area as well. It’s definitely fun to tinker, as I believe that is how Sam and others like him, are able to breathe new life into old technology.

I hope your home viewing goes back to normal soon, so that you may appreciate merry matrimonial harmony for the holidays!


576i/720i/1080i mpeg2 TV broadcasts, can be software decoded and deinterlaced on the ATV1, used it for years now with my compiles of Gotham / Kodi / Crystalbuntu.

Settings in the Video OSD:

Deinterlace video > Auto
Deinterlace Method > Auto select
Video scaling method > Bilinear

Scroll down > Set as default for all videos.

Using - Deinterlace Method > Auto select - actually uses the basic software Bob deinterlacing method.
If you have 1080i h264 TV Broadcasts, just set Deinterlace method > Deinterlace (half)
This setting for 1080i h264 will then be remembered for that particular Channel only.

This will be as good as you can get without running out of CPU processing power.

The best quality deinterlacing I have in my house comes out of an AMLogic S812-H box, that uses Advanced motion adaptive Edge enhancing Hardware deinterlacing. Its excellent, particularily for fast action sports broadcasts :smiley:

So I installed the OSMC onto a USB boots up no problem seems to work well. (havent configured everythign yet…)

The only thing weird is that when I reboot the ATV it doesnt boot into OSMC, instead reboots to defaults ATV os from the HDD, even though the USB is still plugged in.

In order to get back to OSMC I do a hard reboot ( unplug power) and replug the power to get it going.

How would I solve this?


Thank you wrxtasy, very much appreciated. I believe that you are the same guy from the KODI forums and I have read many of your previous posts regarding the deinterlacing performance of the AMLogic chips. I’m looking forward to purchasing a Wetek Core in the near future.

In my region, the OTA broadcasts are 720p and 1080i, for obvious reasons deinterlacing is only required on the 1080i streams. I believe MPEG-2 is the only codec allowed for OTA in North America.

I will check my current settings against your recommendations and see how things turn out. I am aware of an unofficial OE 6.0 build by chewitt which I may consider, to see if this offers any performance improvements.

It seems to be a tricky issue getting these devices to work well with MPEG-2 streams and deinterlacing. Point in case, some of the recent MPEG-2 issues on the Nvidia Shield with Jarvis, but you appear to be well aware of those.

Onward and upward, I say, have a great day!


I’ve never run into the problem, but then I didn’t keep the original ATV1 OS for more than a couple days.

It may be that the USB device isn’t responding quick enough for detection, so the HDD boots

You can force the ATV1 to boot from a bootable USB device by pressing “menu” and “-” on the remote while it’s restarting.


CrystalHD decoding was removed from Kodi with the release of Kodi 14, but I have re-added it to Isengard and will be doing the same for Jarvis.

MPEG2 and VC1 never worked reliably with CrystalHD acceleration. Remember that CrystalHD is a black-box decoder. We upload firmware to it, and we DMA MPEG2/H264/VC1 in and we get frames out. I believe the reason VC1 and MPEG2 never worked properly was because we weren’t configuring the decoder properly. I’ll take a look in the New Year and see if there’s a quick way to get this working with CHD accelerated.

As @wrxtasy suggests, this is your best method for deinterlacing on the AppleTV. In the interim, until I get an opportunity to explore if it’s possible to get VC1 and MPEG2 working, I have made sure that this type of content is never sent to the CrystalHD decoder. In the past, you would get a black screen on some content and would have to manually disable hardware acceleration, which was very much a pain. Now, OSMC will only accelerate H264.

Indeed – AmLogic can do very good (adaptive) deinterlacing, which is one of the many reasons the OSMC Vero 2 is based on an AmLogic SoC.

Please let me know how you get on with that and if we can do anything to improve OSMC. We should have the hard disk installation coming very soon, which should help out those guys wanting to use their SSDs.

That’s correct – the aTV isn’t enumerating it quickly enough. Unfortunately, there’s not much that I can do to remedy that, but you should have more luck with a different USB stick. May I ask which USB stick you are using at the moment?



Sam: thanks for the detailed reply and for all of the effort you continue to put into this project!:osmc:


Yay, someone used it!


Its weird because I never had this issue with my CHD installation on the USB.

why would the CHD reboot to KODI and the osmc reboot to default ATV?

EDIT: read Sams, response… its true I installed the OSMC on a different USB then the CHD.

I’m going to try to reinstall on the same USB as the CHD (which was working fine for the reboot)

I ran the latest OE 6.0 unofficial created by chewitt and the same difficulties with 1080i MPEG-2 streaming and deinterlacing persist. I will say that OSMC seems to have better performance on 720p-1080p Blu-ray videos. :smile:

I have verified that my settings in the Video OSD are identical to wrxtasy suggestions. I may have to try the Crystalbuntu2/KODI instructions and see if things turn out a bit different.


I experimented with mpeg2 CHD Hardware decoding a while back and whilst it would decode there were a lot of jagged block artifacts in the resulting picture. VC1 I recall may have been a bit better.[quote=“slot47, post:142, topic:10029”]
It seems to be a tricky issue getting these devices to work well with MPEG-2 streams and deinterlacing. Point in case, some of the recent MPEG-2 issues on the Nvidia Shield with Jarvis, but you appear to be well aware of those.
mpeg2 and .vob containers are causing a number of issues across various platforms. A few of us behind the scenes have given the Kodi dev. Koying some code ideas to work around this known problem. You will be happy to know this combo plays fine on the ATV1. :smiley:

The other thing I will say is I’m running v4.0.7 of the TvHeadend server on an OE AMLogic device (C1) in the backend. This version fixes a lot of streaming problems. v2.1.18 is the TvHeadend client on the ATV1.

BTW. Crystalbuntu2 will be no different if you cannot get mpeg2 deinterlacing working out of OE6.0.0 / Kodi Isengard 15.2

Wrxtasy: I’m glad I didn’t spend any further time and effort trying to go back to CB2/KODI15, and I won’t be attempting this after your comments. :+1:

I can fire up a TvHeadend Server(4.0.7) on my Ubuntu box(14.04) and see if this changes the situation as it could be MythTV. I have noticed that KODI identifies my OTA live streams as 25 FPS, but the recordings are listed as 29.97. Here in the Great Green North, we are using NTSC, so that seems like a strange anomaly. Perhaps this is just a cosmetic error? I can always go one step further and configure ServerWMC on one of my Windows 7 boxes.

Just one final question: The additional CPU usage wouldn’t be related to the fact that 1080i OTA content is being distributed at a much higher bitrate than a typical DVD as it relates to the MPEG-2 codec?


P.S. I think I might be getting something that thrills me to the CORE for Christmas!