OSMC kernel update issue

I tried to run the update, but the process failed and a popup dialogue told me to report this in the forum. What is the best way to do this? Also, after the failed update all my 4K (HDR) content play really choppy :frowning:

Same issue here. Installing on a Vero 4K+. Install failed with error message “Error Installing: vero364-image-4.9.113-64-osmc:arm64” and now 4k playback is extremely choppy (we’re talking ~2fps)

Please post logs. @bcollins92 also.

Hi @grahamh . Could you please tell me how I can create these logs and send them here?

Settings->MyOSMC->Log Uploader->Upload Selected Logs Now … and post the resulting URL here.

1 Like

Here you go: https://paste.osmc.tv/qukexuhapo

I also have the same exact problem as described by @bcollins92 and @erikvdkuilen after attempting update v19.4. Error message and now choppy 4k playback.

Here are my logs: https://paste.osmc.tv/ehoruruhum

Here is my url @grahamh :smiling_face: Thanks for checking it out

https://paste.osmc.tv/okemavayum

Just a small addition: I just watched a 1080p file and that also had a lot of frame drops. I did another upload for the log, hope it helps

Https://paste.osmc.tv/opimawozek

@erikvdkuilen @bcollins92 @jt30

The issue you are experiencing (update error, slow playback) has occurred because your system hasn’t been updated for some time. In future, I’d suggest keeping your device up to date more frequently.

This issue was solved here in November: Error after November update. It only needs to be performed once.

Alternatively, you can reinstall OSMC.

I’ve moved this to a new thread.

For issues, I recommend starting a new thread for issues instead of posting on the release thread.

In short: you can run this via the command line:

sudo apt-get install --reinstall vero364-image-4-9-113-64-osmc:arm64

or check for updates again via My OSMC.

Cheers

Sam

2 Likes

Hi Sam, I have three versions of the vero364-image installed, which is weird. Can I uninstall old?

osmc@osmc:~$ apt list --installed | grep vero364-image
vero364-image-3.14.29-160-osmc/now 160 arm64 [installed,local]
vero364-image-4.9.113-60-osmc/unknown,now 4.9.113-60-osmc arm64 [installed,automatic]
vero364-image-4.9.113-64-osmc/unknown,now 4.9.113-64-osmc arm64 [installed,automatic]

Thanks Sam. I’m sure my system was up to date (I certainly hadn’t rejected any updates when prompted) but I guess not. Either way, the “sudo dpkg --configure --pending” command fixed the problem and everything is now working as it should be.

Thanks again, and apologies for not posting in the right place.

That’s odd @sam_nazarko , since I have auto updater active. I’ll just do a complete reinstall and see what happens.

update: works for me again :slight_smile: Thanks everyone for all the help

We automatically purge older kernel versions – unless configured otherwise, so there shouldn’t be any action needed on your side.

Glad things are working as expected now. This issue occurs if updating from a very old version of OSMC. It should not re-occur now.

Appreciate your quick reply! That worked perfectly, thank you. My apologies on posting in the wrong thread. Noted for future reference. Like the others have mentioned though, I have auto update enabled, update after every prompt, etc. As far as I’m aware, I should have been up to date. Maybe not though.

Hello,
I too had the same error message and so on with the March update.
Hopefully everything was solved running “sudo dpkg --configure --pending” as recommended here and in Nixo’s other post about November update.

But I am 100% sure I never skipped one update since a year at least, so even if this is easily fixed, there might be another reason than upgrading from a too old version.

@Sam, in case it can help, here are my last 3 updates.

osmc@Vero4K:~$ apt list --installed | grep vero364-image

WARNING: apt-real does not have a stable CLI interface. Use with caution in scripts.

vero364-image-4.9.113-55-osmc/unknown,now 4.9.113-55-osmc arm64 [installed,automatic]
vero364-image-4.9.113-60-osmc/unknown,now 4.9.113-60-osmc arm64 [installed,automatic]
vero364-image-4.9.113-64-osmc/unknown,now 4.9.113-64-osmc arm64 [installed,automatic]