Osmc / krypton / subtitles

First post and first off I hope I won’t be wasting your time. I’m no sort of expert with my little media set-up and may well be overlooking something that should be obvious, but here goes. The last OSMC update left me with a brand new look and – unfortunately – the inability to use subtitles. I’m deaf, so the subtitles are a necessary part of my viewing experience. I went through the Settings - Player - Language - Subtitles setup to enable subtitles and so forth, so far so good (I think). I tried to play a file and check for a subtitle file, which downloaded, but will not display. When I access the in-play screen that shows details about audio and subtitles, it shows Enable Subtitles / Subtitle Offset and Browse for subtitle in a bright gray. The Subtitle function is grayed out and cannot be accessed.

It’s probably something easy and silly that I’m overlooking, but I’m … well, I can’t think of anything else to try and would very much like to be able to use my little Pi. Has anyone encountered anything similar since the latest update? Any advice?

I’m completely lost without the subtitles.

One other thing – when I try to view a show where I’ve already obtained a subtitle file, it displays just fine, so … the problem seems to be in the downloading? I really have no clue & any help is much appreciated.

Apologies for my newbie status and if I’m wasting anyone’s time.


Have you tried this: Local Subtitles not displayed while playing mkv file

It worked for me.

Thank you so much! Much appreciated. :slight_smile: