Local Subtitles not displayed while playing mkv file

Hi guys,

i’m new to raspberry and osmc so sry for the newbie question.

I’m trying to play a mkv file with embedded subtitles. Problem is, that the subtiles were not displayed although osmc is recognizing them (in subtitle menu “local subtitle available” and also in the audio menu the right subtitle).

So … do you have any idea what the problem could be? I really dont get it. Tried it with some mp4 files and it worked perfect.

I found a reddit post from a few days ago which is saying, that it could be a bug, but no “official” statement from developers. http://www.reddit.com/r/raspberry_pi/comments/2vmowu/

So thx for your help

ps. off course subtitles are enabled :wink:

It is probably SSA/ASS subtitles since that is part of the Matroska container format.
You will need to go to the console and run:

sudo apt-get install libass5

That will install the missing library used for those kind of subtitles. It will be corrected in a later update/release.

1 Like

Thank you!

…after installing the library everything works fine :slight_smile:

Hi, I tried doing this, but I just get an error saying it can’t find libass5. Can anyone tell me what I am doing wrong please?
Thanks,
Dave

As with any Debian based system you need to run this command first to update the apt cache, and the upgrade any already existing pacakges:

sudo apt-get update
sudo apt-get upgrade && dist-upgrade

Afterwards run:

sudo apt-get install libass5

This will update Alpha 4 to the most recent packages and then afterwards you install the SSA/ASS-library.

Strange, I play MK4’s all the time and never have had a issue with a subtitles not displaying. I do use the plugins for Subscene and opensutitles.org to download the subtitles.

Subtitles you download are mainly .srt. Subtitles embedded in .mkv can be almost any format and it is the SSA/ASS format that the current alpha dont have builtin support for.

Many thanks, that worked perfectly :slight_smile:

Cool, and thanks. This might explain my difficulties as well. I’ve gone through the steps, but I haven’t tested results with playback yet.

Hello… I’m also new to this… When I try to make that command (sudo apt-get install libass5) in my terminal to Openelec I get the following reply.

There is no working ‘sudo’.

On debian/ubuntu/all general purpose linux distributions ‘sudo’
allows a permitted user to execute a command as the superuser
or another user, as specified by the security policy

With OpenELEC you have root access by default, so you dont need ‘sudo’

VERY informate but also very confusing… I’m guessing you guys control your media station in some other way. Care to tell me how?

Thanks in advance…

I’ve replied to your other post here:

Sam

I guess this issue is still actual.

This seems to be the best thread for it so I’ll continue here.

Did the 3 apt-get commands but still no subtitles.

Added a few subtitles service providers so I guess I’ll manage but would still like to figure out why this doesn’t work.

Back to basics (mentioning irrelevant stuff as well just in case). Used CladDVD to rip a DVD (*), shows subtitles properly in VLC on my main computer. Sure have the subtitles in OSMC enabled visibly (tried fixed and bottom just in case) as I can see subtitles if I go and fetch one from podnapisi.

OSMC shows Local subtitle available.

Now what?

More info:
Had Raspberry installed on one of the original/early Pi’s since 2103 (Hardware says BCM2078 = Pi1?). Started to get video stutter recently on lots of files so finally got fed up and upgraded to OSMC. Way snappier (mostly), good job. Maybe time to donate again (although my quota for this year is full :slight_smile: ).

*) File info shows (apparently this is for subtitles?). Haven’t had to dig around considering these issues for ages.
Text #1
ID : 189 (0xBD)-32 (0x20)
Format : RLE
Format/Info : Run-length encoding
Muxing mode : DVD-Video
Duration : 1h 24mn
Delay relative to video : 31s 231ms

Thank you very much, I had the same problem and it worked, you the real MVP

Thank you

That helped
Cheers