OSMC Marches on with early update

We normally stick to a single monthly update, but we're pushing out an early one this month to improve support for the new Raspberry Pi 3 and Vero 2. Here's what's new:

This is a companion discussion topic for the original entry at https://osmc.tv/2016/03/osmc-marches-on-with-early-update/

Great work guys. Thank you for working so hard to push this out!

Awesome, thanks!

I’m going away for a few days, so I had to stay up all night to get this done, but it looks like I got it done just in the nick of time.



Thanks for your dedication!
Really appreciate it.

Don’t let stupid comments get you down :slight_smile:

I hope we haven’t upset you while running around you begging für an RPi3 Version, like a dog begging for his ball.

Thanks indeed! :+1:

Yes Thanks.

I confirm a little error with a 2nd Wifi (eg USB-Dongle) I can’t confirm the Licences and get to the GUI, without no problem and after also no problems with the Dongle may there is a way to deactivate the onboard wifi.

I was able to go through the initial walk through this morning without issue

Looks like I’m not the only one

Tried it 2 times with the USB-Wifi-Dongle the next without works like it has to

Once again Sam and the team, you guys have done everyone proud.

Appreciate all your hard work. Looking forward to giving this a try lateron.


Thanks sam just wondering if you got time to backport those dvb t2 drivers for the vero 2 in this update understandably if not with everything else going on! Thankyou for the hard work!

Hi Sam and the rest of the team.
First of all thanks for the smooth transition towards the RPi3! I had a RPi2 previously, so I just had to make sure I updated it before switching the SD-card to the new RPi3.

1 question though: Could you maybe post the contents of what cmdline.txt and config.txt should look like for the RPi3. I’ve taken out the overclock settings I previously used on the RPi2, but I also noticed my config.txt still had dtoverlay=lirc-rpi in it, while it should be dtoverlay=sdhost now, right?


These are two unrelated settings. The first is for enabling GPIO IR receivers, the second is for enabling the sdhost SD card driver. You can have multiple dtoverlay lines in config.txt.

Thanks, however, no sign of sdhost in my config.txt, while according to the changelog it should be the default, so that’s why I’m asking how the default cmdline.txt and config.txt should look. Just to do a quick check for does that have been using the same SD cards through multiple versions.

Yes it’s the default again on Pi 2/3, when there is no entry in config.txt to override it.

You can check if its active with:

dmesg | grep sdhost

If you see no match it is not active.

Nice, I’ll write a short review on the vero2 soon. I guess after some harsh and a bit sarcastic posts from me I owe it to you guys. Vero2 is already near perfection for me. After completing my setup it runs some services simultaniously without any issues and unpack speed is also great!
Just 2 things that come in mind:
Is the option to disable shutdown on keypress in kodi: settings -> system -> power management -> function for "off" still greyed out? Would be nice to turn that off.
And second: Did libcec also land or does it take some more time? Now cec on vero2 kind of works but signal is lost after some time. Possibility to send a cec command to vero2 which can turn on tv and av receiver would also be nice, … if that is even possible. (I guess it also greatly depends on the tv and avr model) If I recall right, my old pi1 runnning raspbmc could turn on my lg tv.

I don’t quite follow what you’re trying to achieve here - this setting controls what happens when the shutdown function timer expires - at the moment the only option is to shutdown, hence it is greyed out.

If you don’t want this to happen, simply set Shutdown function timer to Off.

Great work!

Question: I’ve been running OSMC on RPi3 previously by using an RPi2-installation image.
Now after updating within OSMC the overclock profiles still seem to run at default RPi2. 850 CPU clock. :cry:

Will this change if i re-install entire OSMC with noobs RPi3-image? Or are there no RPi3 clock/overclock profiles within OSMC at all right now? :slightly_smiling:

The changes to get OSMC working on the Pi 3 were done in a very short period of time so the Overclock profiles have not been updated yet.

So you have two choices:

  1. Manually remove any speed related lines such as arm_freq from config.txt and reboot - this will allow the Pi 3 to boot at its default clock speeds. Make sure you don’t re-enter the Pi overclock module or it will be reset to defaults, which will actually be Pi 2 defaults. (Eg underclocked for a Pi 3)

  2. Look up the default clock speeds for the Pi 3 on the Raspberry Pi website (I don’t know what they are off hand) and use the custom option in Pi config to manually configure those speeds to match. Or you could edit config.txt directly and the Pi config module will honour the changes you make.

Edit: Directly from @popcornmix, these are the default Pi 3 clock speeds:

Default for Pi 3:


So if you use the custom overclock to manually select these speeds your Pi 3 will run at the correct default speed.

In a future update we will fix the overclock profiles properly.

1 Like