OSMC Marches on with early update

:heart_eyes:
Thank you so much!

On my harmony remote the on/off button is programmed to switch tv+avr on or off. It is also a “cec button” which, if pressed shuts down the whole system because of the setting in kodi. I don’t need to shutdown the system or kodi. If I really need to, I ssh to vero2 and type systemctl stop mediacenter. If I need to shutdown the whole system I type systemctl shutdown now. (which btw doesn’t always seem to work, somtimes it seems system hangs on restart).
There’s a keymap editor addon in kodi so I could just change the button to not send shutdown. But during config I need to press it to specify. And guess what,… vero2 turns off then.
Another way i think is to edit remote.xml file but before that I need to know the name of the button.
I know turning on debugging in kodi and with tail command I can see pressed buttons but once again if I press on/off vero2 shuts off.

wait, it doesnt actually shutdown. I was misstaken, i had this issue with the hummingboard and turning the option to off solved it.
Strange, i linked it to 2 system freezes…
Now since a few days everything works flawlessly…

Hi Sam.

I have used your NOOBs/build.sh to make new NOOBS compatible package to use in my Dual Boot images.

Using a Raspberry Pi 3
Now, I was wondering why it didn’t seem fast and checked the config.txt (after it has booted)

gpu_mem_1024=256
hdmi_ignore_cec_init=1
disable_overscan=1
start_x=1
dtoverlay=lirc-rpi:gpio_out_pin=17,gpio_in_pin=18
disable_splash=1

#NOOBS Auto-generated Settings:
hdmi_force_hotplug=1
arm_freq=850
core_freq=375

I’m using the latest NOOBS 1.8.
I assume this is a NOOBS bug - appending the wrong arm_freq and core_freq?
Does NOOBs append these settings after it installs each OS?

I’ll check it out.

Did you open and close My OSMC -> Pi Overclock by any chance?

Nope. Fresh install via NOOBs.

I’ve posted a bug over at the NOOBs github as it appears to be them still adding in Raspberry Pi2 frequencies.
It’s odd that they do this though - I thought they would just leave all the Pi’s to use their default values.

Those are not Pi 2 frequencies. I’m pretty sure this is actually a My OSMC issue. We’ll wait for @Karnage to report back

Hmm. I thought because they were under

#NOOBS Auto-generated Settings:

That noobs had added them…

or do you think NOOBS added just the hdmi_force_hotplug
and OSMC has then added the 2x lines below it?

Have downloaded the new installer for mac on both Mavericks and el Crapitan. When I try to use them neither recognises the device (SD Card) that I am trying to update. The SD card is being seen by the mac in both cases and appears on the desktop but even refreshing the device selection on the installer does nothing. Any suggestions?

As additional information I have tried with different SD cards and none have been detected. If I insert a usb stick and refresh then the USB is detected. I am trying to set up a ps2 with a wired connection and asking for the latest osmc update. If I ask for the earlier update then the card is still not seen although it had previously worked. All cards are visible on desktop and disk utility has verified the cards.

A side question, will this the final being for the RPi 2/3 one Image for both? Sam talked about a different userland and there will be no crossupdate between RPi 2 and RPi 3, so my question is how does it goes future?

OK solved the problem. I was using the same micro sd adapter for all the cards and it appears the adapter was broken. Have changed adapters and now updating cards.

Arghh!!! You know some days just don’t go well. There was nothing wrong with the adapter I had accidentally locked it. Totally wasted day.

No, Sam was talking about x64 builds for Pi3.

Ah ok so unless there is an 64bit Version of OSMC we will stay with two Images one for Pi 1/Pi Zero and one for Pi 2 /Pi 3 ?

Exactly.

Thanks for the lightening.

Hi, thanks for the info. Are there any issues with usb wifi or vnc connectivity (or restoring default internet settings)? After the updater rebooted my raspberry pi I can no longer access it through ultravnc, though SSH works fine.

Where can one find the image download for this March release?

I can only find the 3 February release under Download - OSMC which gives the rainbow screen with 4 long flashes, 4 short flashes on RPI 3

Thank you

The image is called 2016.02-3.

Sam