Osmc-no-secure-path edited!

So I succesfully have locked myself out of my system, because of no root access to OSMC.

I was looking for fixing the problem “make: ldconfig: Command not found” on the internet and found that maybe adding a line to “/etc/sudoers.d/osmc-no-secure-path” would solve my problem.

After rebooting OSMC can’t boot up, just getting a sad smiley and constant trying to reload.

Is there no way to fix this?

When trying to use sudo to rewrite the file I’m getting:

/etc/sudoers.d/osmc-no-secure-path: syntax error near line 1 <<<
sudo: parse error in /etc/sudoers.d/osmc-no-secure-path near line 1
sudo: no valid sudoers sources found, quitting
sudo: unable to initialize policy plugin

Please help, I really would appreciate not having to refresh the sd-card and start on a new…

Boot to a root shell by changing init in cmdline.
Mount rootfs manually and edit the file.

Or use a Linux LiveCD to edit the card

Don’t edit files randomly in the future unless you are sure what you are doing

Root is locked, there is no root access on OSMC?

Not sure what you mean… “Boot to a root shell” - how?

cmdline on my Macbook?

Search the forum for ‘init cmdline.txt’ and click the first result

You are a hero! Do you also have the solution to my problem with ldconfig?

I am not able to download any programs easily in a normal way… I would like to install wiringPi to the raspberry. Isn’t this possible?

ldconfig should work fine without any issues. I’m not really sure what issues you have, but I suspect it may be due to some changes you have made on your system

This is my problem… And I’m always getting problems with dpkg - even after I had tried to reinstall on new.

➜  wiringPi git:(master) ./build
wiringPi Build script

WiringPi Library
make: ldconfig: Command not found
Makefile:131: recipe for target 'uninstall' failed
make: *** [uninstall] Error 127

That build script is likely mangling your PATH

Set a full PATH before calling ./build, or run the commands manually

Make sure ./build is using bash

What is meant here? I have tried to search in the build file where the problem starts, but can’t find anything where the ldconfig is mentioned?

I guess the “make” is giving me troubles. Sorry for being such a noob. I’m glad you want to help me…

If you are able to run sudo ldconfig without issues then path is not the problem, the script is.

I am sure you can probably make and make install WiringPi manually

➜  wiringPi git:(master) sudo ldconfig
sudo: ldconfig: command not found

Well I’m not able to run sudo ldconfig without issues …

  • But I can run “sudo /sbin/ldconfig”

This gives me following

/sbin/ldconfig.real: Can't create temporary cache file /etc/ld.so.cache~: Permission denied

Than you successfully broke something in your system

osmc@osmc:~$ sudo ldconfig --help
Usage: ldconfig.real [OPTION…]
Configure Dynamic Linker Run Time Bindings.

-c, --format=FORMAT Format to use: new, old or compat (default)
-C CACHE Use CACHE as cache file
-f CONF Use CONF as configuration file
-i, --ignore-aux-cache Ignore auxiliary cache file
-l Manually link individual libraries.
-n Only process directories specified on the command
line. Don’t build cache.
-N Don’t build cache
-p, --print-cache Print cache
-r ROOT Change to and use ROOT as root directory
-v, --verbose Generate verbose messages
-X Don’t generate links
-?, --help Give this help list
–usage Give a short usage message
-V, --version Print program version

Mandatory or optional arguments to long options are also mandatory or optional
for any corresponding short options.

For bug reporting instructions, please see:

You seem to have made some changes to your system that have broken this.

I’m not sure what they are but checking your shell history may help.

A reinstall may be the best way to address this

Great… ^^ There is no way else to install wiringPi?

There are probably pre-built binaries.

But if you have issues with running ldconfig then you will have problems on your system sooner rather than later. We don’t know which commands you ran and don’t have logs to investigate.

Is would just be pretty sad to refresh the SD-card, because of the many modifications I’ve made to the Kodi Skin, the addons and so on. :frowning:

It’s quite simple to backup your kodi config. We’ve provided the function to do so easily in MyOSMC.

So I figured out that the problem is when I start to configure Skin.confluence by my own.

Sudo ldconfig worked before I started to configure and didn’t after.

What should I do here?

What commands have you run to edit the skin?

I’ve just modified a lot of files in the skin.confluence folder and removed some image files.