Osmc November update dependency error

Got the message of avaiable update today and chose no to update later.
Now I ran apt-get update and apt-get dist-upgrade via ssh and got several errors concerning version of vero2-image-3.10.104-8-osmc

Now running apt-get update gives me an error saying the process got interrupted and i should run dpkg --configure -a.

Running this gives me error saying dependency problems prevent config of vero2-kernel-osmc.

vero2-kernel-osmc depends on vero2-image-3.10.104-8-osmc; but:
Paket vero2-image-3.10.104-8-osmc is not installed. So stays unconfigured.

Running apt-get dist-upgrade gives me this:
E: Sub-process /usr/bin/dpkg returned an error code (1)
And suggests to use -f.
Now apt-get update also tells me to try apt-get -f install. Trying this gives another errors and sad faces.

It clears the ssh screen so i don’t know exactly what but something like it’s not allowed to delete and reconfigure vero2-kernel-osmc or vero2-image-osmc…
Please help, don’t know what to do now.

It seems to me like update routine only updated vero2-kernel-osmc but not vero2-image-osmc??.. idk.

PS: I can provide the output but it’s in german…so I shortened it and kind of translated it.

The image is there in the repository.

Have you been installing anything else with APT that’s perhaps in a partial state?


sudo -s
export LANG=C
apt-get update
apt-get install vero2-image-3.10.104-8-osmc

And paste the output

No, I haven’t.
Ok, suddenly no error with apt-get update

But running apt-get install vero2-image-3.10.104-8-osmc gets me this:

apt-get install vero2-image-3.10.104-8-osmc
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt-get -f install’ to correct these:
The following packages have unmet dependencies:
vero2-device-osmc : Depends: vero2-kernel-osmc but it is not going to be installed
E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).

And apt-get -f install gives me:

Reading package lists… Done
Building dependency tree
Reading state information… Done
Correcting dependencies… Done
The following packages were automatically installed and are no longer required:
libass5 libenca0 vero2-image-3.10.104-1-osmc vero2-image-3.10.104-2-osmc
Use ‘apt-get autoremove’ to remove them.
The following extra packages will be installed:
vero2-image-3.10.104-8-osmc vero2-kernel-osmc
Suggested packages:
fdutils vero2-doc-3.10.104-8-osmc vero2-source-3.10.104-8-osmc
vero2-image-3.10.104-8-osmc-dbg vero2-manual-3.10.104-8-osmc
Recommended packages:
initramfs-tools linux-initramfs-tool kernel-common
The following NEW packages will be installed:
vero2-image-3.10.104-8-osmc vero2-kernel-osmc
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/9843 kB of archives.
After this operation, 25.8 MB of additional disk space will be used.
Do you want to continue? [Y/n]

Preconfiguring packages …
Selecting previously unselected package vero2-image-3.10.104-8-osmc.
(Reading database … 38006 files and directories currently installed.)
Preparing to unpack …/vero2-image-3.10.104-8-osmc_8_armhf.deb …
Examining /etc/kernel/preinst.d/
Unpacking vero2-image-3.10.104-8-osmc (8) …
Selecting previously unselected package vero2-kernel-osmc.
Preparing to unpack …/vero2-kernel-osmc_3.1.4_armhf.deb …
Unpacking vero2-kernel-osmc (3.1.4) …
Setting up vero2-image-3.10.104-8-osmc (8) …

Hmm. There is a symbolic link /lib/modules/3.10.104-8-osmc/build
However, I can not read it: No such file or directory
Therefore, I am deleting /lib/modules/3.10.104-8-osmc/build

Hmm. The package shipped with a symbolic link /lib/modules/3.10.104-8-osmc/source
However, I can not read the target: No such file or directory
Therefore, I am deleting /lib/modules/3.10.104-8-osmc/source

Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.10.104-8-osmc /boot/uImage-3.10.104-8-osmc
run-parts: executing /etc/kernel/postinst.d/inform-updater 3.10.104-8-osmc /boot/uImage-3.10.104-8-osmc
run-parts: executing /etc/kernel/postinst.d/upload-to-nand 3.10.104-8-osmc /boot/uImage-3.10.104-8-osmc
6+1 records in
6+1 records out
6320128 bytes (6.3 MB) copied, 0.639011 s, 9.9 MB/s
Setting up vero2-kernel-osmc (3.1.4) …

Seems like it worked now?..

That looks fine.

Try sudo apt-get -f install again and if that returns no errors you are fine.

Some reasons this can occur:

  • you ran apt-get upgrade in the past
  • the repository didn’t update completely
  • some other packages were in a partial state


Did a reboot and no error when running apt-get -f install now.
Strange…but no error is good.

Always am carefull not to run this.

Alright, thanks anyway!

It’s possibly your Vero 2 checked for updates when a mirror was in the process of updating. This is rare, but with the # of users we have, it can happen.

If at the time, vero2-kernel-osmc was updated, but the vero2-image-osmc updated Deb wasn’t present, APT wouldn’t be happy. Fortunately the solution is always a quick apt-get update && apt-get dist-upgrade – it’s just a temporary network issue.