OSMC November Update - Samsung CEC

CEC on my 2 Samsung TVs have stopped working, is there a way to fix it? Have power cycled TV and pi any ideas?

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

You “power cycled” or you actually shut it down and pulled the power plug from the wall for a moment? Because it does matter…

Same issue here with LG tv. Unplugged both TV and Rasp Pi B+, still not working.

Try only booting the pi after the TV is fully booted and on the correct HDMI input?

If no joy there, please provide debug enabled logs.

I power cycled TV as per the instructions on this site http://support-us.samsung.com/cyber/popup/iframe/pop_troubleshooting_fr.jsp?modelname=HLN617W&idx=137718&modelcode=&

to be more specific about my problem:

I have updated my Raspberry Pi B to the latest OSMC Update released as short while ago and since then I cannot use my Samsung controller to control OSMC, I’m relying on Yatse Andropid App

The AnyNet+ CEC setup menu shows no CEC devices

I have told OSMC to log everything and have just hit the upload logs button and given the following URL: http://paste.osmc.io/xojemizapu

Still no go. Peripherals blanked out in settings as well.

Found this in log:

15:47:15 24.980453 T:3025023536 ERROR: Unable to load libcec.so.3.0, reason: libcec.so.3.0: cannot open shared object file: No such file or directory 15:47:15 24.980768 T:3025023536 ERROR: Initialise - failed to initialise bus cec

I have the same in mine.
Fear not, Our glorious leader is on the case.

This is good news! I look foward to hearing about the fix :smile:

Same here on 2 Samsung TV, hope to see this fixed…

Yesterday I installed OSMC (October build) on by RPi v1. TV is LG. Remote control via HDMI-CEC / remote working just just fine.

Today, I notice that there was an upgrade (28th November build), so I did a manual check for upgrade, and upgraded the system.

Now, the remote control via HDMI-CEC no longer works, and I wished I did not upgrade so quickly :frowning: I’ve tried rebooting, powering off completely, etc. No joy.

???
Jens

Can you explain how you did this?

Same on my Sony TV that has always worked until I just updated to November release. Device no longer listed in Peripherals.
About to check logs.

Edit: same logged error - cannot open shared object file: No such file or directory

My OSMC/Updates/Manual/Scan for update

Regards,
Jens

1 Like

Looks like we may have found the issue… Standby for resolution shortly…

2 Likes

Temporary fix till update is release: Please only attempt if you know what your doing.

Sh into pi (suggest using putty)

enter the following commands:

ln -s /usr/osmc/lib/libcec.so.3.0.1 /lib/libcec.so.3.0
ln -s /usr/osmc/lib/libcec.so.3.0.1 /usr/lib/libcec.so.3.0

restart and cec is working again. Not sure why osmc is not looking for libcec in /usr/osmc/lib. But this sorts it.

Thanks Tom.

(please delete if I’ve over stepped any lines, just trying to help)

Don’t do that.

Wait a few minutes please

Sam

I just did the update to the November release and lost CEC function on my RPi 2. Went to check the configuration in System | Settings | System | Input devices | Peripherals and found the Peripherals option greyed out and unselectable. This is the first time I’ve seen this behavior. I enabled logging and uploaded the logs to http://paste.osmc.io/celevedaho

Hoping for a quick solution.

Your log says you have a Pi 1 not a Pi 2 ?

Can you please post the output of the following two commands:

dpkg-query -L rbp1-libcec-osmc | paste-log
ls -al /usr/osmc/lib | paste-log

For anyone with a Pi 2 having the same issue, replace rbp1 with rbp2.