OSMC on Raspberry PI. Won't start IPTV streams

With Krypton so soon to be released and quite possibly containing the fix, it’s unlikely much time will be spent on the issue in Jarvis. If the patch you provided is the solution then this is a Kodi problem, not an OSMC issue.

Hi,

Yes, it also happens on other OSs, but this doesn’t necessarily mean that it’s a Kodi problem, as it doesn’t happen for example on Kodi for android. It could also be a component or a library that linux based OSs use, or the KODI implementation on these OSs use, …

Let’s continue using Kodi v14, till Krypton is available and PVR working on it.

Best regards,

I’m bringing this up again as I was stumbling over the same kind of trouble when I tried to add an iptv playlist to my Vero4. The log showed me the 404 error, but I was able to get it running with LibreELEC on a Raspi3.

Unfortunately, I am too much of a noob to find the difference between both distributions and fix it on my osmc (which is the distro I prefer, and I would like to stick with the Vero4).

Any ideas?

Thanks in advance!

Datti

Which IPTV provider?

Some seem to block the OSMC useragent specifically. It’s worth asking your provider if they do this.

Thanks for the reply. I will contact the provider to find out if they are blocking the OSMC useragent. Any particular reason why anyone would do that?

If they are, is there a way to hide the useragent or spoof it? :wink:

Datti

Im having the same trouble even though my providers says they really dont filter user-agents. But they do. Maybe just not intentional. I have got it working now by spoofing another user agent by adding “|User-agent=Kodi/16.1 (Macintosh; Intel Mac OS X 10_11_6) App_Bitness/64 Version/16.1-Git:2016-04-24-c327c5” to the end of every url in the playlist. I just googled an user-agent. I have made a script though which downloads the playlist and adding the working user-agent to the URLs at boot.

Note that just “|User-agent=kodi” is not enough. I have not had time to do more tests though. Going to be interesting to see if the string “OSMC” is blocked. Im guessing so. I dont know though if the User-agent string has to be formatted in a picky way though.

Working: Kodi/17.1 (Macintosh; Intel Mac OS X 10_11_6) App_Bitness/64 Version/16.1-Git:2016-04-24-c327c5

Not working: Kodi/17.1 (X11; Linux armv7l) OSMC/2017.04-1 HW_RaspberryPi/1.0 App_Bitness/32 Version/17.1

1 Like

Just to let you guys know I’m still watching this.
Please keep me posted from your providers.

So far no reply from my provider. But I can confirm that Zissou’s user-agent worked like a charm. I now have the streams running on my Vero4. Thanks! (and I will get back as soon as I get a reply about the reasons OSMC is being blocked)

Yep it’s definitely the OSMC user-agent being blocked, I have run some tests now. Im also in contact with my provider about the issue once again.

Im trying to get it working also, but i dont. So how do you type it?

http://domain.com:8080/get.php?username=XXX&password=XXX&type=m3u_plus&output=ts&"|User-agent=Kodi/17.1 (Macintosh; Intel Mac OS X 10_11_6) App_Bitness/64 Version/16.1-Git:2016-04-24-c327c5"

Like this?

No, remove the &" in the end, the URL should look like:

http://domain.com:8080/get.php?username=XXX&password=XXX&type=m3u_plus&output=m3u8|User-agent=Kodi/17.1 (Macintosh; Intel Mac OS X 10_11_6) App_Bitness/64 Version/16.1-Git:2016-04-24-c327c5

…with the output set to your preference, i use m3u8. I wrote an addon for kodi which adds a working user-agent. It downloads the playlist with the m3u8 output, but it should be fairly simple to edit it to get an “ts” output. i should update the addon to allow setting of output. The addon works with my specific provider, don’t know what URL other providers use…:confused:

The addon is now updated to allow selection of output-type in addon settings.

Yes, thanks.

After your update, i changed it to match my providers url. Saved the new file. In PVR addon i choose local file, added the new one, saved, rebooted Kodi. But yet i get the

CDVDDemuxFFmpeg::Open - error probing input format
Error creating demuxer.

iptv_all.m3u

Thats right, right?

I initially got a curl-error when it wouldn’t accept the OSMC user-agent, not a FFMpeg. Are you using the PVR simple client? Have you tried the m3u8 output instead?

Thats the fixed one yes, the addon initally wrote two playlists, one with all channels and one with just the swedish ones. Hence the name “all”. Just haven’t changed it.

Got it, I think, i forgot to add the user agent if it’s an .ts file. I will fix it now.

I try now with the m3u8 output. And see.

Not working, when i press a channel nothing happens and in the logfile it says

21:20:16.716 T:11424  NOTICE: VideoPlayer: Opening: pvr://channels/tv/All channels/pvr.iptvsimple_2072523487.pvr
21:20:16.717 T:10792  NOTICE: Creating InputStream
21:20:16.742 T:10792  NOTICE: Creating Demuxer
21:20:16.743 T:10792   ERROR: CDVDDemuxFFmpeg::Open - error probing input format, pvr://channels/tv/All channels/pvr.iptvsimple_2072523487.pvr
21:20:16.749 T:10792   ERROR: Previous line repeats 9 times.
21:20:16.749 T:10792   ERROR: CVideoPlayer::OpenDemuxStream - Error creating demuxer
21:20:16.749 T:10792  NOTICE: CVideoPlayer::OnExit()
21:20:16.766 T:11424  NOTICE: CVideoPlayer::CloseFile()

I’ve updated the addon in GitHub so it nows add working user-agent if .ts is selected… You could update and try .ts again. If not working then i have no idea what could be wrong.

Have you bought the MPEG2 codec? I should work without it though.

It works now, thanks mate. Disbaled the PVR and enabled it again and it worked, lol. <3

1 Like

I will update It again tonight with the option to set custom provider URL