OSMC RC Update on RPI2 Video/Audio Stattering issue (Only when Subtitles are Enabled)


I’ve been having audio/video stuttering issue when I update the latest OSM RC version (March 14th 2015).

I just reinstall the RC version from scratch restored my kodi backup, and was all working smoothly until I downloaded the latest OSMC update which now causes any video played to stutter (both audio and video) as soon as I start playing the video and when I skip back or forward. The issue only lasts a few seconds and then it is smooth again. It didn’t however happen at all in Alpha4 or on the RC version prior to updating online.

Is this a know issue, is it being addressed on the next release?

Thanks in advance for your replies.

I think it’s a Pi firmware issue that was fixed recently


My description of the issue was incomplete, I added a couple of things on the initial Post.

I should also mention that this only happens when using Hardware Decoding, Softwared decoding doesn’t cause the same issue.

If it is a RPI2 firmware issue on RPi2 why has it only started happening aftert he update. Does the OSMC update change the firmware used?

Please provide debug logs and media info



Forgot to ask, you said it was fixed recently, is that on a pre-released update? WIll I get the fix on the next available update online?


Firmware is maintained by the Raspberry Pi Foundation, hopefully OSMC will release the new firmware soon, probably at the time that Kodi 14.2 is released for OSMC (14.2 was just released by Kodi) Note that this is all speculation and no promises are made

http://paste.osmc.io/ seems to be out of service at the moment.

Also I’m not sure what specific logs file would be useful, or if I just use the log uploader withing the OSMC kodi add-on.

anyway as Dilligaf pointed out it’s probably an RPi2 firmare related issue, surely other people would have experienced the same if that’s the case though.

sorry, but I don’t understand if that’s the case, when I installed OSMC RC everything was working fine. I updated it and the issue started.

Does that mean that the update install a new RPI2 firmware that doesn’t work properly?

sorry for the many question I’m just trying to understand how that would happen.

Looking at history maybe it wasn’t firmware but something in the backports, anyways he fix is coming

Cool, thanks.

I just received an update today 29th March, but the issue is still there.

I’m curious to know if anybody else with Rpi2 that installed RC and has updated osmc online gets the same issue for 3 or 4 seconds when playing or skipping.

I turned update off after installing - experience has shown that updates often cause issues initially so unless something is missing/broken I tend not to update often needless to say I dont have the issue

Well I suppose that’s what i’m gonna have to do. I’ll use another pi to test official release if there is an upgrade path.

This sounds like an issue that snuck into the Kodi branch we use.
Do you use subtitles?
If so, try disabling subtitles and see if the issue is gone.

If this is the case this has already been fixed and will be shipped in the next mediacenter (Kodi) update.

P.S: You will often have available updates as we use Debian APT and have the Jessie source. This doesn´t necessarily mean that OSMC is updating any of it´s packages, it can be something else.
Mediacenter/Kodi has not been updated in a while so that was not what you saw.

1 Like

I do use subtitles, and yes that might be the case, i’ll confirm as soon as I have a chance to test.

Thanks for clarifying.

If it is an issue with kodi, is there a way to downgrade the kodi version without reinstalling osmc RC from scratch?

Thanks again for your help.

At this moment, no. There is only one version available in the repository at the moment.
Remember, you are on RC, things are still being tested.

If you dare you could try my test build from this Friday. I also use subtitles and built my own version to test.
It´s actually not dangerous at all since it uses the same versioning etc. so it will not bork any future upgrades.
And in this case you will be able to downgrade.


Thanks @miappa you’re more familiar with this then I am

Oh, I forgot to mention; I believe this only affects OMXPlayer.
If this is the case (not entirely sure) you can disable OMX acceleration but keep MMAL acceleration enabled.
You do this in Settings>Video>Acceleration.

1 Like

Thanks Miappa, you are exactly right, only when using subtitles the issue occurs.

And you are also right, the issue disappears even when using subtitles if the option “System->Video->Acceleration->Allow hardware acceleration (OMXPlayer)” is turned off.

Thanks a bunch for clearing this up for me.

I suppose I’ll leave OMXPlayer acceleration off until the issue is fixed in the next Kodi update.

great news that your nightlies will be back, @miappa, I’ve always used them successfully for raspbmc. by “this Friday” you actually mean the 3rd of April, right?