OSMC RC wifi problem

I have tried setting up my wifi network (both by terminal and by gui) and it appears to connect but there is not actual connection (it says status: not connected)
It’s a problem with the RC version because with the alpha 4 works perfectly.

When trying to set up by terminal I get this error when typing the ‘connect …’ sentence:
“method connect with signature “” on interface “net.conman.Service” doesn’t exist”

my wifi adapter is edimax
(this one http://www.amazon.com/Edimax-EW-7811Un-150Mbps-Raspberry-Supports/dp/B003MTTJOY)

regards

I had a connection but no internet access. I had to move my rpi much closer to my wifi router before it could get internet access. Much closer than was required when running under raspbmc.

Oh, I see maybe is that… but something needs to be improved then, because as I said before at the same position with the alpha 4 version it works perfectly (also with raspbmc)

I have the internet connection issue with this model as well. It shows “Connected” in My OSMC but when I am streaming I got “playback failed”, switching to wired connection and it works! Do I need to update the driver and how?

Same here. I’m using PiHut wifi adapter on RPI-B
Did new install with Alpha4 about a month ago. Wifi worked first time and has been
working perfect ever since.

Then I did new install last night with RC, and wifi doesn’t come up.
The install went fine, and I didn’t see any errors. OSMC starts up fine, and seems to be ok.
Although, I can’t connect to it, to check :frowning:

I tried complete RC install from scratch twice in case I had put in wrong wireless settings.

But everything was identical. Wifi works perfect with Alpha4, but not at all with RC.
I didn’t try moving closer to my router. Its already pretty close (around 4 meters way in direct line-of-sight)

I will try plugging in ethernet cable, and see if I can connect to it.
If I can do that, and get the wireless going, I’ll be happy.

Otherwise, I would need to go back to Alpha-4, because it’s not much use without wifi.

Thanks.
ps maybe RC is missing driver for this wifi adaptor (but A4 must have had it)

Tried searching? The OP has an Edimax 7811Un which is the same as mine which is referenced in this post

Hi,

I have the same WIFI connection issue on my Pi 2, with an EDIMAX N150 and OSMC RC : Pi2 is connected to the network, but no internet access. I tested with OpenELEC, and WIFI is OK.

I have also another problem : my SSID is not broadcasted, I had to broadcast it to try to connect. On OpenELEC, an hidden network is found, and I can type the SSID name and the passphrase.

How can I help ?

Thanks.

Trying to get my B+ to load the wifi… I have tried the WiPi and the new one that i got which is here http://www.newark.com/adafruit-industries/814/miniature-wifi-module-raspberry/dp/53W6285.

unable to get the adapter to connect to the LAN… Also unable to get the terminal to come up. any ideas would be appreciated.

Is it possible this issue is related to ssh or samba shares? Mine seems to work ok till I ssh or use a samba share then drops out.

Hi,

For me (Pi2 & Dlink DWA-121 802.11n Wireless N 150 Pico Adapter [Realtek RTL8188CUS]) it just drops every now and then (it almost never works for more than an 1 hour). Sometimes is comes back without resetting it.
I’m guessing it has something to do with the signal strenght, which seems a lot much weaker than it was on the alpha 4.
As i explained in other posts, i noticed a small improvement as i get the Pi closer to the wifi router, not stable enough, but a little better. Both the Pi and the wifi router are in the same room, with nothing between them, at approximately 4 meters from each others.
If any logs or tests are required by the dev team, i’ll be glad to help.

Thanks,

Hi,

I updated osmc this morning, and it seems to work a lot better ! =)

I had something strange going on with my Yatse remote (working at boot, but only for 1 minute), i had to re-enable some option in the services configuration menu, but now it works fine.

Thank you so much guys !

We haven’t updated any packages that are related to Wifi yet so I’m afraid your update has only had a placebo effect! :smile: (or the problem is just intermittent…)

However we have a new kernel with wifi driver changes that should address most of the wifi issues people are seeing which will be released soon, along with an RC2. See my post here:

Ahah, i guess i’m a little hasty=)
It was working really fine this morning, i could play a remote file with a high bitrate, which didn’t played well before… but i guess it’s sporadic, because it just lost wifi as i tried to access it through ssh (wich is strange, because i pinged it for 1 hour, and i had only 5% loss, and the second i initiate a ssh connection, it loses wifi).

Thanks anyway for the good news about RC2 !

Yes! I think RC2 fixes it for me =)
No dropouts since almost 12h straight, and the led is blinking (it wasn’t on RC1).

Thank you !

A post was split to a new topic: No Internet on wifi hotspot