OSMC RC3 + PI 2 + Hyperion + Lightberry = Not Working

Hello,
I have a problem with RC3, Hyperion does not work: frowning:
I’m active in the SPI configuration OSMC and I also added the line in the /boot/config.txt file.
I transfer my hyperion.config.json file in the opt / Hyperion / config
Hyperion is installed correctly but the LEDs still do not turn on.
Even with Android application that does not work well when it connects.

Before passing under OSMC, I was on Raspbian + 14.2 Kodi and Hyperion worked fine.

PS: I use a Lightberry 56 Leds

Thank you in advance for your help, I’d really like to stay under OSMC: smile:

EDIT : I forgot to mention, I use a PI 2

I forgot to mention, I use a PI 2

Same configuration with Lightberry HD is working here. I didn’t enable SPI true OSMC Settings (didn’t work) only in config file. If you can’t connect with your APP it seems there is no Hyperion server running yet.

Hello, Android applications (HYPERION AND BOBLIGHT) connect fine (Logs OK) but the LED does not light up.

Same for the SSH command test :frowning:

Help me

Have you done this -> RPI2 + Hyperion + OSMC - #64 by miappa

I would try just add dtparam=spi=on to config.txt. Don’t use OSMC Settings for SPI. Works for me

Thank you for your answer but it’s the first thing I did but and it does not work for me …

Did you run this Lightberry setup before already or is it new (never used befor

If you want, I can send you my config files. Maybe there is something wrong in your files.
Alternatively you can download a preconfigured image (Lightberry) from lightberry and try out if your hardware is working at all. I never installed them myself, coz for me it was working always with OSMC.

Hello,

I use it successfully on lightberry Raspbian + Hyperion.
Thank you, but my configuration file and functional well

I can even OpenELEC with no problem but it is OSMC I want to use.

I despair …

May I ask why not?

Once I used OSMC Settings to enable SPI and it stopped working for me. After I switched it off again in OSMC Settings, it started working again. Maybe it’s just with my installation. I didn’t mean don’t use it in general. Just trying to help with my own expierience.
I guess it’s not a good idea to use OSMC Settings to enable SPI when dtparam=spi=on is already written inside config.txt

That won’t cause any problems

Sam

my fichier config.txt (pi2)

gpu_mem_1024=256
dtoverlay=spi-bcm2835-overlay
dtparam=spi=on
start_x=1
sdtv_aspect=1
disable_overscan=1
hdmi_ignore_cec_init=1

I tested with the deactivated option in OSMC but with this config file, but also without success

@jofrenchy try running these install commands mate let me know how you get on :smile: https://github.com/tvdzwan/hyperion/wiki/installation don’t worry about the spi part

Good evening; thank you for your reply.
It is exactly with what I initially installed.
Still, I repeated the handling but it changes nothing.

At the end of the installation I get it but that does not seem to be the case because under raspian I had the same thing

Installing startup script in init.d
insserv: warning: script 'K01hyperion' missing LSB tags and overrides
insserv: warning: script 'hyperion' missing LSB tags and overrides

the following command

hyperion 50-remote --priority --color red --duration 5000

give this

osmc@osmc:~$ hyperion-remote --priority 50 --color red --duration 5000
Connected to localhost:19444
Set color to 255 0 0

But the LED still does not light …
I do not understand because under Raspbian or Openelc it works without problems.

Check the following setting -> Go to System/settings/services/remote control/ and enable both option in there. This will allow hyperion to remote control kodi. Maybe this it the issue.

Hello,

Thank you for your message but it was already done without success.

But, I have resolved my problem, yes yes

I start a new installation to SD
I installed Hyperion (as before)
I add the line in the file confix.txt
I have not checked in SPI OSMC

And there, it worked the first time.

Thank you has atous for your help, I’ll finally discover OSMC filled with Lightberry

Ok I see. Just as I told you :smile:
Happy you solve your issue.

Thank you :slight_smile:

Hello,

Today I updated OSMC and Hyperion stopped working :frowning:

SPI is always activated in the config.txt file.
If I OSMC active in the menu that does not change even after a reboot.

What set apart reinstall everything?

Here log

Thank you

root@osmc:~# sudo /usr/bin/hyperiond /etc/hyperion.config.json
Application build time: Mar  6 2015 20:57:44
QCoreApplication initialised
Selected configuration file: /etc/hyperion.config.json
ColorTransform 'default' => [0; 53]
Device configuration:
{
        "colorOrder" : "rgb",
        "name" : "MyPi",
        "output" : "/dev/spidev0.0",
        "rate" : 1000000,
        "type" : "lightberry"
}

Failed to open device('/dev/spidev0.0')
Black border threshold set to 0.01 (3)
Creating linear smoothing
Created linear-smoothing(interval_ms=50;settlingTime_ms=200;updateDelay=0
Effect loaded: Knight rider
Effect loaded: Blue mood blobs
Effect loaded: Cold mood blobs
Effect loaded: Full color mood blobs
Effect loaded: Green mood blobs
Effect loaded: Red mood blobs
Effect loaded: Warm mood blobs
Effect loaded: Rainbow mood
Effect loaded: Rainbow swirl fast
Effect loaded: Rainbow swirl
Effect loaded: Snake
Effect loaded: Strobe blue
Effect loaded: Strobe Raspbmc
Effect loaded: Strobe white
Initializing Python interpreter
Hyperion created and initialised
run effect Rainbow swirl fast on channel 0
Boot sequence(Rainbow swirl fast) created and started
XBMC video checker created and started
Display opened with resolution: 1920x1080
Frame grabber created and started
terminate called after throwing an instance of 'std::runtime_error'
  what():  Json server could not bind to port

manually update OSMC and it should work again …